Previous 1 2 Next 15 Replies Latest reply: Aug 28, 2008 12:29 PM by Jason L
Tasuki Level 1 Level 1 (0 points)
So on the way home today, I had just selected an app from the app store for installation when my iPhone 3G went black, loaded the apple logo and then automatically got stuck on the "connect to iTunes" screen.

I came home, connected it to iTunes and it told me that the iPhone was in recovery mode and that I must restore it. So I did that and when the process was done, I received the following error:

"The iPhone 'iPhone' could not be restored. An unknown error occurred (9)."

Now every time I try to restore it, it hangs at "Waiting for iPhone..."

Does anyone know what error 9 is? All the Apple stores here are booked and I'm going out of town tomorrow night so I won't be able to get to one until Thursday at the earliest. I'm also expecting some important phone calls, so I'm pretty ****** off that this happened so suddenly.

Powerbook G4, Mac OS X (10.4.8)
  • Tasuki Level 1 Level 1 (0 points)
    Just an update for anyone who's curious; I spent about an hour and a half on the phone with Apple, talked to a normal rep and a specialist and neither one ever heard of this happening before. We tried a lot of different things to restore my iPhone and absolutely none of them worked.

    I was told at the end of the conversation that it might be the SIM card causing the problem but I don't believe that at all; it shouldn't matter what SIM card I have in the iPhone, if it worked properly before, there's no reason for it to not work properly now. :P Anyway, it seems mostly like it's a hardware issue so I'm going to go into a Rogers store sometime today and try to get it replaced.
  • funny_guy Level 1 Level 1 (0 points)
    It happened to me when I tried upgrading my firmware from 2.0 to 2.0.1. Then, I removed the dock and connected iPhone directly to cable. It resolved the issue.
  • ManateeMac Level 1 Level 1 (5 points)
    I got an Error 9 when trying to do a Restore. After turning my stuck iPhone on and off several time by holding down the two buttons, and plugging and unplugging from the computer while holding down the front button on the iPhone, I finally got the screen with the arrow and "iTunes" on the iPhone. Then it did a clean Restore. This was after not being able to get iTunes to see the stuck iPhone at all for more than a day.

    Good luck.
  • Tasuki Level 1 Level 1 (0 points)
    I wasn't using any dock; just the cable that came with the iPhone.
  • Tasuki Level 1 Level 1 (0 points)
    There wasn't any problem with iTunes recognizing the iPhone; it would start the recovery process and hang at the "waiting for iPhone" screen. There's only been two instances where it's gotten past that and actually started the recovery process... but it'd get interrupted and I'd get unknown error (9).
  • theminhb Level 1 Level 1 (0 points)
    I just got prompted to do the 2.0.1 update, and did. Im in the same situation. Cant restore. Unknown (9) Phone worked fine before.

    Cant get the phone to do anything. Stuck. Tried restoring 5 times now. Hope to hear a fix.
  • simpson_aj Level 1 Level 1 (0 points)
    I've been having the same problem, was updating to 2.0.1 using the dock and it failed halfway through, after that the iphone wouldn't restore. tried rebooting, restarting itunes, resetting iphone, in the end i simply removed it from the dock and plugged the cable in to the iphone and it worked first time.

    really odd, but i'm glad its working!
  • Tasuki Level 1 Level 1 (0 points)
    Unfortunately, there's been absolutely nothing that I can do to fix this problem. The specialist I talked to said that using my old SIM card could likely be the problem but after getting the new SIM card that came with the iPhone activated, I still had no success trying to restore it.

    At this point, I'm just going to go into an Apple store and see if I can get a replacement.
  • Ah M Bas Level 1 Level 1 (0 points)
    I had the same problem. I tried a different USB port on the computer, and it worked. Apple is beginning to become a little more frustrating than I had wanted to be...

    After the restore, nothing is on my iphone. It was trying to restore the iPhone, from a backup I did a few days ago, and its stopped. NOW I have to re-SYNC all the information, music, movies, apps, and contacts....

    This was my first iPhone (the 3g model) and I thought the update process would be painless and streamlined...doesn't look like it from what I see on this forum, other blogs, and my personal experience.

    Message was edited by: Ah M Bas
  • Alias Not Available Level 1 Level 1 (0 points)
    My sympathies to you. I just bought the thing yesterday, took it home to sync on iTunes and got error 9. I've tried everything mentioned on here and more, but nothing has worked. I took the phone back to the store and they told me I would have to call tech support back and get them to send me a new iPhone by UPS. What if the new one does the same thing due to an unidentified settings issue on my computer or something? Well, at least I didn't have it long enough to be expecting any important phone calls!
  • TeXeL Level 1 Level 1 (0 points)
    I had a similar issue. I installed iTunes just yesterday and connected the phone. During the firmware update it seemed to loose connection to my PC and reconnect several times. I just figured it was doing that because of the firmware updating but then it failed with error 9. I then tried a restore because the phone was unusable and got error 9 while trying to restore.
    (I should note the iPhone is directly connected to PC USB 2.0 port)

    Contacted both my Wireless Carrier and Apple and both told me the same thing. Uninstall iTunes, QuickTime, Apple Mobile APP, and the Apple Software Update, reboot pc and reinstall which I did. After that same issue.

    I was advised to take the phone to a local Apple Store and they would fix it on the spot or replace it on the spot which I was going to do.

    After doing some research I found out this error 9 issue is caused by the PC USB port. I install iTunes on another PC and had no issue restoring the phone, all is perfect now.

    Then I reconnected the phone to my original PC and noticed it seems to be conflicting with other USB devices. What I've found is if I remove all other USB devices (except keyboard & mouse) and reboot PC with the iPhone still connected it works fine. Kind of a pain but I seemed to narrow the issue down.

    Not sure if this will help anyone else but try it and post to let me know please. I'm hoping they can fix this because its rather annoying to have to disconnect all other USB devices and reboot every time I want to update something.
  • ibennetch Level 1 Level 1 (5 points)
    TeXeL, this is similar to the conclusion I've reached except even when my iPhone is the only USB device on my PC I still get the error. Since the phone works fine on my iBook, I blame the PC's USB chipset. It's annoying since my music library is on the PC and there's no easy way to bring it over to the iBook while maintaining my playlists and star structure, but at least it doesn't seem like my phone is broken.

    I plan to add an add-on USB controller to see if that improves the situation -- currently I've only got the onboard USB which seems to have similar issues with other USB 2.0 devices (like my external hard drive).

    I hope this information helps you.
  • KevinT Level 1 Level 1 (125 points)
    I had the same error when I attempted the update to version 2.0.2. I was connected via a USB port on my Dell monitor. I moved the computer to the front USB port on my PowerMac G5 and the issue did not occur again.
  • strydi Level 1 Level 1 (0 points)
    I use a Dell laptop for business, and on my trip last week I went to update my iPhone to 2.0.2 and had this happen. I tried for a day and a half to restore, but it continued to time out.

    I found absolutely no way to fix this. If you get this error, use a Mac to restore it instead. Apparently its faulty USB drivers on PC/Windows which causes it.

    Since I did not have my MBP with me, I went to an Apple store where they restored it on a MacBook and everything worked fine. Of course I had no way to get my data back, but I didn't lose much (other than web clips, a few random photos) since I'm all synced up to MobileMe.

    I think this thread can likely be closed unless Apple has some light to shed on the Unknown Error 9 -- which it sounds like they need to fix for Windows users.
Previous 1 2 Next