14 Replies Latest reply: Nov 2, 2008 7:33 AM by dillera
macbuddy89 Level 1 (0 points)
I have been all over the internet trying to fix this problem. I have tried manually setting up my gmail account and using the default settings. Once I type in my password and hit "save" it instantly tells me that it can't connect using ssl...i have tried the method of clicking "yes" and "no" and still can't connect to the server. I have deleted and re-entered my email info a dozen times, restored the iphone, switched passwords online for my account. I'm going crazy. is anyone else having these problems?

black 16 gb iphone 3g, Mac OS X (10.5.1)
  • HamOnRye Level 1 (15 points)
    Two things to try.

    1. Make sure IMAP is enabled for your gmail account. Log in to gmail, click on settings in the top right, click on Forwarding and POP/IMAP, click Enable IMAP and Save Changes.

    2. Sometimes Gmail just needs a kick in the pants. Go to http://www.google.com/accounts/DisplayUnlockCaptcha type in your gmail username and password and the letters from the image, click unlock. That resets some sort of account verification info (doesn't change your password or anything).
  • dlswoosh5 Level 1 (45 points)
    I was getting a "Can't connect using SSL" error message when setting up my gmail account. This solution seemed to work:

    Logon to your GMail account (using computer).
    Go to "Settings"
    "General" tab
    Scroll down to "Browser Connection" and check "Don't always use HTTPS"
    Save settings.

    Then setup your gmail account on your iphone.

    Hope this helps.
  • Nylz Level 1 (0 points)
    Just wanted to say that the kick-in-the-pants-approach did the trick perfectly.
  • TonyM Level 1 (145 points)
    There seems to be circumstantial/unofficial issue with email ssl connections. Just waiting a little while and trying again, possibly again, and again . . . . so on . . . solves the problem. Once the account is setup and running you are bound to get an error about not being able to connect via ssl . . . I thought it had something to do with switching radios (edge, 3g, wifi), but I don't think so anymore. I spent a lot of today creating iphone documentation for my dept, about 5 restores later, and this happened 4 times across 3 different email account setups (one being gmail).

    Good luck. This can be frustrating. I think after the third try (if you let it time out that many times) it actually lets you save the setup even though it couldn't verify the ssl connection.
  • NeilB Level 1 (60 points)
    I'm having the same problem as the original poster. I've tried all of the suggestions here but none of them have helped. And FWIW, all the while, my wife's iPhone is checking her Gmail without a hitch.

    Any other tips would be most appreciated.

    Is there some way to "trash the prefs" of the iPhone's Mail app?

  • TonyM Level 1 (145 points)
    Have you tried restarting the phone or force quiting mail? (launch mail and then hold the home button down until the app quits).

    As for resetting prefs, under settings--> general--> reset look at the options.
  • NeilB Level 1 (60 points)
    Thanks TonyM!

    As it turns out, restarting the "phone" did the trick. Though that would have been a solution I would have tried early if I'd been on a Mac, it didn't occur to me to try that with the phone. I'm still getting used to this thing being a computer with the ability to make phone calls.

    As for the force quitting and resetting options, thank you as well... I didn't know how to do either of these things so your tips are good to know.

  • orangeburg Level 1 (0 points)
    thank you so much!!!!

    i spent 3 hours on the phone with cingular and apple and no one could figure out the ssl problem

    but this website worked ( http://www.google.com/accounts/DisplayUnlockCaptcha )

    thank you!!!!
  • robertklein Level 1 (0 points)
    i spent 3 hours fixing it.....andu fixed it...Go Unlocking Captcha!

  • chococo Level 1 (0 points)
    I was almost gettin' crazy after trying to set up an account 30 times vainly

    UnlockCaptcha did solve all of the problem!

    thank you!
  • The Big Walleye Level 1 (0 points)
    this works for sure!!!!

    To configure IMAP for your iPhone, just watch our video or follow these steps:

    Enable IMAP in your Gmail settings.
    Tap Settings.
    Tap Mail.
    Tap Add Account.
    Tap Other. (Note: If you're running software update 1.1.3 or later, tapping the 'Gmail' icon will automatically configure IMAP. However, archiving and deleting messages will work differently. If you want your Gmail IMAP actions to operate as designed, please continue on to the next step.

    Make sure that:
    The IMAP tab is highlighted
    Host Name is imap.gmail.com
    User Name is your full Gmail address, including '@gmail.com.' Google Apps users, enter your full address in the format 'username@your_domain.com'

    For Outgoing Mail Server (SMTP), Host Name is smtp.gmail.com

    Tap Save.
    Check our recommended client settings, and adjust your client's settings as needed.
    And you're done. You can verify your Advanced settings by tapping Settings > [your Gmail IMAP Account] > Advanced.

    Incoming Settings
    Use SSL: ON
    Authentication: password
    Server Port: 993

    Outgoing Settings
    Use SSL: ON
    Authentication: Password
    Server Port: 587

    Now that your account is set up, learn
  • NeilB Level 1 (60 points)
    The Big Walleye wrote:
    this works for sure!!!!

    Nope, that doesn't work for sure. Plus, if it did, there wouldn't be so many people posting here with this problem as the info you posted is easily available at Gmail's help site.

    As for me, I'm having to re-make my iPhone's email accounts as IMAP ones (with delete on iPhone = archive at Gmail), and so far I'm back at square one. The "Unlock Captcha" trick isn't working and neither is restarting the phone. The only IMAP email setup that did seem to work was the "delete on iPhone = Trash at Gmail" one, but that is not how I need it to function. And on top of that, trying to re-make that setup isn't working now either (the iPhone endlessly tries to sync with my Gmail via IMAP but doesn't show the message that I can see are there using my PowerBook's Mail app checking Gmail via IMAP too.)

    Any other suggestions?

  • ClintDiesel Level 1 (0 points)
    I have tried everything here, but it still will not connect. I have been using IMAP with my gmail account on my computer for quite some time now, so I know the IMAP works, just not on the iPhone. One of the reasons i bought an iPhone was the idea of mail on the go, but so much for that...
  • dillera Level 1 (0 points)
    One more data point for the kick in the pants... it worked for me. My wife just got a 3G last night and it wouldn't connect to gmail (same as other are reporting in this thread). I already had IMAP enabled on her gmail acct and was getting pretty frustrated. After reading this thread I pulled up the http://www.google.com/accounts/DisplayUnlockCaptcha page and had my wife fill it out-- and the iPhone connected instantly.

    Thanks for the link! I wish Google had a pointer to this somewhere.