Previous 1 43 44 45 46 47 48 Next 718 Replies Latest reply: Apr 15, 2010 12:07 AM by JJ Decker Go to original post
  • kingmo Level 1 Level 1 (0 points)
    Same problem here. Had the iPhone for about 3 weeks now, have downloaded about 16 free and paid 3rd-party apps (about 1 addition screen's worth). iPHone started getting glitchy 2 days ago, couldn't sustain a call for more than 3-5 seconds. Hard reboot corrected that situation. Now the 3rd party apps don't work (e.g. Facebook, Free RSS, Banner, etc.). They just start booting up, and then stop, and I return to the Home screen. Very frustrating, and not awe-inspiring. All my initial amazement has faded to "here we go again"
  • Loren Ryter Level 2 Level 2 (495 points)
    You did not say whether you updated the Firmware to 2.1 and iTunes to 8.x
  • linux courting mac Level 1 Level 1 (0 points)
    I had similar problem of purchased apps splash screen only, then dieing (though iTunes 8). When I was syncing the iPhone with iTunes, I noticed an error message about "Purchased Apps not authorized on my computer." Message recommended going to Store-> Authorize Computer in iTunes menu. I authorized computer, turned iPhone off, then on, and did a manual resync, and all apps are working. (not sure if turning iPhone off and on was necessary)
  • JiPs718 Level 1 Level 1 (0 points)
    Thanks a bunch for your help, this definitely worked for me on the first try!!! Kudos to you!!!
  • Williss Level 1 Level 1 (0 points)
    I have 3 apps downloaded and they have worked fine for about a week. Tonight I was trying to access one of them and all I get is a black screen and then the home screen.
    Any help appreciated.
  • cabie Level 1 Level 1 (0 points)
    I had this exact same problem for several months now and I don't know whether or not this solution has been brought up yet (I have yet to go through the many posts so sorry if it has) but I was able to fix this on my iPhone without any restoring (I have the updated iTunes & firmware though):

    1. Sync iPhone
    2. Do not disconnect iPhone from computer
    3. Go to the App Store on your iPhone & update each app separately

    Doing this works perfectly for me although for heavy-app users it may still be a little tiring but it's a lot easier than reinstalling anything. Let me know if this works for any of you!
  • ipitts Level 1 Level 1 (0 points)
    I just bought a phone a week ago and downloaded a few apps, this same thing happened with it. All downloaded apps appeared momentarily and then closed. I deleted one free app then reintalled it - all the apps worked. I thought Apple was supposed to be relatively bug-free. Guess not.
  • Rasterstudios Level 1 Level 1 (0 points)
    Hi guys,

    I bought this iphone on 2009 January and installed dozenz of free apps and payed apps.But for the past 1 wk all my apps are not working and it simply crashes and goes to the home screen. I am having 2.2 version of iphone firmware. I heard this as a known issue. Do you guys know any fixes for this? Please help me in this regards
  • QAPete Level 1 Level 1 (0 points)
    Obviously, from the size of this thread and a quick Google search, this is a huge issue for a lot of people.

    I have had my 3rd-party apps crash fairly often, especially after powering down the phone (not just putting it to "sleep").

    Every time this has happened, I've simply deleted a free 3rd-party app from my phone, then gone to the app store and download/reinstall it. Bingo: all 3rd party apps are working again.

    While this is very Microsoftish of Apple to have let this problem exist for so long (months), at least there's a quick repair.
  • digitsu Level 1 Level 1 (0 points)
    No need to reinstall / redownload all the apps. I guess apple fixed this in the latest firmware update, or itunes, but things are not as bad as the problems people had when this mail chain began.

    It seems to do with the authentication with itunes that each downloaded app does upon loading. To fix all your apps, just download a NEW app (a free one is good) authenticate with itunes upon download, then all the other apps will start working again.

    Something seems to get flubbed with the itunes authenticate when you switch between computers for the iphone sync.
  • zulite Level 1 Level 1 (0 points)
    If you go into Itunes and under the "store" tab - Reauthorize your computer then resync the iphone - should clear it up after the sync is over. I did this for mine and a message appeared saying the computer was already authorized, but after authorizing and resyncing - it go my apps back.
  • jax200 Level 1 Level 1 (0 points)
    My quick fix:

    1. Deleted a non-responsive free app.
    2. Re-installed it.

    Everything worked. I think iTunes is indeed the culprit, but have not verified as yet.
  • amir_Iran Level 1 Level 1 (0 points)
    you're star dude, that solved my issue

    Thank you so much!
  • lv-avi8tor Level 1 Level 1 (0 points)
    This works!! I "deauthorized" my PC ... then "Authorized" it ...and then synced the iPhone.

    Thank you!!
  • jrooney Level 1 Level 1 (0 points)
    same problem. Anyone know if Apple is working on a fix?