Previous 1 2 3 4 Next 56 Replies Latest reply: Aug 26, 2008 5:25 AM by eccparis Go to original post
  • Dave McGuire1 Level 1 Level 1 (35 points)
    After spending a considerable amount of time on the phone, I got transferred to an engineer. She thinks I'm going to have to send it in, unfortunately. (Right now, I'm trying the "erase all content and settings" option as a last resort.)

    I hope you folks have better luck than I've had. Three hours on the phone and back to square one.
  • jsebooth Level 1 Level 1 (0 points)
    Although I'm quite skeptical. I'm trying "Erase All Content and Settings" as well. I would've thought a fresh restore would do the equivalent of that but maybe not. It says it will take a long time so I'll post result an ~1 hour.
  • jsebooth Level 1 Level 1 (0 points)
    update: "Erase All Content and Settings" does NOT solve the wifi issue so don't waste your time.

    so I've now confirmed that...
    1. Complete new, clean restores (using fresh 2.0.1 updates) does not solve the problem.
    2. The various "Erase/Reset" options in the iphone settings do not fix the problem.
    3. And, of course, shutdown and restart of iphone does not fix the problem.

    Additionally, it appears that I cannot access voicemail (voicemail button not working) and my phone is not ringing when people call (yes i've checked the settings).
  • DrThisGuy Level 1 Level 1 (0 points)
    I'm in the exact same boat and have tried everything 3x over. I could handle not BT or wifi for a little bit until a fix is figured out but I cant have my phone not ringing when people call. One thing I also noticed is that I sometimes dont get voicemails until hours later. I have a 5pm appointment with a genius today as I don't think this problem is so wide spread that there will be another update to fix it and even if there was, I don't think it will be out any time soon
  • jsebooth Level 1 Level 1 (0 points)
    update: Apple is sending me a replacement. I agree that this appears to be a real problem directly linked to updating the firmware and that it is not a freak accident, but the incidence appears to be too low for us to expect another firmware fix in the near future.

    Oh yea. Additionally, my iphone battery seems to be running out far more rapidly than it did before and I'm not using it nearly as much. Just adding another problem onto the list.

    Good luck to those experiencing the same problems.
  • dfury7 Level 1 Level 1 (0 points)
    Do you have to ship your old one back first? How much fighting did you have to go through to get a replacement? Have you used the original one for long?
  • geauxracerx Level 1 Level 1 (135 points)
    To fix this issue go into settings then the wifi network. Tap the little blue arow by the network name the screen will shift to the right. Scroll to the botom turn on automatic wait for all the fields to load up then press the home button. Your wifi should be working now. I had this issue on my fiance'e's 1st gen
  • Frank Marks Level 1 Level 1 (0 points)
    Thanks for your advice geauxracerx but in my situation there is no blue arrow. To the left the WiFi icon is greyed out and where there should be the arrow (or a switch) there are only the words "No Wi-Fi" I have a photo of it but I do not see how I can upload a photo on this page.
  • fatgin Level 1 Level 1 (0 points)
    I'm having the same problems with wifi and bluetooth as well as the battery problems, and the phone not ringing when I receive calls. But I have 2 more to add. My time seems to jump around. Sometimes it is the right time, sometimes it is 2 hours off. Sometimes it jumps an hour while I'm looking at it. Also, if I try to run any app from the app store, it just crashes right away and I go back to the home screen.

    I spoke to a representative and he said that I have to take it to the store. I have a genius appointment tomorrow night. He said they will try to fix it and if they can't, they will probably give me a new phone. After seeing jsebooth's post, I'm guessing I will be getting a new phone tomorrow....or at least be on the waiting list for one....again.
  • geauxracerx Level 1 Level 1 (135 points)
    Send the photo to your email then upload to a site like photobucket then just copy the url and paste it here
  • dfury7 Level 1 Level 1 (0 points)
    Hey guys,

    I spoke with Rogers and they escalated the situation and will be shipping me a new I Phone 3G. They think that something during the update process to 2.0.1 corrupted the phone internally. They have no idea how to fix it and rather than waste my time they are sending a new phone via UPS and I should have it within 48 hours. THis makes me very nervous about updating my I Phone software in the future!
  • geauxracerx Level 1 Level 1 (135 points)
    call your service provider. Had to do this with my fiancées 1st gen.
    She was getting no data signals
  • geauxracerx Level 1 Level 1 (135 points)
    Also you can force iTunes to restore an older firmware by hold the
    Shift key down and clicking restore. iTunes will open a box and ask
    Which firmware file you want. You can find the older firmware if you
    Do a google search for it. Save it to your desktop
    Then navigate to it in the box that pops up after you hold the shift
    Key and click restore. If you have a 1st gen you will need to search for iphone1,22.0_5A347Restore.ipsw
    If you have the 3G then you need iphone2,xxxxxx blah
    Hope you get it.
    There are different firmwares for the diff phones
  • Dave McGuire1 Level 1 Level 1 (35 points)
    As others have noted, erasing everything hasn't worked. The engineer at Apple called me again today and asked me to look at the menu Settings > General > About > Wi-Fi Address. When I told her that it read "N/A" she said my phone had to be sent in for repair or replacement.
  • JBrunr Level 1 Level 1 (0 points)
    This morning I updated for 2 day old iphone to the 2.0.1 software. This resulted firstly in a bricked phone, which was then finally revived with the help of apple support by a hard reset. After the reset I then had the greyed-out wifi or no more wifi capability; according to my carrier Rogers, this cannot be fixed so they are sending me a replacement iphone. What a crap day!