Previous 1 2 3 4 Next 58 Replies Latest reply: Aug 9, 2008 3:29 AM by Peter Mergaerts Go to original post
  • H@nk Level 1 (0 points)

    I tried the 2.0.1 update and it hosed my iPhone. I tried again and got an error. Tried again and got the same error. I thought I was destined for a trip to the Apple store. Finally, I unplugged my iPhone USB cable from the back of my iMac and plugged it instead into the Keyboard USB 2.0 port. This time the update proceeding correctly. Once done, it restored my iPhone data without problem.

    Hope this helps!
  • Cellguy Level 1 (0 points)
    Same here. Did the 2.01 updadate, got the error 6, tried to do a restore, same error. Now I'm trying the update from above but dosn't look promising. Been "updateing" for about an hour or so. Anyone find any other way of getting their phone working again? Havne't tried calling AT&T yet, would that just be an exercise in futility?
  • dshannon Level 1 (0 points)
    I'm having the exact same problem. Have tried everything. Very annoyed at this point. I guess I have to go to the apple store on lunch tomorrow (SO frustrating). It was working fine - that'll teach me to go and do an update! ARGH.
  • Michaelworks Level 3 (695 points)

    Read about update issues and help
  • Marcel Beek Level 1 (0 points)
    3AM (Amsterdam time) I fixed my iPhone3G that gave me the 1604 error by using the iPhone SDK xcode. You can restore your iPhone with the SDK I think the SDK has a longer time-out... I put the iPhone in DFU mode but that didn't work 100% so I tried the normal restore (usb icon with itunes logo) it takes a long time so for all the steps so be patient! Good luck fixing your iPhone in xcode!
  • BigV Level 1 (0 points)
    Apple..i have to say im deeply disappointed. I loved my iphone when i got it and now im back to using my 3 year old sony ericsson! talk about reliability!! the bloody thing hasent last me even a month!! The amount of pain and money this useless update (2.0.1) has cost me is unimaginable. Im putting a "sell" recomendation on your stock!!
  • musa91620 Level 1 (0 points)
    All this sounds really bad. You have not found some sort of workaround to restoring? I we can't restore, then I will not go to 2.0.1 until it is sure. Why though are some people ok? What does it depend on? Can you send it to Apple for a new one?
  • GFD613 Level 1 (0 points)
    I am in suburban NYC. Late this evening, I opened iTunes (I always open iTunes before I dock my phone or pod so that I can download my latest podcasts and avoid having to sync twice). I received the prompt to update iTunes, which I did.
    I docked the phone and was automatically informed 2.0.1 was available. I just upgraded the phone, and all seems quite fine and normal.

    My thoughts:

    1. Always check for an update to iTunes before accepting any iPod or iPhone update. Make sure you have the latest version of iTunes before updating your device.

    2. Resist the temptation to click on the "check for updates" button for your device. Wait for iTunes to offer the update to you. Why? To make sure the latest version of itunes has been released first.

    Hope that helps anyone who hasn't done the update yet.
  • Just Be Level 1 (0 points)
    Me too, I have you able to go back to 2.0????

    Angela Hernandez-Weyne
  • danomack Level 1 (0 points)
    I had the same problem with 2.0.1 - on both the 3G AND the touch. With the touch it was restore errors 1604 a few times, 1602 a couple times, and with the phone it was 2 (I think)... anyway, this page helped a ton:

    For me (this is in XP Pro) it was a matter of doing a complete uninstall and re-install of all Apple programs, choosing a new USB port (one in particular seems to work for this problem, God knows why), and creating a new user. I would do the following - and it worked for both the touch and the phone:

    1. plug phone into USB and put it in restore mode (hold down the home and sleep/wake buttons until the apple logo appeared (about 10 sec.) - the connector/itunes image will appear
    2. log into new user, and itunes would start immediately and tell you to restore your unit
    3. start restore/update process
    4. process fails (predictably, for me anyway) - 'unable to restore, yada yada'
    5. unplug unit and restart computer
    6. log into same new user
    7. put phone in restore mode and plug it in. If iTunes starts, close it. (Mine never started at this point).
    8. navigate to the up to the Software Updates folder (i.e. c:\\documents and settings\[user name]\application data\apple computer\itunes\iphone software updates\) and choose the new firmware file (iPhone1,22.0.1_5B108Restore.ipsw in this case - you will have downloaded it during the previous failed restore attempt).
    9. double click on it
    8.iTunes will start and give you dialog boxes - agree to everything
    10. try not to look - water and watched pot and all that.

    The first time I did this (on the iPod touch) I wasn't expecting it to work so I went and had a shower. I came back and was just finishing up - 2.0.1 on the touch. I celebrated. By myself - it was a sad moment, but I had restored the touch to factory settings (1.5) about 10 or 15 times trying to get the new firmware. So when my 3G bricked (I had to try the upgrade just straight up), I immediately went to the user I had created for the touch and repeated the steps that had worked for it. Bingo dingo, 2.0.1 on the 3G.

    I have no idea if this will work for any of you, but I sure hope so.

    Message was edited by: danomack
  • BigV Level 1 (0 points)
    Hi, thanks for the all the help guys but nothing seems to be working. Guess i'll be heading down to the apple store tom morning. I have a strong feeling i'll be getting a new replacement phone (but not tom..cause that would make life too easy right!!).
  • jmpainter Level 1 (0 points)
    Mine was doing the same "Unkown Error Occurred (6)".

    I deleted the iPhone update and Downloaded it again. Fixed it.
  • BigV Level 1 (0 points)
    guys..went to the store the guy tried every trick under the sun! it didnt work..they just gave me a new replacement phone! error 1604 cannot be fixed. Take it down to the store and get a new phone.
  • Peter Mergaerts Level 1 (10 points)
    Well, that's what I did, back to the Mobistar shop here in Belgium. I need to wait 2-3 weeks (!!!) to get a fixed or replacement phone they told me. Yep 2-3 weeks, I only had my phone 2.5 week. Meanwhile the subscription needs to be paid of course... GRMBL
Previous 1 2 3 4 Next