4 Replies Latest reply: Sep 7, 2008 3:31 PM by drsailer
nanoftwo Level 1 Level 1 (0 points)
I receive emails alright, but occasionally receive a message stating that the contents of the email did not download from the server. Sometimes, I actually receive the contents of the email and when I check it later, I get the message that it was not downloaded. There does not seem to be any rhyme or reason and I have no idea how to fix it. Anybody else have this problem? Thanks for any help.

HP, Windows Vista
  • Michael Marshall1 Level 1 Level 1 (5 points)
    I am having the same problem. I noticed no one replied to your post. Did you ever figure out the problem. I would like to know how to fix this problem. Can you post a reply here
  • Texarado Level 1 Level 1 (0 points)
    I, too, experience this problem. So far, it only affects my primary e-mail account. (Our company's "info@______" account works fine, displaying its incoming messages' contents. All of the settings appear to be identical.)
  • murrdog Level 1 Level 1 (0 points)
    I have this exact same issue. What's the deal???? I'm ready to take the phone back for a refund.
  • drsailer Level 4 Level 4 (1,495 points)
    When this occurs, it's normally with a pop account. When another device, like your home computer, retrieves the message, it's no longer available on the server for the iPhone to retrieve. The iPhone does not retrieve the entire email until you open it. If the email is removed from the server by another device, the iPhone still has the email header, but cannot download the content from the pop server. This happens even if you've viewed the email in the past.

    Best way to fix: get an imap account, or set up your email as imap, if that is an option. I switched to imap over a year ago (original iPhone) and haven't seen that message since. Gmail is free and works well as imap, MobileMe is not free, but does work well. There are other options out there, also.