6 Replies Latest reply: Aug 7, 2008 7:18 AM by covhill
covhill Level 1 (10 points)
I received my Mac Pro yesterday and it won't let me access the second drive.
When I click on the icon it gives me the message, "The folder can not be opened because you do not have sufficient access privileges." (The icon has a little lock on it.)

When I do a "get info" on this drive, it won't let me change the access. I unlock the lock icon but it stays on "custom" no matter what I do.

help!

oh and I also want to mention that when I go into System Prefs -> Accounts on my main drive, the "Allow user to administer this computer" is always grayed out, even when I unlock it to make changes.

Message was edited by: covhill

Mac Pro 3.2 Quad, Mac OS X (10.5.4)
  • Korben Dallas Level 1 (5 points)
    At the very bottom of that window, is there an "Ignore Ownership on this drive." checkbox. You'll want to choose this.
  • covhill Level 1 (10 points)
    I tried that before but it made no difference. I still can't change my access priviledges from "custom".
  • The hatter Level 9 (60,930 points)
    Take a look at BatCHMOD
    http://www.macupdate.com

    Did you "Apply to enclosed items"?
    Did you add your userid name to list?
  • covhill Level 1 (10 points)
    BatCHMOD looks like it could help but there must be a way of getting around this without an add-on?

    It must be something simple that I'm missing.

    --Did you "Apply to enclosed items"? --

    It doesn't give me this option under the gear icon. Perhaps because there's nothing to apply as it doesn't allow me to change the privileges in the "get info" window.

    --Did you add your userid name to list? --

    I'm not sure what you mean by this?
    ..

    Just to be clear again - this hard drive icon has a lock on the bottom left corner. It won't even let me change the label color of this icon as everything is locked.
  • The hatter Level 9 (60,930 points)
    Batchmod you simply drop a folder or drive icon on. It isn't an add-on. And it is easier to use than the terminal to change ownership flags.

    But it sounds like someone with root privilege messed things up royally. And that you can't use superuser.

    If you unlock the ownership permissions, you see a list of system, root, guest, shortusername(s) and click "+" to ADD a USER.

    Any changes you do make, you also need to apply to enclosed sub directories.
  • covhill Level 1 (10 points)
    Thanks a lot for your help.

    But now that's become the least of my problems.

    posting a new thread...