11 Replies Latest reply: Oct 6, 2008 10:02 PM by Freida
SegmentFault Level 1 Level 1 (0 points)
Is anyone having problems connecting with WIFI devices that are not broadcasting SID for security reasons? It's important security constraint for us in our company that we don't advertise our WIFI access due to competition being within sniffing range. We currently use Cisco WAP's using WPA Enterprise connectivity.

Thanks...

Macpro, Mac OS X (10.5.4), Lots of bells and whistles
  • brianandsuz Level 1 Level 1 (10 points)
    I've configured WiFi connections to my home wireless router (Linksys WRT54G) with MAC address filtering (allow in list) and WEP (128bit). I've also turned off the broadcast of the routers SSID.

    To make the initial iPhone (3G, 2.0.2) configuration as easy as possible, I enabled the router to broadcast its SSID. Worked like a champ.

    When I go back and turn off the SSID broadcast, even though the iPhone "knows" the network, it can not find it and does not connect. Turn SSID back on and "poof!" instant connection. It's worth mention that my work laptop (Thinkpad T43P), personal MacBook and Nokia e61i all are happy to connect when the SSID broadcast is turned off.

    Sorry it's not a solution to your post, but at least recognition of the same issue.
  • James P Malone Jr Level 1 Level 1 (0 points)
    I'm having this issue with 2.1

    My wife's phone is not having this issue with 2.0.1
  • ~BobS~ Level 1 Level 1 (55 points)
    I've been running a non-broadcast SSID config for years and have never had a problem attaching devices to it. Never had to switch broadcast back on to attach with either iPhone 1st gen or current. Unless you have some syntax problem I can't see why it wouldn't attach. Knowing the name should act the same as having it broadcast to you.
  • BobF4321 Level 1 Level 1 (0 points)
    This has just started being a problem for me also. When I turn SSID broadcast back on the network appears with the checkmark next to it, so the software does know your last selected network, and should automatically add it to the "choose a network" list. Sounds like a bug to me.
  • pgordash Level 1 Level 1 (0 points)
    I cannot connect to my work WiFi network which also does not broadcast it's SSID. It's more difficult for me because IT will not flip the SSID to be broadcast for a few minutes for my iPhone to find it. My iPhone is 2.1 and will connect just fine to my home network that does broadcast. Hopefully someone has another workaround...

    Thanks,
    Paul
  • MobileDev Level 3 Level 3 (565 points)
    Just to be sure, to those who are having problems...

    You are going to Settings, WiFi, choosing Other Network, and typing in the exact (upper and lower case) name of the network, right?
  • pgordash Level 1 Level 1 (0 points)
    MobileDev, that is exactly what I am doing.
  • Jason L Community Specialists Community Specialists (10,495 points)
    Hey SegmentFault,

    Try Resetting Network Settings on the iPhone, go to Settings> General> Reset> Reset Network Settings.

    If the iPhone still does not connect give a little more information, like radio mode, iPhones IP, and the exact error when attempting to join the network.

    Jason
  • pgordash Level 1 Level 1 (0 points)
    My situation is exactly like SegmentFault's: using a corporate network using Cisco wireless access points (802.11b) around the office. Can't peel them off the ceiling to get a specific model number. Type in the info manually in the "other networks" and get a "could not find the network".

    Works fine at home with a linksys wrt54g, but then I have my SSID broadcast.
  • Freida Level 1 Level 1 (50 points)
    I'm leaving on a trip in the morning and I so depend on my iPhone!! Now it stopped seeing wi fi! Yikes. I thought it was my router but then I went to starbucks and it doesn't connect there either.

    Last night I restored clear back to march and it worked. What's happening! Oh, my god!!! lol NO WI FI!
  • Freida Level 1 Level 1 (50 points)
    Oh and then I downloaded lots of stuff and my apps and then it stopped working again!