Previous 1 2 Next 21 Replies Latest reply: Oct 9, 2008 4:27 PM by Jitanjafora
Jitanjafora Level 2 Level 2 (245 points)
Hi fellow Mac-lovers,

This Smurf was handed down to me. It had very little memory, a 300Mhz CPU, a small hard drive, and was running 10.1. Piece by peace, I mustered a gig of memory, a 40GB HDD, a Radeon 7000 PCI I had lying around, and finally a Sonnet 500MHZ G4 upgrade, and installed Xubuntu Hardy in it.

Everthing was going well, but I wanted to make sure that the Sonnet CPU was what the seller said it was, and I didn't know how to get that information under Xubuntu, so I erased the HDD and installed 9.2.2. Curiously enough, the CPU was listed as a G3 300Mhz.

I decided to install OS X to make sure, but installing Tiger in the HDD and putting it back didn't work; it would stop halfway during booting and hang there forever. Went back to OS 9, worked fine, still detecting the CPU as a 300Mhz.

Then I decided to install Panther. No go. At the end of the installation of CD 1, it just hangs forever. Tried several times, same luck, or lack thereof. The base OS 9 continued to work, and I checked the HDD using the Disk Utility in the install. Everything looks fine.

Frustrated, I tried Erase and Install with Panther, with the same result, the installer hanging and going nowhere. Tried reinstalling Xubuntu, but the installer also hangs now.

I'm at the end of my wit here. What's going on with this Smurf?

Any feedback will be very appreciated.

Thanks in advance.

P.S. It also has a Sonnet Harmoni PCI card that worked very well in Xubuntu, and should work with the Airport Extreme drivers in Panther, if I ever get to install it...

P.P.S. Now even the OS 9 install hangs...

MacBook Pro, eMac, iMac, Gigabit, MDD, Pismo, Mac OS X (10.5.2), Also Tiger (10.4.11) and OS 9.2.2
  • Lou Mazzucchelli Level 4 Level 4 (1,685 points)
    Did you install the Sonnet "G4 unblock". The old B&Ws had a firmware "feature" that prevented this upgrade. You must remove the feature to have a G4 behave correctly in a B&W (mine does just fine).
  • Jitanjafora Level 2 Level 2 (245 points)
    Hi Lou,

    Thanks for the quick response.

    The CPU was sold to me without software, so that could be part of the problem. Is the "G4 unblock" part of the Sonnet hardware, or is it something else?

    Thanx,

    F
  • Lou Mazzucchelli Level 4 Level 4 (1,685 points)
    It's a firmware update - you should be able to download it from the Sonnet site.
  • Jitanjafora Level 2 Level 2 (245 points)
    Thanks, Lou,

    I got the Firmware updater and burned to a CD suing another computer. My problem is still that ALL installers keep hanging on the Smurf. I replaced the processor with the old one for reinstalling OS 9, and it's still a no go. The installer freezes midway.

    Could it be the CD drive? I have checked the cables, and they all look like they're in place...
  • Lou Mazzucchelli Level 4 Level 4 (1,685 points)
    Could be - might also be the installer disk. Might also be a RAM problem.
    A hardware diagnostic CD would be a good thing to have - you might be able to download an
    image from the Apple website.
  • Jitanjafora Level 2 Level 2 (245 points)
    I'll try to find a diagnostic disk image somewhere in the depths of Apple Support.

    I'm ruling out the installer disks, because all OS installers hang equally (the problem has actually gotten worse), and it would be a rare occurrence if all those CDs went bad at the same time. (I have tried 2 Xubuntu installers, 2 OS 9 installers, and Panther).

    RAM was working OK before. In fact, my 9.2.2. installation was booting and working fine until I erased it today in yet another attempt to install something else.

    Thanks again, Lou.
  • Grant Bennet-Alder Level 9 Level 9 (51,750 points)
    Does this Mac have the solid three-drive bottom shelf with screws installed only from below? If so, it may be the Rev 1 "Heartbreaker" G3, that is just a little flaky when its hard drive is replaced by one that is FASTER than the original drive, or any drive larger than about 40 GB \[presumably because ALL drives over 40 are faster than the original drives.]

    The "litmus test" is on this page, where you look under 3. Revised IDE Controller Chip. to see whether your motherboard is Rev 1 or Rev 2:

    http://www.xlr8yourmac.com/G3-ZONE/yosemite/newfeatures.html
  • Jitanjafora Level 2 Level 2 (245 points)
    Hi Grant,

    Thanks for responding!

    Apparently it is the accursed Rev 1, since there is no 402 on the IDE chip. I tried switching HDDs (it does have a 40GB 7200RPM drive) for a smaller one, but the OS 9 installer still hangs...

    "A little flaky" does not begin to describe this. Could it be the CD drive? I could try a working SD I have somewhere...
  • Jitanjafora Level 2 Level 2 (245 points)
    I have, by the way, reset NVRAM using firmware, reset PMU and PRAM. Still no dice.
  • Grant Bennet-Alder Level 9 Level 9 (51,750 points)
    Do you have the little OS 9 Utility called "Gauge Pro"? it has a simple memory test built into it. It should run booted from an OS 9 System/Install CD.
  • Jitanjafora Level 2 Level 2 (245 points)
    I might. Problem is, the OS 9 install freezes mid-boot, so I can't do anything from ANY CD...
  • Grant Bennet-Alder Level 9 Level 9 (51,750 points)
    If you cannot Boot to an OS 9 System/install CD, you have a Hardware Problem. Those CDs serve as an incorruptible source of known-good software, eliminating the Hard Drive and the software on it as a source of problems.

    If you have multiple RAM modules, shift each module down one slot and bring the last one around to the first position. If no change, do it again until you have gone through the whole set of possibilities. If no change try removing one module at a time. Above all else, be methodical -- and only change one thing at a time.

    --------

    If you CAN Boot to the OS 9 System/Install CD, stop right there -- don't Install anything.

    Find the copy of Gauge Pro on the Hard Drive and double click on it.

    Choose something like "Test Memory" off its Menus.

    Message was edited by: Grant Bennet-Alder
  • Jitanjafora Level 2 Level 2 (245 points)
    Hi Grant,

    Thanks for all the help. I do seem to have a hardware issue.

    I installed OS 9 in a Firewire drive using my Pismo, took it all the way to 9.2.2, booted from it to test it, and then took it out of the Firewire case and put it in the Smurf instead of the other drive. Tried to boot from it --same scenario.

    So there's something wrong with this machine, after all. Something went south at some point.

    When I boot into Open Firmware, I'm always getting this error message in the beginning:

    1 1 2 failed to respond

    Whatever that means. Although I'm a complete ignoramus, I think it means something bad. I haven't been able to find anything in Apple's database that explains it.

    Thanks again,

    F
  • Grant Bennet-Alder Level 9 Level 9 (51,750 points)
    If it goes through most of the motions of working, but doesn't, it is most likely a memory problem. Try my method above or if you prefer, drop back to a small configuration that works and build upward from there. Above all else, be methodical and try to change only one thing at a time.
Previous 1 2 Next