9 Replies Latest reply: Nov 20, 2008 11:16 AM by jparker
ehmjay Level 1 Level 1 (10 points)
So for some reason all my divx/xvid files are no longer playing their sound. I've been poking around at the audio codecs and the only AVI files that have the sound working is those that have AC3 audio encoded into them. The rest (even the generic MP3 audio) don't.

VLC plays them fine (as per usual).

Just to narrow everything down:

Within library/audio/plug-ins/components:
A52Codec.component
AC3Codec.component
AC3MovieImport.component
XiphQT

Within library/components/
AC3Codec.component
AC3MovieImport.component
XiphQT

Within library/quicktime/ (minus the apple codecs)
AC3Codec.component
AC3MovieImport.component
DesktopVideoOut.component
FLACImport.component
Flip4Mac WMV Advanced.component
Flip4Mac WMV Export.component
Flip4Mac WMV Import.component
FLV.component
IMXCodec.component
XiphQT.component
XviD_Codec 1.0 alpha.component
XVIDDElegate

Again - video works just fine just audio I'm having troubles with (in QT).

Am I missing something here? And don't recommend Perian. It screwed up my QT last time!!

PowerBook G4 12-inch, Mac OS X (10.5.2), 1.5 GHz Power PC G4, 1.25 GB DDR SDRAM, 100GB HD
  • Klaus1 Level 8 Level 8 (45,415 points)
    And don't recommend Perian. It screwed up my QT last time!

    How did you make it do that?

    You DO need Perian from http://perian.org/

    You should read this support page http://perian.org/#support in case you need to delete older codecs.

    You should also ensure that you have downloaded and installed all the correct versions for your Mac of Security Updates up to and including 2008-005. (N.B. Security Updates require both a restart and a permission repair.)

    In Macintosh HD/Library/Quicktime/ delete any files relating to DivX (Perian already has them). However it should be noted that Perian is not an internet plugin and will not play DivX files imbedded on a website. For that you will need the DivX Player browser plugin available from http://www.divx.com/divx/mac/
  • ehmjay Level 1 Level 1 (10 points)
    Thanks but no thanks, last time it made DivX videos play back slow and copy and not only that after contacting apple about other video playback issues they said that Perian has caused more problems than solutions and that even if you try to remove it it leaves traces behind.

    I'm not making the same mistake again. I've installed nearly all the codecs it would install anyways. All its good for is a one click solution to doing what I've already done... that an screwing with things it shouldn't be touching.
  • Klaus1 Level 8 Level 8 (45,415 points)
    Thanks for sharing a unique experience.

    Please post back when you have found an alternative solution.
  • ehmjay Level 1 Level 1 (10 points)
    I'm not alone. Just go to any mac forums site and do a quick search. You will come back with both great perian experiences and horrendous.

    I fall into the later of the two. I think it stems partial from the fact that I'm running PowerPC and despite the tag of Universal it really hasn't been optimized for the PPC.

    Of course they're not alone in that problem, Apple seems to have the same issue with it's quicktime updates.
  • Klaus1 Level 8 Level 8 (45,415 points)
    Perian 1.1 (not the former beta) works fine with my PPC Mac.

    You need to remove obsolete QuickTime Components: FFusion, Xvid Delegate, 3ivX, DivX, XviD, msmpeg4v1, msmpeg4v2, AviImporter, EX_M4S2, and Casio AVI Importer.

    I have had no issues with any Quicktime updates.
  • ehmjay Level 1 Level 1 (10 points)
    Yes well I tried that last time and it screwed things up, uninstalled it and fixed MOST of my problems but not all. Apple said I would have to reformat to clean everything up.

    Im glad it works for you, but again it's caused problems for me.

    Having said that, these videos should still work REGARDLESS of Perian being installed so what's going on?
  • Charles Laine Level 1 Level 1 (0 points)
    I have the same issue. I downloaded the latest WoW cinematic trailer. It requires xvid. OK, no problem. Download and install xvid. I can now see the movie. The video is just fine. However, it i silent. I checked the properties of the movie and noticed the audio was simply mpeg layer 3.

    OK, so, let's try and play any mp3 in my QT player. Tried that and guess what... it's silent too! So, I am also in the boat of QT not playing mp3 audio. Sound is working on this Mac. I can hit the volume up or down keys and I hear my beep get louder or quieter. I can play iTunes just fine as well.

    The bottom line is, audio is working on the machine, but QuickTime is not playing mp3 audio.

    Any clues as to what is wrong would be helpful.

    Here's some system info...

    Model Name: iMac
    Model Identifier: iMac4,1
    Processor Name: Intel Core Duo
    Processor Speed: 2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 2 MB
    Memory: 1 GB
    Bus Speed: 667 MHz
    Boot ROM Version: IM41.0055.B08

    System Version: Mac OS X 10.5.4 (9E17)
    Kernel Version: Darwin 9.4.0
  • Infinite Loop, 1 Level 1 Level 1 (25 points)
    Perian Worked fr me

    PPC G4 AGP graphics
    Mac OS X 10.4.11
    QT 7.5.5
    Perian 1.1.2
  • jparker Level 1 Level 1 (15 points)
    I was having the same issue (good video but no sound on on an xdiv file--not sure of the sound encoding.) Installing Perian and removing my old xvid codex solved the problem.