Previous 1 2 Next 23 Replies Latest reply: Sep 18, 2008 10:42 AM by jegbert
Reuben Feffer Level 2 Level 2 (195 points)
Hi,

I have this (1) badge permanently next to Applications in my LIBRARY source list. When I click on it, I see it says "1 Update Available" and when I click on that it says "No updates available. Check again later."

This seems messed up to me. There aren't any Application updates available, but iTunes thinks there are. How do I make the (1) badge go away?

 iMac 17" 2GHz, 2GB RAM, 250GB Hard Drive, Mac OS X (10.5.4),  16GB iPod touch  40GB Apple TV
  • lockeddoor84 Level 1 Level 1 (0 points)
    I'm sure this isn't the best answer, but this happened to me last week and I ended up deleting the application that was causing the problem and re-downloading it.
  • Reuben Feffer Level 2 Level 2 (195 points)
    Thing is, iTunes isn't indicating WHICH app there are updates available for. It just says "1 Update Available" but doesn't give any more detail than that.

    So, short of deleting ALL my apps, I don't know what to do.
  • Scottster Level 1 Level 1 (0 points)
    Well, think yourself lucky. Mine was stuck at 9 this morning. By deleting 3 apps that I didn't want I've got it down to 6. But now it's stuck there, with no updates available and no other apps that I wish to delete.

    So, any other suggestions out there?

    Scottster.
  • erilou Level 1 Level 1 (0 points)
    Hi - I'm having this issue as well. Have a permanent 1 next to my applications - but no updates available, and no indication of which application is causing the problem. Would love a solution (other than deleting and reinstalling all my apps, since I'm guessing the situation would eventually repeat itself). Is there some sort of fix for this? Or is it just a bug?
  • Reuben Feffer Level 2 Level 2 (195 points)
    Glad to hear I'm not alone.

    If there were notification badges in iTunes actually over EACH of the Apps, it'd be much easier to see (work out) which Apps have updates available. But the way it is at the moment, if something goes wrong like this, it's impossible to know which App is the cause of the problem.
  • hoodoo1966 Level 1 Level 1 (25 points)
    I created this problem today as follows:

    I had 4 pending updates. However, I only wanted two of them, which I updated. Then, I deleted the 2 other apps that I no longer wanted without updating them. Now, I have the app section notifiying me of 2 available updates, but then when I check, it says no updates available. So now it's stuck at 2. So it would seem that, in my case, if you remove apps without applying an available update, somehow the iTunes notification becomes stranded.

    And interestingly, the Touch itself did not notify me (with badges) with the the app store icon of the available updates with the 2 relevant apps still on the touch, and when I did try to run many other apps after the two updates above, many would crash until I reset the device. Strange.

    Message was edited by: hoodoo1966
  • Scottster Level 1 Level 1 (0 points)
    If your theory is corrent then it should be possible to reinstall the previously-removed apps (assuming you can remember what they are), apply the updates (if any) and then delete the apps again. I might try this later but rather busy right now... will report back.

    Scottster.
  • hoodoo1966 Level 1 Level 1 (25 points)
    I tried re-installing one of the deleted apps, it automatically downloaded the update. I then removed it. Still says two updates available. It may or may not have been complicated by the fact that updates for two other apps became available between yesterday and today, these were installed as well.
  • iCoco Level 1 Level 1 (90 points)
    Hi, may I join the "update badge bug club". In my iTunes app section I have 11 iPhone apps plus 3 iPod games right now. iTunes is constantly telling me there are 2 updates available but then, after clicking the message, it tells me "Sorry, no updates available". Kinda enervating.
  • iCoco Level 1 Level 1 (90 points)
    From this other thread I've learned that, as it seems, the "stuck update badge bug" is connected to a "duplicate files bug": When an update is available, iTunes downloads it and stores a duplicate in finder rather than replacing the outdated file. So after a while you'll find several files of the same app in finder, like AIM.ipa, AIM 1.ipa, AIM 2.ipa and so on. Somehow, this seems to cause the update badge problem.
  • Andy Manson Level 1 Level 1 (15 points)
    Count me in this boat too. I tried reinstalling iTunes and that did not help.

    It started for me when an update appeared in iTunes. Instead of updating it there, I went straight to the iPhone, clicked on the app store (where it did not have a badge showing an update), went to updates (where one showed up), then I updated it there. The badge in iTunes never went away even when I did a transfer of purchases from the iPhone to iTunes.
  • mmuzzy Level 1 Level 1 (0 points)
    I was looking for someone else who might have this problem. Add me to the club membership, I'm stuck at 1 update available also.
  • Steve Crow Level 1 Level 1 (5 points)
    I started writing this post thinking I was able to solve this problem by doing the following:

    1) in iTunes clicking on Applications
    2) Right click on an application
    3) Selecting "Show in Finder"
    4) Find any file that has a number at the end which means there is more than one copy
    5) Delete all but the latest version of that application and rename it to remove the number ***AT THIS POINT THE UPDATE BADE NUMBER WAS ERASED SO IT FELT LIKE I SOLVED THE PROBLEM***
    6) Re-sync your phone (you may have to reboot as well)


    Now I had at least one application (labyrinth the tilt table game) that broke when I did this so I deleted it from iTunes and re-downloaded it from the iTunes App Store...it's important to note that this a FREE application

    ****JUST NOTICED THAT THE PROBLEM HAS RETURNED IN ITUNES, PROBABLY HAPPENED RIGHT AFTER I REBOOTED MY IPHONE BUT I DIDN'T NOTICE IT RIGHT AWAY.IT MUST BE STORING THE WRONG INFO SOMEWHERE THAT I DIDN'T FULLY ERASE WHEN I THOUGHT I DID****
  • Steve Crow Level 1 Level 1 (5 points)
    I just rebooted iTunes itself and now it seems fixed! One of my applications ( the game that I deleted and then re-downloaded) actually still has two copies of itself in Finder but for some reason now it doesn't seem to impact the badge problem.

    The copy of the game that has the number at the end of the file name has a newer "Date Modified" date and is a larger file size - it must be a newer version of the game.

    I wonder if I reboot iTunes again if the problem will return?
Previous 1 2 Next