6 Replies Latest reply: Aug 13, 2008 1:42 AM by Flame_eric
Flame_eric Level 1 Level 1 (0 points)
I have recently did a verify disk from the disk utility. However i was told that my disk needs repair. So i booted up from my installation disk. I managed to boot up from my installation disk nd ran a verify permission and repair permission command. When i did a verify Disk command from the disk utility, it said that i need to run the repair disk command. When i did so, the error message that came up says that they are unable to unmount the disk. Therefore, the Disk repair cannot be done.

MacBook, Mac OS X (10.5.1)
  • V.K. Level 9 Level 9 (56,130 points)
    you should definitely fix this problem first before dealing with the trash problem in your other thread. they might be related.

    boot from the install DVD again, start disk utility, select your internal hard drive (the name not the model) and click "unmount" in DU toolbar. if that suceeds try repairing disk again.
  • The hatter Level 9 Level 9 (60,280 points)
    Sometimes it just needs to be retried again, but if your DVD has 10.5.1 or earlier, I would install OS X on another drive and use that for doing repairs, and that way you can also run other 3rd party tools to help diagnose and repair your system.

    Also, make sure you have either TimeMachine or a bootable backup (clone) if not both, and insure your 'clone' boots and works fine.

    I never run Verify disk. Ever. I boot from another drive and just go straight to Repair Disk and then run either Disk Warrior or TechTool Pro (or even both).
  • Flame_eric Level 1 Level 1 (0 points)
    I have tried the repair disk a couple of times but have yet to try to unmount it. I shall try that. Thanks.
  • Flame_eric Level 1 Level 1 (0 points)
    I managed to unmount my drive this time that i tried. However, when i use repair disk, the following error came out.

    Keys out of order.
    Rebuilding Catalog B-Tree.
    The Volume could not be repaired.
    error: Filesystem verify or repair failed.

    I tried it 5 times. Same error message.
  • V.K. Level 9 Level 9 (56,130 points)
    try running Disk Warrior (if you have it) on the drive. I that doesn't work you need to reformat the drive. do you have a backup? if not make one asap. then try reformatting the drive. then restore your system from the backup you made.
  • Flame_eric Level 1 Level 1 (0 points)
    It seems like both this problem and the other one i posted on the regarding the Trash, is related. I couldn't boot from Disk Warrior. Therefore, i downloaded Techtool Deluxe from apple website. I did a scan and repair. Repaired 3-4 times before i managed to have a scan without error. Everything seems to be fine now.