Previous 1 2 Next 25 Replies Latest reply: Oct 7, 2008 2:02 PM by shape
The Zach Level 2 (380 points)
I'm trying to add artwork to some .aiff files I just imported. I've tried dragging the cover art from my desktop to the Drag Album Artwork here space under Selected Item and I've tried dragging importing my selecting the song > Artwork > Add.

The artwork appears in both places, but once I go to the next song it disappears. And the cover art I'm trying to add is a .jpg file from a site I've used for artwork countless times.

I was able to add artwork to an AAC file though. Is it not possible to add artwork to AIFF fies?

Thanks!

iMac, 2.4 GHz, 2 GB RAM, 500 GB HD, Mac OS X (10.5.4), iPhone
  • Bob / Judy Thornhill Level 1 (0 points)
    Had the same problem with aiff files. finally converted the files to mps & replaced one file which allowed me to attach artwork to that song. Did not have that problem before all the upgrades but do not know for sure if that was the cause.
  • Diane Wordsmith Level 5 (6,000 points)
    When you manually add artwork, you have to apply it to all tracks in the album. (Sounds like this didn't happen.) That would explain why you don't see the artwork when it advances to the next track.
  • The Zach Level 2 (380 points)
    I did try to add it to all of the tracks, same thing I've done for the thousands of other songs in iTunes.
  • wolvesjames Level 1 (15 points)
    Hey The Zach,

    I know exactly what you mean. I have an AIFF library on an external harddrive which I use as a back up to my originals. I have been adding artwork to these tracks for months now and have had no problems until I upgraded to version 7.7.1.

    Now each time I attach artwork it appears in the +Get info+ artwork box, but then when you close down the box the artwork does not appear in the library. When you then open the +Get info+ box again the artwork is missing there too.

    I noticed that if you attach the artwork whilst the song is playing it does work, but then after the song finishes it disappears again!

    I'm assuming its a bug or (worse) that iTunes will no longer allow you to attach artwork to AIFF files. I can't see the reason for that though so I am assuming its a bug in this new version.

    Has anyone else experienced this?


    James.
  • Byrdman70 Level 1 (0 points)
    I have the same problem since updating to new Itunes aiff will not accept artwork....
  • Sergeant Karma Level 1 (25 points)
    Chalk another one up. It's very annoying.
  • Bill Gadzia Level 1 (0 points)
    I have had the same problem with my 10.5.4 Intel iMac since the last iTunes upgrade. I used to be able to bring in CD quality AIFFs, add the artwork and then convert to AAC. The artwork would be part of the new AAC files.

    Now, if I try to put the artwork in the AIFF file, nothing shows up. If I convert it to AAC, no artwork is present. I can add the artwork to the AAC file, so in the end it's no big deal.

    I have a disk still in AIFF form that I added July 12th that I was able to put the artwork in, but I haven't been able to add the artwork to the AIFF files since the last iTunes update on August 1st.

    Perhaps Apple will correct it in the next update.


    Bill
  • billyjoejimbob Level 1 (10 points)
    Yup, same here. Must be a bug. How does one get this to the "right" people?
  • wolvesjames Level 1 (15 points)
    Good question.

    I spent some time looking for a way of reporting this to Apple directly, but could not find anywhere to do so. Hopefully they already know about it, but it would be nice to be sure. Perhaps they even check these discussion boards!

    Another thing I noticed that has changed since the update is that I am sure before that I could import AIFF files (that I had added info too) from one iTunes library into another and for that info to carry across. Now when I add those AIFF files the info doesn't import across so I have to add all the details again.

    It's as if the data isn't being correctly encoded into the AIFF files (as with the artwork).
  • wolvesjames Level 1 (15 points)
    Problem appears unresolved in iTunes 8 too. Has anyone else had any luck?
  • Jim MacCormaic Level 4 (2,635 points)
    It still continues in version 8, much to my frustration and disappointment. It's a deal-killer for me, so I've dumped iTunes 8 and reverted to 7.6.2.

    May I suggest that you do as I have again done and hound Apple with feedback requesting the return of the functionality we enjoyed up until 7.7.1. This is the appropriate place for feedback:
    http://www.apple.com/feedback/itunesapp.html
  • wolvesjames Level 1 (15 points)
    Cheers for the link Jim. Have added my two pennies worth as well!
  • wolvesjames Level 1 (15 points)
    Problem seems to be fixed in the latest update 8.0.1! I can now add the artwork to the missing albums as normal!

    Really pleased this has been fixed
  • murphyb74 Level 1 (0 points)
    Problem seems to be fixed in the latest update 8.0.1!


    This would be great. I had reverted back to v 7.6.2 because of this. Can you add artwork to groups of songs as before? Thanks.
Previous 1 2 Next