Previous 1 2 Next 15 Replies Latest reply: Dec 2, 2008 12:55 PM by Robert Carlisle
jjoseph Level 1 Level 1 (5 points)
I pray that this will work. It will probably be the deciding factor for upgrading to Leopard.

We have a network with a Verizon Wireless Router. Through the router several computers access the internet, as well as, this D-Link 323 External Bay is connected. All the machines have access to the D-Link storage bay through the finder. However, when we attempted to utilize one of the Hard Drives for Time Machine (Brother's New Computer), Time Machine does not see the Network Drive.

Is this possible? There were a few people that posted solutions via "Netgear ReadyNAS" but we followed some of the steps which didn't seem to work. But there is a good chance we are not following the directions properly.

Any help on this would be greatly appreciated.


John J.

PowerBook G4, Mac OS X (10.4.11)
  • Anders Jangö Level 1 Level 1 (0 points)
    I have the same NAS, and as far as I have read here and on other forums, it would be necessary to install "netatalk", which is the Linux implementation of the Apple network protocol AFP with encryption. Virtually all NAS units are Linux-based, which is basically is a good idea.

    So I merely verified that it did not work and decided I would not give it the work.

    So, since any resistance is futile and I will be assimilated anyway, it is going to be a either a FW disk or a TC.

    But read
    " volume/", it is excellently described and would most probably work, although it is not quite clear to me how to get all that into the NAS.

    But SuperDuper works as expected using both of the two NAS's of my network.
  • jjoseph Level 1 Level 1 (5 points)
    I'm trying to set up Time Machine with NAS. I was having trouble getting TM to see the NAS, but I figured that one out (Thanks to another post). Now the problem is "The Back Up Disk Image cannot be created."

    I'm able to view the drive in the finder and we can create and delete files and folders to the drive from the finder. The computer has a single word name (to make it simple), but still the problem persists. Is there something we're missing?

    System: Mac OSX 10.5.4
    Network: Verizon Wireless Router
    NAS: D-link DNS-323 (w/500 GB in Bay 1; 300 GB in Bay 2)
  • Prynce Level 1 Level 1 (0 points)
    Which post was that that you found how to see it, currently configuring the same NAS today!

    Message was edited by: Prynce
  • jjoseph Level 1 Level 1 (5 points)

    I actually can't tell you where I read the post, because as soon as the Mac recognized the NAS on the network, it was only seconds later that Time Machine give us the option. However, the problem still remains, after we select the proper drive, Time Machine reports the Disk Image cannot be saved (something like that).

    In other words, I'm still working on finding a solution; and unfortunately no one seems to have solved the issue. There was some mention about making sure the mac has an identification (i.e. display name).


    John J.
  • Patty B. Level 1 Level 1 (0 points)
    I'm having the same issue implementing Time Machine with a third-party NAS (DNS-323). I haven't solved the problem myself, but I believe I'm close to solving it following the instructions published here: rd/

    and then here: le-problems/

    Read the instructions in those links, then read what I'm about to write here - the only problem I have left with implementing Time Machine with my DNS-323 is that when I use Disk Utility in OS X to create a sparsebundle image of 250GB, my MacBook tells me I can't create the image because I only have 147GB of space on my MacBook's HD. From what I understand, this should not be an issue because although I am trying to create a sparsebundle image that is 250GB, my MacBook should be recognizing this image as being essentially 0GB big, because there are not yet any files backed up to this sparsebundle image. Apparently, it is only after the sparsebundle image is created, moved to the DNS-323, then filled by using Time Machine to back-up my MacBook's HD, that this file should actually begin occupying space. So, for example, the way it SHOULD work is as follows: I create a sparsebundle image using Disk Utility in OS X, and define it as 250GB (though the "recognized" size of the image at this point should still be pretty much 0GB). Then I move the sparsebundle image to my DNS-323. Then, to back up my MacBook's HD, which currently has 103GB of stuff on it, I run Time Machine and make it back-up to the DNS-323. Once the back-up is completed, the sparsebundle image should be recognized as being a file that is approximately 103GB in size (now that my MacBook's entire HD has been backed-up to the sparsebundle image).

    However, I repeat, this is not working as it should for me. I can get this to work for me if I create a sparsebundle image using Disk Utility and define the size of the image as being equal to or less than the remaining space on my Mac's HD, but that's not good enough for me, and based on what I know about sparsebundle images (and what I've described above) this should not be a limitation. I want to create an image that is defined as being at least 250GB large, the same size as my HD on my Mac.

    Any help would be greatly appreciated.


  • almumen Level 1 Level 1 (0 points)
    I assure you it works but you need to follow the steps correctly.

    the details is here: rd/

    I have a McBook Pro and Leopard and NAS box D-Link DNS-323 and it worked perfectly. My NAS is connected to the DSL rounter via ethenet cable. I connect to the router wirelessly and reach the network device.

    there was only one undocumented exception on the procedure which I commented:

    {quote:title=Mohammad-Al-Mumen wrote:}
    tried it and it did not work from the first time. after long time investigation I found that the file created by time machine add “tmp” to the sparse bundle file name which does not work if you just use it. you have to remove the “tmp” from the file name and then it will work.

    the original file name which I used (since this is the name used by time machine) and did not work:


    when I removed the “tmp” part from the file name and then follow up the rest of the procedure, it worked perfectly. The working file name:


    thanks again. The solution works perfectly now.
  • NoRemorse Level 1 Level 1 (0 points)
    I have got this to work except it all broke again with 10.5.4, and is not resolved with 10.5.5
  • Monty1945 Level 3 Level 3 (690 points)

    Time Machine was not designed to work with NAS boxes, only those external drives directly connected to your computer, or to a Time Capsule.

    You can fool around with it and use all kinds of trick methods to get it to work, but it usually fails somewhere down the line for any number of reasons. I've seen people that got a particular NAS to work, only to have it fail several weeks in.

    I've also seen people get an external hard drive to work connecting it to the Apple AEBS by connecting it directly, first, making a backup and then moving it to the AEBS. They, too, will likely fail at some point, as I have seen first hand before.

    Your best bet is to use some other backup software that normally works over a network. I use Retrospect, and there are others. I do use TM, but connected to each of my 5 Macs, for more-or-less instant retrieval and do an archival backup, over the network, to my OS X Server.

    Use it the way it was designed and avoid a lot of pain.

    Good Luck - Cheers,
  • barlowc Level 1 Level 1 (0 points)
    Can someone advise, I probably have a stupid issue:

    I have a DNS-323 on the network and Mac 10.4 Finder sees the device, but Finder 10.5 does not. What am I missing?

    So is the consensus that DNS-323 will not work with TimeMachine? Sounds like it.

  • Music4Film Level 1 Level 1 (0 points)
    DNS-323 works fine. No modification to the DNS-323 are required. Only two things.

    1. You have to unlock the Time machine preferences to be able to see the DNS-323 networked volume. You do this by typing the following into the Terminal.

    defaults write TMShowUnsupportedNetworkVolumes 1

    Then, the first time you want to select the Volume on your DBS-323, you have to actually mount it via your networked browser onto the OSX desktop. Then it will show up in the Time Machine volume options. You select the proper volume that the sparsebundle resides on (see net step).

    2. You have to actually manually create the sparsebundle file for the DNS-323 volume. You can do this with disc utility. The important thing is to name it correctly. The name of the sparse bundle contains the MAC ID of your computer. Something like the following:


    (This is how multiple computers / sparsebundles can be backed up with Time machine on the same physical hard drive.) I honestly forget where I found the instructions on how to create and properly name the sparsebundle file with Disk Utility. But it was pretty easy.
  • NoRemorse Level 1 Level 1 (0 points)
    Here is a tip...
    If you have any anti-virus software (yes they do exist for OSX), then disable it.
    I now have Time Machine working fine again with 10.5.5 and a DNS-323 NAS.
    Of course I forked out for a 1TB Time Capsule before I worked this out...
    At least I don't have to manually create sparsebundle files anymore!
  • Tobin Anthony Level 1 Level 1 (90 points)
    Okay, I'm doing this with a DNS-321 but I should be able to get it work just like your DNS-323.

    However, I'm having trouble making the sparse image in Disk Utility.

    II've got a DNS-321 with two 1 TB drives set up with the D-Link software as if they were a single drive. I'm trying to create the image on the DNS-321 itself.

    The image I'm trying to create is named as you've described. I'm trying to set up a 900GB image using the Mac OS X Extended (Journaled) format. I'm using a Single Partition - Apple Partition Map and am using the sparse image option.

    Disk Utility kerchunks the drive for about a minute and then comes back and tells me that the operation is not supported. Can you give me some of the criteria I need to create the image?
  • Tobin Anthony Level 1 Level 1 (90 points)
    Okay, I see my problem. I need to create the disk image on my local drive and then drag it over to my DNS-321. However, when I do that and start up Time Machine, I get an error (after some kerchunking) that I cannot mount the disk image.

    Does anyone have any insight??
  • Maurice Volaski Level 1 Level 1 (45 points)
    I disagree. There's nothing special about how Time Machine works to prevent it from working on a NAS box. It's just reading and writing bits.
Previous 1 2 Next