Previous 1 2 Next 22 Replies Latest reply: Aug 20, 2008 3:19 PM by Redhousepainter
deiviuxs Level 1 Level 1
My wireless internet on my MacBook is not working anymore. I have a PC, iPod Touch and MacBook at home and a wireless internet (router and modem) that I use. The internet is working perfectly on my Touch and PC but no more on MAcBook (t used to work before). It shows that I am connected but I can't open any web page. I try to use Network Diagnostics but it didn't help..

Mac Pro, Mac OS X (10.4.11)
  • rvaro Level 3 Level 3
    in network preferences does it show you having an IP address??, i would turn off airport, restart router, then turn airport back on when router is up and then try connecting to your network again and see if you have different results...
  • deiviuxs Level 1 Level 1
    I tried your suggestion but it didn't help.
    Under 'System Preferences' > 'Network' and under 'AirPort' it says "Self-Assigned IP" when it is connected to my wireless network.
    It's weird, just when I open Safari it says "You are not connected to the internet" and it doesn't matter what page I try to open it says the same thing as soon as I press Enter (to load new page). It doesn't seem that it even tries to "load" the page. Everything is so quick..
    BUT...the weird thing is that if I connect to my neighbors network (which don't have a password) everything works just fine. Then I can open any page on Safari and in network preferences under AirPort it says "Connected." It might look that it is my networks fault but once again, my network works fine on my PC and iPod Touch and IT USED to work on my MacBook but I have no idea what happened and it doesn't work now..

    Message was edited by: deiviuxs
  • rvaro Level 3 Level 3
    thats why i asked that question... even tho it is self assigned your IP is still displayed... start a new location and manually enter in an IP address for your network as well as the DNS entry...

    you writing you message on a PC just proves that your apple laptop configuration is incorrect and your network and internet are fine...
  • deiviuxs Level 1 Level 1
    Where can I find my network's IP and DNS addresses?

    Also, could you give me some step-by-step-instructions how and where to add/edit the IP and DNS addresses? I am new MAc user and I don't know much yet.


    Message was edited by: deiviuxs
  • rvaro Level 3 Level 3
    network preferences, beside status.. should say

    Airport is connect to 'home network SSID' and has the IP address (example)

    i would start a new location for home:

    open network preferences, press locations... edit locations, press add, name it 'home' , when home is selected go to advanced, TCP/IP tab, Configure IPv4 set to manually, enter your ip, subnet, router addresses, IPv6 can stay automatically.
    click DNS tab, press add, then enter your DNS address (router in most cases), then say ok and then apply...
  • deiviuxs Level 1 Level 1
    Ok, I did it but it's still not working..
    I assigned everything manually and used my iPod Touch to find my networks preferences (IP, DNS, etc.) but I still cannot open any webpage even though in the network preferences it says "Connected."
  • rvaro Level 3 Level 3
    are you able to take screen shots of each tab in network preferences and post them... also include the IP address of your wireless router/access point...
  • rvaro Level 3 Level 3
    is that first pic from the windows PC ip address??

    because you cannot duplicate the same address... that causes ip conflicts... change the ip on your mac to then try again
  • deiviuxs Level 1 Level 1
    Yes, the first pic is from my PC. On the PC the IP address ends with ".101" and on my iPod Touch with ".100" I tried using IP with ".102" on the Mac but it didn't work..still the same...
  • rvaro Level 3 Level 3
    try doing a power cycle of your router while the airport is off.... when router is back online then turn on airport....if still nothing then there may be some security settings messed or maybe your wireless card
  • xpriensmac Level 1 Level 1
    Hey Ther,

    Check if you are able to connect to the network throught Ethernet. if that works, then it could be a problem with your wifi.....

    Second, try to enter the password for ur Wifi Connection again, and see that the settings are the same as with your network environ (i.e if the Security is WEP, then you should also have the same). It happens if you sometime reset your network/router and change your password. Also, try to add ur wifi network manually, by going to System Preferences/Network/Advanced Settings.

    It shows connected, coz it is connected to your Router.

  • deiviuxs Level 1 Level 1
    Ok, I tried turning off AirPort and restarting my router and modem and then turning on the AirPort and connecting to my network again using MAc but it's the same thing..didn't work (works fine on PC).

    To xpriensmac:
    I wasn't sure what you suggested to do...I didn't understand it well enough..

    I think I will end up going to Apple Store tomorrow and asking them for help (Genius Bar)....
  • xpriensmac Level 1 Level 1
    Oh, i meant to connect your macbook to your Router directly using an Ethernet Cable, to see if the internet comes up.

    Secondly, in System Preferences/Network, you get the 'Advanced" option. Go to your advanced settings and in the 'Airport" tab, just see the network name and security. if your network is "Security enabled" then it should show your Security Level.

    Now go to TCP/IP and set the Configure IPV4 to "Using DHCP" and save your settings.

    Come back to your "Airport", click on the "+" sign at the bottom, and then add your network manually giving the right "Security Option" and your passkey. Save your settings, and then connect to your network again (might require a restart too).

    PS: Going to apple store is the best thing if none of these works.
Previous 1 2 Next