3 Replies Latest reply: Aug 19, 2008 5:38 PM by fakeExpert
fakeExpert Level 1 Level 1 (5 points)
When one of the Macs with AppleTV shared content goes to sleep, it is grayed out in AppleTV interface. When selected, I expect it to wake up the sleeping Mac, so that I can start streaming content. It doesn't seem to do this. I have to physically run to the sleeping Mac and nudge it.

Am I missing something? Has anyone gotten this to work?

If not, then Apple should consider this a feature request. With current "green" initiatives, it would be nice to be able to save some energy. Without an auto-wake feature, I have to leave the Mac on all the time, even though I only need it on for short periods of AppleTV access.

It should similarly be possible to wake the main "synced" mac, as well (not just "shared" macs.) Currently, when the Mac with the main library goes to sleep, you are left with only those items actually resident on AppleTV hard drive when you select "My <Content>". It would be better if it woke up the sleeping Mac so that other non-synced content in the iTunes library will show up as usual.

It is curious that the new iPhone "Remote" App already has this capability. (It wakes any sleeping/grayed-out Mac when selected in Remote.) This proves that it is easily do-able. It should be a simple change for AppleTV.

AppleTV, Mac OS X (10.5.3)
  • StevanE Level 1 Level 1 (5 points)
    Definitely a problem. I discovered the same issue when my reliable old Cube recently died and replaced it with a Mini for iTunes serving. The Mini is running Tiger, but has the same problem. While there is a "Wake on Modem" setting in the Energy setting, there is no, "Wake on LAN" setting. Very stupid missing feature, and should be added as an upgrade to Snow Leopard. I will have to leave the Mini constantly on (very un-green), because I will continue to run Tiger until Apple stops supporting iTunes on Tiger or reverses the (stupid) decision to not support Classic on Leopard.

    By the way, the same problem exists if you setup remote access to the Mac at home. My Mini is also setup to be a server for files that I can access from my MacBook Pro while I am at work. Once the Mini goes to sleep, it will never wake when the laptop makes a remote query over the Internet. There is a utility called WakeUp that can correct this, but it won't work on AppleTV as it is software that runs on the remote laptop (or AppleTV) and convinces the Mac it is making an Administrative query.

    You call this progress??
  • fakeExpert Level 1 Level 1 (5 points)
    I think you may be a victim of a different problem. The Mac Mini (apparently) must not even have the appropriate wake-on-lan hardware. That is why it cannot be remotely woken. Unfortunately, if this is the case, your problem cannot be resolved, since you would need different hardware. There is nothing that they can do in Snow Leopard to "fix" this. (Though, after re-reading your post, I am a little curious what this "WakeUp" utility you mention does. Are you saying you can wake your Mini remotely using WakeUp? This seems to contradict my assumption that the mini has no wake-on-lan hardware support.)

    But in my case, the new iMacs DO have wake-on-lan hardware support. This is clear from settings available in the energy saver control panel, and from the fact that I am able to wake it using my iPhone Remote.

    All I am asking is for AppleTV to send out this same "wake" message to the Mac when you attempt to access the shared content. This should be easily do-able. No OS update is required. Just an AppleTV update.

    Message was edited by: fakeExpert
  • fakeExpert Level 1 Level 1 (5 points)
    EDIT: I did a little research, and it seems that your Mac Mini ought to have wake-on-lan hardware support. I don't know why the "Wake for Ethernet Network Administrator Access" isn't showing in your energy control panel. This missing option led me astray. It should really be there. You really shouldn't need a Snow Leopard update to enable it. The WOL support is definitely in Leopard, and I'd assume it's in Tiger as well. Are you sure you are using wired ethernet? WOL is not available via Airport. I'm puzzled... Sorry for the confusion...