Previous 1 2 3 Next 30 Replies Latest reply: Dec 13, 2009 9:10 AM by joeyconnick
Janice Fisher Level 1 Level 1 (95 points)
Suddenly, the search function on iCal is not working. The window drops down where the results are to appear, but it is blank. What can I do about it? It's never happened before so I have no idea what the problem is.

iMac, Mac OS X (10.5.2)
  • Ferd II Level 7 Level 7 (24,355 points)
    cassie229,

    Quit iCal, open System Preferences>Spotlight>Privacy, and add your Macintosh HD to the list. Wait a couple of minutes, and then remove your Macintosh HD from the Privacy list. You should notice (after a short delay) that Spotlight is reindexing your HD. After Spotlight completes the index, open iCal and see if your search works.

    ;~)
  • Janice Fisher Level 1 Level 1 (95 points)
    I did this, but nothing happened. I didn't see any reindexing going on.
  • Ferd II Level 7 Level 7 (24,355 points)
    cassie229,

    I noticed that you are still using OS X 10.5.2, I would recommend that you install the Mac OS X 10.5.4 Combo Update.

    Good Luck.

    ;~)
  • jmcopeland Level 1 Level 1 (0 points)
    I am experiencing a similar problem under 10.5.4 where iCal search randomly stops working. If I quit and restart it works again, but only for one search. If I try a different search, I am shown either blank results or the results from the previous search. Any suggestions?
  • Janice Fisher Level 1 Level 1 (95 points)
    I also get the results from the previous search(or a blank) with the search. My problem seems to be exactly the same as yours.

    I also find that sometimes it will not switch from month to week, or one month to the next. It's almost like it's frozen. When I restart it, it's fine for awhile and then it's back to the same old thing. I had absolutely no problems with iCal on either of my two previous macs; I'd sure like to get this fixed

    I also have OS 10.5.4.
  • Ferd II Level 7 Level 7 (24,355 points)
    cassie229,

    If you used Software Update to get 10.5.4, try downloading and installing the *Mac OS X 10.5.4 Combo Update*, and then reindex your Macintosh HD. http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx1054comboupdate .html

    Good Luck.

    ;~)
  • Janice Fisher Level 1 Level 1 (95 points)
    I have 10.5.4. Is the update beyond that? Or is 10.5.4 the update? I install whatever Apple sends, so I think I must have the latest version.
  • Ferd II Level 7 Level 7 (24,355 points)
    cassie229,

    If you "install whatever Apple sends," it sounds to me like you used Software Update which does indeed install the latest OS X Update, but it is an incremental update.

    Some users have found that the incremental system updates which use the Software Update method do not work as well for them as the Combo Update, which is designed to update any system from 10.5 up through the latest version which is currently 10.5.4. Even though you may have 10.5.4, use of (reinstalling) the Combo Update often corrects problems that may have occured using Software Update.

    Since you appear to be having some of these problems, the first and often most effective troubleshooting step involves reinstalling the Combo Update. For that reason, you have nothing to lose and in my opinion everything to gain by using the Combo Update: http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx1054comboupdate .html

    Good Luck.

    ;~)
  • AlanTheNewBrit Level 1 Level 1 (5 points)
    I've encountered the same quirky or non-functional Find function.
    Despite using the 10.5.4 combo update.
    Frustrating, as I store my serials and other vital info in iCal
    Thankfully I'm old enough to keep a paper notepad about!
    I've (during the period of my Find hassles) noticed Spotlight has become overly obsessive with indexing and the beachball is omnipresent - though the indexing and beachball may not be related to iCal troubles.
    If you're desperate you can "iCal > File > Back Up iCal... and copy the backup to a Mac with less than 10.5.4...
    Or if really, really desperate, use Resorcerer or a similar utility to directly access the text in the .icbu backup file. These problems were sorted - I think - in 10.5.2! Before then it was sometimes possible to quit and reopen iCal to recover Find functionality.
    The Find 'demon" has returned...
  • AlanTheNewBrit Level 1 Level 1 (5 points)
    Unable to access Find feature in iCal 3.0.4:
    Solution to access an emergency find function:
    Step one:
    Download the Sunbird Calendar application from Mozilla
    http://www.mozilla.org/projects/calendar/sunbird/
    Step two:
    In Sunbird import your exported iCal calendars (.ics files):

    Your exported calendars are now searchable in Sunbird.
    Crude but effective.
    Exporting Sunbird's (previously iCal) calendars as .ics files and importing them into a calendar stripped iCal App window didn't restore the Find feature in iCal.But at least the data in the calendars is safe.

    The loss of the Find feature in iCal is not new, it ocurred in an earlier version. I agree with others that Apple are sometimes happy to release obviously buggy - seemingly with even basic testing neglected - software. Let's hope the cure is in a very short pipeline.
  • Robbie D Level 1 Level 1 (5 points)
    I had this problem too, this is the fix:

    Quit iCal (if it is running).

    Then, from the Terminal, run the following commands:

    $ cd ~/Library/Application\ Support/iCal/Sources
    $ rm */Index

    Relaunch iCal - it will automatically rebuild the Index for each calendar, re-enabling your search.

    Job done.
  • coolnige Level 1 Level 1 (0 points)
    This fix worked for me. Re launched and there are the search results.
    Like the previous posts, I also have been having this problem across 4 computers, each one taking their turn to fail dislaying search results. Big pain when I have the local clubs calendar in the making here. +Thanks Robbie D.+
  • cesargeronimo Level 1 Level 1 (0 points)
    I have tried to do this fix. I do not have an iCal directory in my application support directory. Would it be located elsewhere?
  • Janice Fisher Level 1 Level 1 (95 points)
    How do I put this in Terminal? When I tried, it said "command not found"
Previous 1 2 3 Next