7 Replies Latest reply: Oct 4, 2008 11:01 AM by appleheart
monaya Level 1 Level 1 (5 points)
I popped in a blank dvd as I was going to burn something but decided not to. I on't see the ability to EJECT the disc on the desktop??

I think I must've hit ignore when asked what to do ...

imac, Mac OS X (10.5.4)
  • Kappy Level 10 Level 10 (260,405 points)
    If the disc is showing on the Desktop, then CTRL-click or Right-click on the icon and select Eject from the contextual menu. Otherwise try one of these options:

    1. Restart the computer and after the chime press the mouse button down until the disc is ejected.

    2. Open the Terminal application in the Utilities folder and at the prompt enter:
    /usr/bin/drutil eject
    Press RETURN.


    3. Use the Eject (⏏) button on the keyboard.
  • monaya Level 1 Level 1 (5 points)
    Thanks!
  • Kappy Level 10 Level 10 (260,405 points)
    My pleasure.

    Please mark your topic as Solved.
  • Gary Tamblyn Level 1 Level 1 (75 points)
    I was about to write the very same question. I currently have a Blank DVD in my iMac and it doesn't appear on the screen. I have pressed the eject button several times, this also doesn't work. I realise if I restart I can eject the disk, but that seems like a rather extreme measure to eject a disk !

    Does anyone know of a utility that recognises blank disks (ones that don't appear on the screen) and forces a disk to eject without rebooting. Apple please make the eject button more powerful so it will eject even disks it can't read.
  • Kappy Level 10 Level 10 (260,405 points)
    Did you read my reply to the original query? Solution number 2.
  • Gary Tamblyn Level 1 Level 1 (75 points)
    Discovered it was because I was using VMWare Fusion. Quitting that allowed the disk to be ejected.
  • appleheart Level 1 Level 1 (0 points)
    i've tried all of these options as well as everything else i've found on google so far. nothing happens when i try holding down the track button during start up. my disc is stuck in there and the powerbook won't recognize it at all. please help! !! ! !