2 Replies Latest reply: Oct 17, 2008 9:18 AM by Nathan Williams
Jemster Level 1 Level 1 (5 points)
I'm trying very hard to customize some icons, primarily for a couple of USB pen drives I have. I have the icons I want to use and I am well aware of the usual way of using the Get Info screen of the new icon, selecting the small icon, pressing command-C to copy it, getting the info of the item (drive) I want to change, selecting the small icon and command-V to paste it back in but the results are, at best, random.

I've had the USB drive icon resort back to the default drive icon, I've had the large icon (in the Info dialog) correctly change to the selected icon but the small icon remains as the default drive (yes, tried ejecting and re-inserting the USB key just in case and the effect remains!)

I've had the Icon change to a previously copied icon! (And when I select Show Clipboard from the Finder Edit menu it is displaying the CORRECT icon that I had just command-C'd ??).

Basically the effects are random. After a while, selecting & pasting, I may eventually get it to work (got one of them done! Yay!) and there appears to be absolutely nothing wrong with the USB keys (plenty of free memory, no problem reading & writing to them in any other respect).

Anyone got any thoughts? I don't remember ever seeing this problem on Tiger, is it Leopard specific perhaps? Am I unique?

20" iMac coreduo 2.0GHz, Mac OS X (10.5.4)
  • 1. Re: Really Weird Icon Problem!
    Jemster Level 1 Level 1 (5 points)
    As a quick follow up, I think I've just found out how to get around it...

    If I select an icon, copy and paste it in the first time, it works
    If I select another icon, copy it and try to paste it (to the same drive), it doesn't work...

    HOWEVER

    If I put something else on the clipboard between these two operations - i.e:
    Select an icon, copy and paste it in the first time - it works
    Select some arbitrary text (e.g. in the browser) and copy it
    Select another icon, copy and paste it in - IT WORKS!

    I've tried this 3 times in a row now as I was shocked when it suddenly worked after my original posting.

    Can anyone else replicate this strange behaviour? Is it a clipboard problem? I'd put it down to user error except I now seem to be able to replicate.
  • 2. Re: Really Weird Icon Problem!
    Nathan Williams Level 1 Level 1 (5 points)
    I consistently have this exact problem. I tried your solution of copying other data to the clipboard in between icon paste operations, but it still wouldn't work on my drive.

    What did finally work for me was that I deleted the unwanted icon with 'get info' so the thumb drive icon reverted back to it's default state (the little shiny metallic drive icon), ejected the USB drive, restarted the finder (hoping to clear out that pesky icon still somehow stuck in the system), remounted the USB drive and was able to paste on my desired icon.

    Hope this helps other in case the first method doesn't resolve your problems - there may be differences in our two OS versions which might explain the quirkiness.