Previous 1 2 Next 26 Replies Latest reply: Oct 19, 2008 6:52 PM by Graham K. Rogers
Landon Dial Level 1 (0 points)
My iPod Touch running 2.0.2 wont connect to my wifi even when im standing right next to my router. it saying theres no routers near my house when theres usually 5 or 6. anybody know how to fix this?

Dell, Windows XP
  • shawn10 Level 1 (10 points)
    SAME HERE! My router shows up, but it won't connect to it! It worked FINE until I upgraded to 2.0.2. I took a look at some other threads, and it seams that we're not the only ones having this problem. Some even said the wifi stopped working with 2.0.0 and 2.0.1! But a new update will be available in September. This is just frustrating! I sure hope they get it right this time.
  • Totem Level 2 (405 points)
    What types of routers are you using?
    What type of encryption do you have on your routers?
  • Landon Dial Level 1 (0 points)
    netgaer. it worked fine until i upgraded. now it says it cant find any router though
  • Peter01 Level 1 (0 points)
    Neither 2.01 or .02 works but found that wifi does not work with Netgear router. Works fine in a number of commercial premises and some domestic ones with routers other than netgear
  • t-com Level 1 (0 points)
    for some reason my ipods wifi settings were erased so when i go to connect to a network under the settings screen it says no wifi instead of saying wifi not connected. i also went to general then to network and network configuration but it said that i couldn't configure. any advice?
  • Landon Dial Level 1 (0 points)
    well my ipod connected fine with my netgear router before i updated to 2.0.2.
    it doesnt connect to any. i had about 3 other networks around me, one being linksys and it doesnt show any of them
  • lzrdoc Level 1 (0 points)
    iPod touch connected to all WiFi prior to 2.0.1 "upgrade". After, can connect with home network, but not with work or other networks despite good signal. No improvement with 2.0.2.

    Apple ... are you listening? Please issue another update which fixes the problem, or allow people to go back to 2.0.0 where WiFi worked.
  • artmat55 Level 1 (0 points)
    My daughter received her first Ipod Touch and loved it. Until she loaded Version 2.0.2 then wi fi didn't work. She uses a Windows machine - IBM/Lenovo....I use a MAC BOOK PRO so I did some home work and realize the time has come to go back to the original Firmware on the Ipod Touch. Well, nothing worked and so I called Apple and got a great technician. However after an hour or so - we couldn't get the Wifi to work or take off VERSION 2.0.2. So I read more on the APPLE Discussion and found this train. Well, I too have a first generation LINKSYS - pre CISCO and use WEP 128K. I did the resets as per someone's suggestion and got in and got more than a page or two and then it stopped. I then disabled WEP and now it's working great. So - either I buy a CISCO LINKSYS or I wait for 2.0.3 and see how that goes. So - my advice - don't upgrade the TOUCH yet.
    I am a new user to MAC's - maybe 3 years now. And don't miss my IBM WINDOWs machines, but this is the first - er 2nd time I had problems - Leopard wasn't ez!!!!
  • Totem Level 2 (405 points)
    Did you reset your Touch? Hold the button down at the top, and powerdown.

    You might be having a problem due to your use of WEP. WPA is definitely friendly to Apple products.

    Ok, WEP ... you must use a 13-letter passphrase on your Linksys Router in order to generate a Hexidecimal code that will be recognized by Apple Wireless Products. If you are using WEP 40/64, then you can use a five-letter passphrase.

    Once you have generated the key on the router, use that, rather than the passphrase that you used to generate the key.

    Before doing this, please make a note of your current key
    For example 'posts' will generate the following key: 524336B910
    Or, 'subscriptions' will generate the following key: A95563D3BDABA98122756CD0DE
    (Don't use the single quote marks when entering the passphrase)
  • 2¢ Level 1 (0 points)
    I've been experiencing the same problems accessing WiFi with my Touch. Like all of you, everything was working fine until I upgraded to 2.0.2. At first I've read other thread with people complaining about the same thing. I've tried everything. I had a Linksys WRT54G v3 wireless router. I upgraded the firmware still nothing. Then I started doing everything you could possibly do to the Touch, resetting, restoring. I restored it 4 times, after the first time you have nothing to lose. I called Apple Care and talked to tech. He walked me through the exact same restore steps I had done myself 4 times before. The best I could get the Touch to do was recognize my home network for a few seconds then it drops off. Today, I bought a new router. I bought a Linksys WRT160N and have changed the broadcast width and tried everything else possible, still the same results. At least I had a good excuse to get a better router for my laptop, All the various "fixes" I've read only seem to be bandaids. Disabling my security encryption is a ridiculous option. It worked before with the same encryption. The bottom line is that the problem lies with this so called "upgrade"! I've noticed when I connect my Touch in iTunes under Summary it states to check for a new update on 4 September. I can only hope there will actually be a release that will fix the problem they created then. Good luck everyone.
  • lzrdoc Level 1 (0 points)
    I have now checked my iTouch with 2.0.2 on a variety of open WiFi networks. It works on my home network, on the network at the Apple store and at a food court network nearby. However, it does not work at an AJ's Food Store network, nor with my network at work, the latter which worked fine before migrating from 2.0. On the ones where it does not work, it recognized the network and has a good signal, just doesn't connect. Apple, there must be a software solution and an update to solve the problem for all of us.
  • AlliW Level 1 (0 points)
    I too have been having problems with my iPod touch and my WRT54G V8 router. I am so frustrated right now because after following the various steps mentioned on the Linksys community forum,, following Earthlink's prompts, and speaking with Apple, and Linksys, my iPod touch will still not work. It is connected to the internet but will not download the pages. It is quite frustrating. I have changed from WPA to WEP, I switched the 4th Generated key to the 1st. I've disabled this, enabled that. I've done just about everything. I updated the firmware. I made the switch from a partial bridge to a full bridge. I made sure it is 128 encryption. Still nothing seems to work. Does anyone have any other suggestions? The one thing I have not done is enter the Apple code into the iPod which searches for website...and does supposedly does something on the iPod-- I cannot access the internet with my iPod so this web address does not work. If anyone has been successful, will you please give me step by step instructions? Yesterday I was on the phone with Linksys for about an hour. Before that with Apple for about an hour and they even sent the problem to the engineering department. before that I was having "Live chats with Earthlink. How it is that I can walk into a Bread Co. or Apple Store and immediately connect to the internet with my iPod touch but I can't in my own house?? Everyone seems to think it is someone else's problem so I've gone around and around. Not one of the Linksys support personnel suggested I look here on their community forum and I only happened upon this forum because I was reading the forum on the Linksys site. I had to pay a $9 fee to have advanced Linksys help but still my iPod does not work and when I called back, the man I spoke with seemed to think the case was closed because my PC, Laptop, and iPod are connected to the internet -- the iPod just won't download the webpages or get mail. I would appreciate any help on this matter. Thanks

    Perhaps is there a router out there that works with a PC, MacBook, AND iPod????
  • wolfboy2712 Level 1 (0 points)
    I have a D-Link router, I just got it secured the other day, and now my ipod wifi doesn't work. I can see networks, I type in my password, it accepts it, but nothing after that works. I go to safari, it says it can't connect to the server, and many other apps keep asking me if I'm connected and online. When I look at the details of my wifi, it only shows the IP address and Subnet Mask. It uses a 9 letter password, and I'm pretty sure it's a WPA. How do I fix it?
  • microgerble Level 1 (0 points)
    What i did on my d-link router was turned mac w/e on and hid the network and made it ad-hoc so it's just a access point!
    It's weird it worked on my g-ma's router same encryption and everything, d=link and all too but hers is only wireless g and mines wireless N.
    I have it set to broadcast all of them though!
Previous 1 2 Next