5 Replies Latest reply: Mar 31, 2009 11:53 AM by jbinchgo
xabbess Level 1 Level 1 (75 points)
Hello,
I'll try to keep this brief. I'm trying to help my brother with a problem that arose today with his Lacie DVD/CD burner. He uses a Mac G4, firewire 800. It quit recognizing media. Same (blank) media as he's always used, but it says that the disk is full. Wouldn't even recognize a movie he had created and burned onto the DVD, using the same burner in question. His computer recognizes the Lacie. He went out and bought a brand new Lacie today and he has the exact same problems, so we're assuming it's his computer and not the Lacie? This is so puzzling, since before today he had no problems. If anyone out there has any suggestions, we'd surely appreciate hearing them.
Thank you in advance.

24" Alum. iMac 3.6 MHz, 5th gen.iPod 30G video, 16 GB iPhone, Mac OS X (10.5.4)
  • american gaucho Level 1 Level 1 (0 points)
    I am having the same problem with my computer, I know its not the dvd burner I can burn a dvd on another machine old g3 with panther using the same media and cables and burner. This is the same equipment that would not work in my imac g5 with 10.4.11
  • johnny apple-to-the-core Level 1 Level 1 (0 points)
    xabbess, did you figure this out?

    I am experiencing the same issue with my Lacie DVD burner (LaCie 20x d2 DVD±RW with LightScribe) not recognizing certain blank media. It will only recognize and burn DVD-Rs, and even that only works sporadically (I've tested DVD+Rs & -Rs from various brands recommended by Lacie). I've tested it on the two computers I have - a Mirrored Door Dual G4 and an iBook G4 both running 10.4.11 at the time - with the exact same results. But it did seem to work fine on an Intel iMac at the tech support office at the place I bought it at (MicroTech). So, I'm thinking the DVD burner is okay and that maybe it's just a compatibility issue with my computers or the OS I'm using.

    So, I'm wondering if anyone out there has experienced this, and has figured out the problem. I've just recently installed Leopard 10.5.5 on my iBook G4, but I haven't had a chance to test the DVD burner on it. When I do, I'll post the results.
  • johnny apple-to-the-core Level 1 Level 1 (0 points)
    Okay, I've tested the DVD burner on my iBook with Leopard on it. It worked slightly better. It recognized more blank media, but it was still finicky and wouldn't recognize some discs from the same pack. And when I tried burning a disk it would get through burning the data fine, but verification would always fail.

    So I still haven't figured this out. Is there anyone out there that has this DVD burner that is working fine for them? If so, what system do you have? I'm hoping my DVD burner will work better on a new Mac - I'm planning on getting a Mac Mini in January 09.
  • Brad Cantos Level 1 Level 1 (130 points)
    I am having the same problem as well with my LaCie d2 DVD/CD burner with LightScribe, but it seems to happen only in iTunes. The drive tries to initialize the disk and then hangs. When I manually remove the disk, it is completely unwritten. This doesn't happen with another external drive. LaCie tech support is useless and won't even help to resolve the problem. Any thoughts?
  • jbinchgo Level 1 Level 1 (0 points)
    My LaCie d2 Dual DVD /CD drive with Lightscribe worked fine for a year. I was able to burn photos, music and data with no problem. Now I have the same problem as many of you but only with blank disc. The drive reads both commercial and home made discs but when I insert a blank disc, I can initialize it but then I get a message "You cannot burn this disc in the Finder because the disc drive is not supported". There is no icon on the screen so there's no way to eject the disc. When I contacted LaCie they recommended that I disconnect the unit from the computer. This got the tray opened and I was able to retrieve the blank disc. I have sent the drive back to LaCie twice but the problem persists. LaCie also recommended I go to System Preferences, then to CDs & DVDs and set Open finder when blank disc is inserted. The problem persists. Don't know where to go from here.