Previous 1 2 3 Next 222 Replies Latest reply: Dec 17, 2010 9:07 AM by dshalky
Matnoz Level 1 Level 1 (0 points)
My laptop can find my router network fine. I reseted my router and Iphone but my iphone still cant find any routers. I reseted the network settings too. If I try to put in the name and password manually it just says "Joining InsertNetworkNameHere" Over and over, with no results. Any suggestions?

It is an iphone 3g firmware 2.0.2

OH the router is a Belkin N Router

Message was edited by: Matnoz

Iphone 3g, Windows XP
  • deggie Level 9 Level 9 (50,805 points)
    Make sure the Belkin is not set to only "N". The iPhone 3G only has b/g and cannot see n.
  • Matnoz Level 1 Level 1 (0 points)
    nope still not working
  • kamil1980 Level 1 Level 1 (0 points)
    I have the same problem. Suddenly my iPhone 3g can't find any wifi network. I have restored factory configuration but still the same. Yesterday my iPhone could find 4-5 wifi networks including my own now not even one. I have updated to 2.02 a few days ago maybe that's the problem. Any suggestions? Is my iPhone broken or there is wifi problem with 2.02 firmware?
  • viking99 Level 1 Level 1 (0 points)
    am having the same problem. all was working well up till yesterday. then the phone said " not connected" then after reset "no wifi", reset again shows "not connected" . I have a mini setup sitting right beside it with no problems wih the network
  • loubylu Level 1 Level 1 (0 points)
    i am having similar probs....
    I am hoping someone here can help me. I'm not a wiz with technology but here goes. I bought my iphone3g a month ago. It never seemed to connect to the wifi i searched on here and someone posted a message about putting a number thread on the dns bit of wi fi details it was fantastic worked great I was very happy. The problem has evolved after 2.0.2 update. Or at least I think that is why it's happened. Now my phone will not connect to my wi fi at home (it's a bt voyager 2500v-3b model). under wi fi settings the voyager is there with a tick next to it.Wi fi is on. In settings-general-network it is there. But my wifi will not work. the signal for it does not show up on my phone. The wifi is working because I'm using right now on my laptop) I've tried turning airplane mode on and off...turning phone on and off...iphone restore...i've tried 'forget this network' and starting again but nothing!! When i use safari it seems to be really slow but thats because the phone is using the (not edge/3g..the other one sorry cant remember its name) network. Is this a 2.0.2 issue? it worked brilliantly before i wish i had never updated new version. PLease if anyone could help me. I loved my i phone before its capabilities were great.. but now it doesn't do what i loved about it.

    Any help would be much appreciated.
    Many thanks from a disheartened iphone lover
  • Ario Arioldi Level 1 Level 1 (0 points)
    I have a similar problem: at home I have an iMac and a MacBook Pro conncted to a WiFi network (Netgear router) working perfectly.
    The iPhone 3G, on the contrary, most of the time is unable to see the WiFi network.
    I've already resetted the iPhone to factory conditions several times but unsuccesfully: sometime I can see the network (WEP protcted) and connect but afterwards the network disappears from the iPhone without any apparent reason.
    Ario
  • Nick Harrison Level 1 Level 1 (0 points)
    My iPhone (1G) cannot find my home wifi either! I tried the airplane mode on/off to reset the network, nothing. Restarted my iPhone, nothing. Based on your replies I'm not even going to try to restore it. I hope this gets fixed with the soon to come update (friday, right?).
  • I love my macbook!!!! Level 4 Level 4 (1,415 points)
    Me too! The problem is that this only happened after I restored the iPhone. Sounds fishy. Please help! I really need to get internet access.
  • melmobarrie Level 1 Level 1 (15 points)
    I am struggling with this too. My brother and sister have ipod touches and theirs each work fine on my home network. I got an iphone last Tuesday, had to get update to start, won't connect to my home network. Have tried all above ideas and nothing.
  • almerchant Level 1 Level 1 (0 points)
    My 2g after a 2.1 upgrade wont show any wifi spots
    HELP
    AL
  • Spud379 Level 1 Level 1 (0 points)
    Wow, same for me. When I click wi-fi, it says not connected. When I click on the wi-fi button it won't load any. Hopefully, this will be fixed since i just got a replacement iPod Touch yesterday. I also here that it is not working on the 2G iPod Touch as well. Hmmmmmm... help anyone?
  • Rodrigo L Level 1 Level 1 (0 points)
    Bad that there are no answers to this forum. My iPhone (2g) does not recognize any wifi network at all, i tried everything, reinstalling, resetting and nothing, I have it upgraded to v2.1 but now with no internet. its a pitty it makes this very nice gadget untrustworthy, specially reading that 3g is having the same problems. Or is there an answer somewhere there?
  • jeankalud Level 1 Level 1 (0 points)
    Same here, and cannot find any answer that work, tried a lot...
  • I love my macbook!!!! Level 4 Level 4 (1,415 points)
    Perhaps it's the receiver in the iPhone itself. It only supports 802.11b/g. Does that sound like anything?
Previous 1 2 3 Next