6 Replies Latest reply: Sep 21, 2008 11:47 PM by icebike
luckyguy9 Level 1 Level 1 (0 points)
Since installing 2.0.2, my WiFi keeps turning itself off and I have to manually turn it back on several times a day.

Also, WiFi finds a network that is not locked or secure, asks if I want to connect, then when I try it displays a pop up window saying "unable to connect" What's up with WiFi??

iPhone 3G
  • gere79 Level 1 Level 1 (0 points)
    exactly similar problem here. since upgrade my iPhone 3G to 2.0.2, my WiFi keeps turning itself off and I have to manually turn it back. And, when I select a network that I want to connect to, it says connection successful, but it still remains on 3G network !!! Anyone?
  • Kloobers Level 1 Level 1 (0 points)
    Same exact problem. I have been trying for two days to get my WiFi to work. I upgraded the firmware on my router and my iPhone was able to connect, but only for about an hour. Now it's the same thing, can't connect.
  • icebike Level 3 Level 3 (740 points)
    Same problem on this thread:
    http://discussions.apple.com/thread.jspa?threadID=1674116&tstart=0

    My problem happened before 2.0.2, so I don't think its a 2.0.2 thing, but I can't be sure.

    What I found is if I let the Iphone fall asleep by itself while looking at any web page that might try to refresh, or with my mail open which might try to refresh, those refresh attempts would happen before the wifi came up again.

    When the phone tries to power up its wifi, it seems to get in an argument with Edge (or gprs) which is being used to refresh web pages or mail, and can't get the wifi connection.

    Shutting down the phone, or at least clicking the home button before allowing it to fall asleep tends to minimize this.

    There are still cases where the background mail fetching just happens to be active when I light up the phone and i fail to get a wifi connection. In this case, turning off wifi and back on again in the settings is the quickest solution.

    Much of this is my impression due to trial and error. But top-button sleeping the phone when not in use definitely helps. Ymmv.
  • Cjuprotennis Level 1 Level 1 (0 points)
    tryturning on airplane mode then connect to your wifi network =)
  • bschellenberg Level 1 Level 1 (0 points)
    Same problem, restated:
    Wi-Fi turns itself off. I notice this only after waking the phone up after some period of inactivity. It never just disconnects when I'm using it. It happens in whether I'm moving to different locations with different Wi-Fi networks, or whether I'm sitting in the same spot all day.

    Current fix:
    - Go into Settings, turn Wi-Fi on.
    - Wait for my network to show up and get a check mark next to it. Even now, the upper left status display shows E for edge, instead of the Wi-Fi icon.
    - Enable and disable Airplane Mode. This seems to force the Wi-Fi connection to be established. The Wi-Fi icon appears in the upper left status bar, and Safari pages load at the expected quickness.

    After doing this, and leaving the phone asleep for some amount of time, Wi-Fi will again be disabled.
  • icebike Level 3 Level 3 (740 points)
    First, Wifi goes off anytime your phone is asleep. When you wake the phone, even before you slide the un-lock slider, you can watch for the appearance of the Wifi icon. It can take anywhere from 1 to 10 seconds, with three being the average. IF it takes longer, it will probably silently fail.

    If you start a task that requires a network connection before wifi appears, then wifi will not work till you stop all network traffic.

    If the Edge radio fires up and starts talking before the wifi gets going, it will block the wifi from working. (I believe this is a software bug, its easily demonstrable starting a long-mail download on Edge, an then turning on Wifi. It will fail till edge stops transmitting. Hold the phone near computer speakers so you can hear the Edge chatter in the speakers.)

    There have been several reports that the high-numbered channels on a wifi router seem to cause problems for the iPhone. If you control the router, lock it down to a low numbered channel, like 1 thru 6. Lower is better as it gets you out of contention with other types of house phones, and it penetrates walls better.

    If you own the router make sure you have a unique SSID (don't leave it saying Linksys). Also, don't use multi-mode if you can avoid it. The iPhone likes 180.11G, not A, or B, and not N.

    For encryption WPA2-Personal (AES) is the most reliable and fastest negotiating encryption. (Its all done in hardware).

    Its best to select a Fast starting Wifi protocol.