Previous 1 2 Next 20 Replies Latest reply: Nov 15, 2008 9:49 AM by Silver6d_Mac.Com Tanner
Arieder Level 1 (0 points)
Hello, I bought a new iPod touch, for a few hours the wifi worked fine, I had about..4 applications installed (no I did not jailbreak the touch), but then all of a sudden it lost the wifi, and couldnt get it back. I turned on broadcast SSID and it sees it, I connect to it, it says connected for a few seconds, then boom it disconnects and loses the network. The router works fine with my wireless laptop.

The router is a linksys wireless G. I also upgraded the iPod to 2.0 software.

Thanks...hope someone can help.

Windows XP Pro
  • shawn10 Level 1 (10 points)
    Your problem is the upgrade. A LOT of people are having problems with wifi since they did the update, including me. Just wait until 2.1 comes out in September. No official release date was promised for this release. We just have to wait. I know it ***.
  • Arieder Level 1 (0 points)
    Dang...that really I'm guessing there is no way to get the Wifi working again? Are they stating early September, mid, late? (ah sorry just saw what you said about no release date) And will it be free?

    Thankyou for your response.

    Message was edited by: Arieder
  • Duddo Level 4 (1,470 points)

    Don't give up straight away, try a few things first (if you haven't already)

    1. "Forget network" on the Touch then set up again and try.

    2. Reboot your router.

    3. Check you have the latest firmware on your router, update if necessary.

    Your wireless may not be working but lots of us are having no problems, so I think yours should be fixable even before any new Apple update.

    Good luck,

  • Arieder Level 1 (0 points)
    Thanks for the advice but unfortunately I've tried them all .
  • shawn10 Level 1 (10 points)
    Yes... it's really annoying. I have tried everything to try and bring back wifi with no luck. We just have to wait... 2 weeks!
  • KatSexiNikki Level 1 (5 points)
    I came onto this site looking for a solution to this very same issue. Ever since I updated my Ipod Touch to the 2.0 Software update. I now cannot stay connected nor see as many available WiFi networks as I used to. So I see that most of the complaints about WiFi have started after this stupid update that I had to pay for which totally adds insult to injury. I truly hope this get resolved. Is there a way to let Apple know that this issue exists?
  • Arieder Level 1 (0 points)
    I tried to find a contact email because it is a pretty big inconvenience but I have yet to find it .
  • Arieder Level 1 (0 points)
    I'm really tempted to downgrade the firmware.....but then i'd have to buy it again when 2.1 comes out :/.....ahhhh WHY APPLE, WHY.
  • Mel Magree Level 1 (20 points)
    I can get WiFi if...

    If I'm accessing a closed network, either a password protected network or a filtered network. For example, I can access my home network. I can also access a network which requires me to register.

    But if I'm accessing an open network, I get nothing. The settings show a strong signal for the network, but the Safari progress bar stops on "http". On the other hand, I can easily access the same network with my MacBook Pro.

    Somewhere I saw a reference to needing a "Client ID", but how many baristas know the details of their coffee shops WiFi?
  • 2¢ Level 1 (0 points)
    I'm relieved and angry after reading this thread. I'm relieved to see that I am not the only person experiencing this problem. I was trying everything I could think of. I reset my Touch and of course lost everything on it. I knew it had to be the Touch because not only did it not recognize my home network but it doesn't recognize ANY networks! What makes me angry is that they released this bug filled update and we have to wait weeks for them to fix it? What a complete joke. It would be nice if they reimbursed us all for the hassle and the frustration! Of course that isn't going to happen though. I just don't understand what they were thinking? At least I know I'm not alone.
  • dren72 Level 1 (0 points)
    I have 2.x and had problems with my secure WiFi. The following worked for me and maybe it can work for you:
    1. Turn off IPod Touch. Hold down on Sleep/Wake button until power off screen pops up and then slide to shut off.
    2. Perform soft reset (Hold Sleep/Wake button and Home button together until Apple logo appears - about 10-15 sec.)
    3. Goto Settings, Wifi and Turn on Wifi.
    4. Goto Settings, Wifi, Turn off "Ask to Join Networks"
    5. Select network (the one that you are having trouble) and select "Forget Network" and confirm when prompted.
    6. Select Join Network and turn On
    7. Select desired Network (and enter password if network is secure).
    8. Save and Close; Look for Wifi icon
    9. Goto ITunes store and see if it loads.
    10. Good luck.

    It took me a lot of persistence but I finally solved it. Maybe it can work for you.
  • Mel Magree Level 1 (20 points)
    Hi, dren72,

    I printed out your "recipe". I'll take it with me tomorrow when I go to the corner coffee shop to pick up a newspaper. We'll see if it works on open networks.

    With all this fussing around, I managed to reset access to my own network and wondered why nothing happened. I had typed in the password incorrectly and, even looking at the "big numbers" as I typed, didn't realize it. When I typed the password correctly, I was back online.
  • Mel Magree Level 1 (20 points)
    I tried your suggestions as much as I could at the corner coffee shop, but they didn't help.

    I didn't follow them exactly because I misinterpreted turn WiFi on as turn it off. But when I sort of made up for that, I could not access it.

    I realized my mistake when I came back home, went back to the coffee shop and tried again. Unfortunately, the signal was now one bar, and so I'm not sure that I've proved anything.

    As I came back home, I searched for my network. I found it almost at my front door and with a strong signal. I walked around the outside and the access would come and go. Every time I could get access again it was always strong, even as neighbors' networks varied in signal strength. So, I couldn't double check if I would have gotten through with a weak signal.

    So, I can access the web on my iPod touch on a closed network but not an open network.

    I can access it at home with an ActionTec GT701-WG DSL modem. I can access it with a coffee shop provided access to ClearWire, a wireless Internet provider. This latter requires registration at hotspots.

    I have software version 2.0.2 (5C1).
  • Arieder Level 1 (0 points)
    The thing I'm worried about is what if it is NOT the update for me...what if it is something to do with the hardware. I downgraded to 1.4 to test and see if it worked, but no luck, I still had the same problem...but when I had 1.4 before it worked, then a few hours after using 2 it stopped working. However I can SOMETIMES still see my wireless network, click to connect, it connects for a few seconds then boom network is gone >.>, so I'm not sure if its my hardware or software....
Previous 1 2 Next