3 Replies Latest reply: Sep 20, 2008 9:42 AM by tjp613
[macbooker] Level 1 (0 points)
Just today I noticed both USB ports on my MacBook have stopped working properly. I normally have a Targus "Notebook Cooling Chill Mat" connected to one of the ports (neither one specifically). I don't think it's the source of the problem as it only draws 25 mA or so.

Today I connected my camera, a Canon PowerShot S5 IS, directly to my MacBook after taking some photos. I had to manually launch iPhoto (6.0.6), and when I did it brought up the import screen but said there were no photos to import. I opened USB Prober and the camera did not appear until a few minutes later (set to refresh automatically, and I was clicking the button). USB Prober said it could have been "suspended." Its listing did not disappear when I disconnected the camera. iPhoto also appeared to believe that the camera was still connected. I right-clicked the camera in the source list and unmounted it there.
Next I got a card reader (SanDisk Extreme USB 2.0 Reader which I know to work) and tried that. iPhoto recognized it as the same camera I plugged in before and again said there were no photos to import.

Next I went to the iMac and plugged in the card reader and a flash drive (PNY Attaché 1 GB) and transferred the pictures to the flash drive successfully. However, when I plugged this into my MacBook, it did not mount and Disk Utility couldn't see it either.

I plugged in my SanDisk cruzer mini 256MB drive (removing the Attaché because they don't fit side-by-side) and the light on the end lit up, but neither it nor my MacBook showed any signs of recognizing each other. I restarted my MacBook, but this did not help.

The ports can still supply power, because the fans in the Chill Mat still spin when I plug it in and the light on the cruzer mini lights up.

MacBook1,1, Mac OS X (10.5.3), 2GHz Core Duo, 1 GB RAM