6 Replies Latest reply: Aug 31, 2008 4:30 PM by Katrina S.
Northwest_nance Level 1 Level 1 (0 points)
Just got a new computer. Decided that instead of loading my music from backed-up DVD's, I'd start fresh, so I loaded every one of my CD's onto the computer individually. Downloaded iTunes and when it asked if I wanted to import my music, I said yes. It then went through hours and hours of converting the songs and when it was done, my iTunes library listed every song at least twice.

I deleted the iTunes music file and tried another way -- I copied all of the music from My Music into the iTunes music folder. It went through the same routine... hours and hours of converting the music and once again the iTunes music library lists all of my songs at least twice.

I've loaded iTunes onto 3 new computers over the last 5-6 years and have never had this problem. Can anyone advise? The only solution I've found so far is to go in and manually delete each duplicate, which is going to take forever and I don't think it's something I should have to do.

Dell XPS 630, Windows Vista
  • Katrina S. Level 7 Level 7 (24,090 points)
    Are there duplicate music files on your PC's hard drive, or just duplicates in the iTunes library?
  • Northwest_nance Level 1 Level 1 (0 points)
    When I go into my iTunes music folder in My Documents, each song is only listed once. It's also stored in my "My music" folder so each song appears to be on my computer twice, but only once in the iTunes music folder. And listed twice (sometimes 3 times) in my Library when I open up iTunes.
  • Crock52 Level 1 Level 1 (0 points)
    I have the same problem ,the music library has been duplicated three times and when syncing to Ipod also it also duplicates , have you got a solution to fix
    this
  • Katrina S. Level 7 Level 7 (24,090 points)
    It might be easiest to start over with a new blank iTunes library. Hold & press the shift key while starting iTnues, as per these directions.
    http://docs.info.apple.com/article.html?path=iTunesWin/7.6/en/15502.html

    Then add all the songs from the "iTunes music folder".

    Up to you whether to delete the duplicates on your hard drive that are in "My music".

    I think what happened was, the music was originally in the "My music" folder. Your itunes preferences were set to "Copy files to iTunes Music folder when adding to library" so that's how you got the duplicates on your hard drive.
  • Northwest_nance Level 1 Level 1 (0 points)
    I have already tried that. When I first downloaded iTunes to my new computer, it asked if I wanted to import all my music. I said "yes" and it went through about 5 hours of converting music, and when it was done, my iTunes library listed all my songs atleast twice.

    So I deleted the iTunes music folder (so when I opened up iTunes, it didn't list ANY songs in my library). I made sure the box that gave me the option to copy songs into iTunes library, was NOT checked. I then went to My Music, selected the files, and dragged them to the iTunes music folder. Once again it went through hours of a conversion process and then listed each song at least twice in the iTunes library.

    Is my mistake that I am copying my songs to the iTunes library? If I'm not supposed to do that, how do I get music into the iTunes library? This is the 3rd or 4th new computer I've installed iTunes on in the last 4-5 years and I've never had a problem like this before.... it's getting frustrating!
  • Katrina S. Level 7 Level 7 (24,090 points)
    +Is my mistake that I am copying my songs to the iTunes library?+
    No, you said you turned off the "Copy files..." setting I mentioned above.

    There is a difference between adding music to the iTunes library database, and copying files to the iTunes music folder.

    So what's happening is probably iTunes is determining gapless playback info. I don't know for sure, what does iTunes say when you just add one song? If it's the gapless playback info that it is determining, there is NO WAY to turn this off, unfortunately. It's a rather new "feature", so you never saw it 4-5 years ago.