2 Replies Latest reply: Sep 18, 2008 5:43 AM by Amanda Winton
Amanda Winton Level 1 Level 1 (15 points)
Hi all
I downloaded the upgrade today to 2.0 and while the install was running - it froze. Only option was a force quit - now my iPod won't restore. If I plug it in, it recognises the iPod, prepares the iPod for restore but then gives me the error '*the iPod 'iPod' could not be restored. An unknown error occurred (2005)*'. I have tried resetting but this only gives me the same result. Quitting iTunes does nothing either.

Does anyone have any suggestions? do I need to try and reinstall and earlier version of the software?

Also, does this mean I lose the download I paid for today - as the downloads folder does not show anymore in iTunes I'm not sure where I would be able to find it?

Any suggestions would be greatly appreciated!

Powerbook G4 15" 1.67GHz, 2GB RAM, iBook G4, iSight, Airport Express, iPod Touch, Mac OS X (10.5.4)
  • JMistry Level 1 Level 1 (0 points)
    I seem to be getting the same error, I attempted to update to firmware 2.1 on my touch, update was progressing well and towards the end when it was verifying the firmware I received error (9). Tried to restore as it suggested but this failed with error (6). I disconnected and tried to attach it to my XP laptop and now I keep receiving message "An unknown error has occurred (2005)".I have done the following to try and resolve it with NO JOY!
    1. Re-install itunes
    2. Re-installed the usb drivers
    3. Tried connecting with minimal usb connections

    Help in this matter will be greatly appreciated.
  • Amanda Winton Level 1 Level 1 (15 points)
    Hi, hopefully I have the answer for you!
    After numerous attempts at reinstalling iPod software and itunes, a visit to the Genius Bar and a new iPod (c/-apple) I was still having the same problem. Turns out that for some reason 2.0 wouldn't recognise some of my music. So I started with a brand new empty playlist and imported and updated one album at a time. It appears that around 2GB of my music is now unrecognisable or donwloadable to the iPod (I will state here that it is all valid music from CD's). So not really sure what's happened, but now everything is working fine and I am not getting the error anymore (although those problem albums I can't get onto my iPod until I try reloading them onto my machine again). My suggestion would be to split your playlist into 2 and then try and update one half, then the other, if neither updates then make yourself a cuppa and painfully drag and update one album at a time. (the first few I did didn't work either so be patient until you find one that does if it isn't immediate).
    Hope this helps. I did find the guys at the Genius Bar quite helpful, although I did go twice, the first time without my laptop and the second time with it - if you go I recommend taking your laptop along with you.
    I think the error messages are completely random though - over this whole process I had in excess of 15 different errors and it turned out to only be one thing!
    Good luck
    Amanda