6 Replies Latest reply: Sep 9, 2008 1:53 PM by Raleigh D.
mont3 Level 1 Level 1 (0 points)
Hi,

I created a number of contacts on my Macbook Pro as husband and wife with two mobile numbers (eg David and Carol). Finding that this makes it difficult to know who's contacting, I've copied and pasted to produce a duplicate contact and then changed the names so that I now have David as one contact and Carol as a separate contact.

BUT, when I synced my iPhone (1st Gen with 2.0 - just bought), the contacts on iPhone all show up as my 'old' contact list - David and Carol instead of being two individual and independent contacts, have reverted back to one contact (eg. David & Carol)

Does anyone have any suggestions for correcting this - it's a REAL pain!

Regards,
M

Macbook Pro, Mac OS X (10.5.4)
  • C Jones Level 1 Level 1 (5 points)
    I'm having the same problem. I've created contacts on my iPhone which are not showing up as contacts in my address book. I dabbled with MobileMe briefly - both contacts and calendar; however, I pulled my contacts off of MobileMe. Now, I can't seem to get my contacts to get in sync.

    Again, I've created new contacts that are not showing up on my cpu. Please help.
  • mont3 Level 1 Level 1 (0 points)
    Hi there,

    I spent 2.5 hours in the phone with Apple this morning and my problem is now solved:

    They discovered that my address book contacts were corrupted (possibly through my Nokia N95 8GB).

    This is what we did:
    1: In Address Book, Clicked on FILE, EXPORT, EXPORT vCARDS (save it on the desktop when it asks for location). This keeps a record of the important data from your contacts - VERY IMPORTANT.
    2: Delete everything, including folders from Address Book
    3: Go to FINDER, LIBRARY, CACHES and delete: com.apple.Address Book
    4: Go to FINDER, LIBRARY, PREFERENCES and delete: com.apple.AddressBook.plist
    5: Go to FINDER, LIBRARY, APPLICATION SUPPORT and delete everything in there (you can drag the IMAGES folder to desktop to save your images if you like).
    6: Open iSync and click on FILE, PREFERENCES and RESET the sync history.
    7: Almost there, go back to Address Book, click on FILE, IMPORT, vCARDs (locate the saved vCard on desktop). Once it has imported your contacts you'll need to recreate any folders you had.
    8: Plug your iPhone into your Mac, Click INFOR tab, and next to CONTACTS click on selected groups - your created groups will show here (make sure all your contacts are in groups). In the 'Put contacts created on this phone . . .' TICK the box and select where you want contacts created on the iPhone to go (I out mine in a folder I created called GENERAL.

    That's it - Click on SYNC and it should work.

    My iPhone then worked properly - contacts sync perfectly both ways.

    All the best.
    M
  • cmigacz Level 1 Level 1 (0 points)
    Fixed the problem -- worked perfectly. thanks for the hard work...
  • mont3 Level 1 Level 1 (0 points)
    Hi there,

    You're welcome!

    Hey, ever wondered what life's about . . . ? Checkout: www.whatslifeabout.com

    Best regards,
    M
  • Hurangeshu Level 1 Level 1 (0 points)
    OK, I tried this - the whole list of instructions - and there is still one contact in my address book that +will not+ appear on my iPhone. Why just one?

    Any other ideas? This is endlessly frustrating.
  • Raleigh D. Level 3 Level 3 (715 points)
    Hurangeshu,

    Have you tried deleting and recreating that contact in Address Book?

    Hope this helps,

    Raleigh