12 Replies Latest reply: Sep 10, 2008 10:42 PM by TantraYogi
TantraYogi Level 1 Level 1 (0 points)

I recently switched to Airport Extreme (AE). My setup is:

MacBook Pro - Ethernet & Wireless to AE
Macbook - wireless to AE
PC - Ethernet to AE
Two printers - USB to AE
Seagate Hard Drive (300 GB, P/N 9Y7865-560) - USB to AE
I am using a powered USB Hub between the AE and my printers and HD

I can see and use both printers from all computers. I cannot see the hard drive (HD) from any computer. It shows up in the Airport utility's disks tab as:
279.5 GB ST330063 1A 3.04

One possible bit of important info: Before, with my D-Link router, I was using the HD as shared from the PC and I could see it on all machines. All I did was move it directly to the AE. I also plugged the HD directly into my MacBook Pro and it works fine.


Macbook Pro & Macbook, Mac OS X (10.5.1)
  • clockworks Level 2 Level 2 (380 points)
    Since Airport Utility can see the HDD, it's basically working.

    I assume that AE with HDD works like TC.
    When you say you can't "see" the HDD, how exactly have you been trying to use it? Have you tried connecting with Finder - it should show under network or shared.

    Maybe it's a format problem. IIRC, I couldn't use an NTFS HDD with TC, needed to be extended journaled.
  • Anann Level 1 Level 1 (10 points)
    As the post from clockworks suggest,I would try to connect using the finder,on my macbook I open up finder and then in finder sidebar under the heading shared it has the Airport Extreme,click on this and it then shows my connected usb HD.If none of this is showing in finder you may have to open the finder preferences from the toolbar and then tick some boxes under sidebar/shared until you can see it.You will be using as shared as you did before because its plugged into the AEBS and all devices connecting will be able to access it unless you put a password on it in airport utilities.
  • TantraYogi Level 1 Level 1 (0 points)
    Thanks clockworks and Annan for your replies.

    I have tried to see it in finder with no success, incl Annan's suggestion of changing preferences for shared. When I plug it directly into the USB on Macbook Pro I see it under devices. It is NTFS. Is that a known requirement that it must be re-formatted? I was previously using in on a PC as NTFS and would like to keep all the data. If I must reformat the only choice is copy all data elsewhere then reformat, correct?
  • TantraYogi Level 1 Level 1 (0 points)
    One other point - Will I be able to see my HDD from a PC later if I reformat now?
  • clockworks Level 2 Level 2 (380 points)
    Like I said, I think that I had the same problem - an NTFS formatted HDD wouldn't work with a TC. Reformatting extended Journaled fixed it.
    Copying the data somewhere else, reformatting, then copying the data back on should fix it.

    With the TC, PCs are able to read and write to Mac formatted disks no problem. The controller board in the TC actually handles the reading and writing, converting the data from the Mac format disks into standard network "packets" that can be understood by just about any computer.
    I assume that the AE works the same way.

    So, while the HDD is connected to the AE, your PCs will read and write fine. You won't be able to connect the HDD directly to the PC using USB.

    Message was edited by: clockworks

    Message was edited by: clockworks
  • TantraYogi Level 1 Level 1 (0 points)
    Thanks so much, clockworks. I reformatted to extended journalled and I can see the drive from both macs. So that's all great.

    I do not see the HDD from the PC, however. Do I have to do something else for that? The PC is connected by ethernet to AE and I can use both AE printers from the PC. But I can not find the HDD in Windows explorer. I re-booted the PC - that did not help.

  • clockworks Level 2 Level 2 (380 points)
    You need to configure the AE - again, I assume that it's the same as a TC....

    Run Airport utility, and click "manual setup". Click "disks", "file sharing". Tick "enable file sharing" and select "read and write" in "Airport disks guest access".

    Change "workgroup" to whatever your Windows PC calls it's network (take a look in Explorer/networks). In my case (XP Home) the workgroup is called "Mshome" by default.

    Save the settings, and it should now work with your PC.
  • TantraYogi Level 1 Level 1 (0 points)
    Clockworks, you rock. Everything you said works...just one more issue. See it in network/mshome but it asks me for a user name and password. Now what?
  • reptilejoe Level 1 Level 1 (0 points)
    I had the same problem and the info in this and other posts helped but didn't completely solve the problem. The final piece of the puzzle was my TC's name.

    When I setup the TC I have it a long name like, "reptile joe's time capsule". The name worked great in Mac-land but it would not show up from my Windows machines. I renamed it to something that Windows would swallow, (8 or fewer alpha/numeric characters, no spaces and most special characters). Works great. I can also get to it from my Fusion VMs.
  • TantraYogi Level 1 Level 1 (0 points)
    Thanks Reptile-Joe. That did not solve my problem. It's on the PC. When I click on the name of my AE in (XP) Windows Explorer, I get a pop-up window asking for user name and password. I'm so close...
  • clockworks Level 2 Level 2 (380 points)
    I get the same thing - pop-up window asking for name and password. Once I've entered the name (user name seems to be the account name, normally the first part of the TC or AE's name that shows in Finder) and password (password is the one that you used when you set up the TC/AE using Airport Utility), everything works OK.

    I've not managed to find a way of stopping this pop-up. The TC/AE won't work without a password. Macs remember the login details in the "keychain", but Windows PCs don't seem to have this kind of facility in this case.

    Just a thought, but I wonder if using the same account name and password on the PC as was used on the Mac that configured the TC/AE would allow instant access?
    It could be that the pop-up only occurs for guest access (i.e. a different user name). When I access it from my iMac (which I used to configure the TC), I get straight in. When I access it from my Mini, I get the pop-up, but all the details are pre-filled. From a Windows PC, I get the pop-up and have to enter the details.

    If I was logged on to all the machines with the same account name, I maybe could get in with no pop-up?
  • TantraYogi Level 1 Level 1 (0 points)
    Thanks again, clockworks and everyone who helped. Success is very sweet!