8 Replies Latest reply: Sep 30, 2008 12:22 PM by John Willoughby
rickhoro22 Level 1 Level 1 (0 points)
I just installed Google Chrome and Safari 3.1.2 on two different WinXP SP2 machines. On both machines I installed Chrome first and then Safari. I don't know if there's any relationship between my problem and the Chrome install, but I can't open any web pages on Safari on either machine. All my other browsers work normally, IE, FF, and Chrome. I tried this with no other browsers running and no difference.

The error message is "Safari could not open the page "http://www.apple.com/startpage/" because the server is not responding."

Any ideas on what may be going on here?

Thanks,

Rick

Dell Inspiron 8600, Windows XP Pro, other system is a Toshiba Portege
  • J~G Level 1 Level 1 (85 points)
    Hi and welcome to the Apple discussions forum!

    If you do have a firewall installed? Then do you need to allow Safari
    in the firewall configuration to connect too the internet.

    If not, then more information please.

    Cheers, J~G
  • phelanpa Level 1 Level 1 (0 points)
    I had the same problem - nothing to do with firewalls for me. In my case, my Windows login password had changed, and Safari did not seem to recognize the new one - even after responding to the request to enter a new password. I deleted the keychain file (keychain.plist) in the Safari preferences folder (+C:\Documents and Settings\yournamehere\Application Data\Apple Computer\Safari\Preferences)+, restarted Safari and voila! I don't know whether the problem is proxy-related or if Safari is not doing NTLM properly.

    Regards, Pat.
  • Alex Blackwell Level 1 Level 1 (0 points)
    I, too, had the same problem after installing Google Chrome, and I'm also sitting behind a proxy/firewall. At first I thought there might a conflict between Safari and Chrome. Indeed, Chrome users need to go to Internet Options->Connections->LAN Settings and de-select "Automatically detect settings" to get the automatic built-in updater to work. In any event, deleting the files in the Safari Preferences subfolder that you mention eventually worked.

    There was another catch, however. Be advised that your LAN policies may include routine password expiration and intruder lockout after X number of attempts. I made the mistake of selecting the "Remember this password" option to avoid hassles. The problem was that my network password had expired since my last Safari session, and Safari never prompted me that I needed to enter a new one. Apparently, if one's password changes, then each time you launch Safari it used the stored password and this counts as an attempted network login.

    Kludgy solution: don't let Safari remember the password.
  • rickhoro22 Level 1 Level 1 (0 points)
    I still haven't gotten Safari to work. A couple of questions and updates on my situation:

    1. I have a firewall running. I have no idea what I would need to set to get Safari to load a web page, or why I would have to set anything different than for any other browsers. That said, I disabled my firewall and still can't load any pages.

    2. I tried to delete the suggested file in the Safari preferences folder, but that file is not in the preferences.. The only files there are com.apple.Safari.plist and PubSub.plist. I removed both of them and restarted Safari. No dice, still no pages load. Safari did recreate these files.

    Any more ideas?

    Thanks,

    Rick

    Message was edited by: rickhoro22
  • Rachel2008 Level 1 Level 1 (0 points)
    Hey Everyone,

    Hope this helps:

    I went into preferences/network/airport/proxies/

    my settings are to configure proxies "manually" and I just unchecked everything on the left. It had "web proxy (http)" selected, and when I unchecked that, everything started working again.

    Hope this helps.

    Rachel
  • The hatter Level 9 Level 9 (60,460 points)
    Have you looked at what preferences Safari is using?

    Also, did you have an older version?

    Still won't work after restart?

    There is never a good reason to "drop your guard" and disable or have to configure a normally working firewall.

    Chrome - I didn't like where it installed itself in Vista, ~/AppData/Local is NOT a valid location, along with half a dozen other 'features' and behavior. Also, when I uninstalled, why does it need to go to a web page, other than to register my IP address - without asking, and without launching my default (Minefield) and launching IE7.

    So I would try uninstalling Chrome just to rule out incompatibility, and to warn you that it does things that may not be what you expect either.

    Safari for Windows doesn't seem to respect some things that affect if and when a web page is saved to local cache, and can only see a problem if you had Safari working earlier (a common thread, installing Safari over older version it seems).

    If you want to try the nightly WebKit build:
    http://nightly.webkit.org/
  • Howard Parsons Level 1 Level 1 (0 points)
    Same problem. I get the message "Safari could not open the page “http://www.apple.com/startpage/” because the server is not responding". This happens w/ any URL. Have tried most of the solutions stated above.
  • John Willoughby Level 1 Level 1 (10 points)
    This was my problem; Windows login password changed, and Safari could no longer access the proxy server. There needs to be a way to update the proxy server password through the Safari GUI. Deleting the keychain.plist solved my problem for now.