4 Replies Latest reply: Dec 7, 2008 10:00 PM by jluvsu2
woodytobiasjr55 Level 1 Level 1 (0 points)
I have four calendars in iCal but only one of them shows up when I try to sync in iTunes using USB, and when I sync my iPhone (old model), no calendar information actually syncs onto the phone.

I'm not using MobileMe and the iPhone & iTunes softward are both up to date. I've tried the "Reset Sync History" in iSync trick, reseting my iPhone back to factory setting, I ran disk first aid, and verified my permissions, but nothing has fixed the problem.

Any ideas?

Black MacBook, Mac OS X (10.5.4), Original iPhone
  • woodytobiasjr55 Level 1 Level 1 (0 points)
    So I figured it out looking at a similar problem in the iTouch forum.

    I ended up going to ~/Library/Calendars and deleted the "Calendar Cache" files. I had four of them, which may have been the problem. I then logged out and logged back in. I oppened iTunes, pluggedin my iPhone, and all of my iCal CalDAV calendars showed up and synced properly.
  • Brian_Dolan Level 1 Level 1 (15 points)
    Thanks for the tip. I just recently had the same issue and your advise helped get my calendars working properly again. Inititally my calendar info was not syncing back and forth with ical and the iphone. Reset the sync data dudn't help but clearing the caches did. I think something in the 10.5.5 update hosed the situation for some reason. Not sure but thanks again!

    -brian
  • sfunrun Level 1 Level 1 (0 points)
    This really helped me, as well. I had upgraded recently to iPhone 2.2 and have a Google Calendar WebDAV calendar set up in iCal, which was subsequently syncing to my iPhone. For whatever reason, the synchronization stopped working and after following your instructions to delete the Calendar Cache files (I had two of them) it started working again! Thanks
  • jluvsu2 Level 1 Level 1 (0 points)
    Thank you so much! This totally worked for me! I had tried everything...reinstalled itunes, reset my iphone, did that reset isync thing...everything! Thanks so much!!