8 Replies Latest reply: Jan 4, 2009 6:52 PM by helpseeking
JeffJohnston Level 1 Level 1 (0 points)
In the last few days iPhoto has started to open automatically when I connect my iPod Touch. This slows down the sync process and seems unnecessary, as the iPod Touch doesn't have a camera. I don't want to disable iPhoto from automatically opening when I connect an actual camera to the computer. Is there a way to stop the iPhoto auto-open only for the iPod Touch without disabling auto-open for all cameras? Thanks.

iMac G4, Mac OS X (10.4.11)
  • Kvino Level 1 Level 1 (0 points)
    I am also waiting for a response. Iphoto thinks my iPod is a camera.
  • surfer13134 Level 1 Level 1 (50 points)
    the reason why this is happening is because you have copied a picture of a app has put a picture in your pictures folder. to stop iphoto from opening,open iphoto,go to preferences,then go to 'connecting camera opens' then select nothing. that will fix your problem.
  • Eunos Level 1 Level 1 (10 points)
    This is typically the result of downloading a photo in Safari on the iPod (or taking a screen shot). The file is stored locally on the device, however when it is connected to your computer, iPhoto will open thinking that the iPod is a digital camera/memory card. To prevent this from happening, import the photo(s) that you have downloaded through Safari on the iPod into iPhoto.. when done, click "delete originals"

    Assuming you don't download more photos (or take more screen shots).. when you connect your iPod again, iPhoto should remain closed.

    Hope this helps!

    Message was edited by: Eunos
  • Kvino Level 1 Level 1 (0 points)
    It worked.
  • JeffJohnston Level 1 Level 1 (0 points)
    Perfect. That worked. Thanks Eunos.
  • porcelained Level 1 Level 1 (0 points)
    THANK YOU. That had been driving me crazy, and I guess I never let iPhoto stay open long enough to see that there was an image on the iPod.
  • boloney Level 1 Level 1 (130 points)
    On a slightly different note, when I open iPhoto, it opens to "devices" and leaves a space for my iPod Touch even when it's not attached to the computer....

    I already have the open "nothing" when a computer is attached preference set up. Any ideas on how to get it to stop doing this? Thanks.
  • helpseeking Level 1 Level 1 (0 points)
    I came across these discussions and am hoping that a solution can be found for my problem. My 13 year old step-son visited over the Christmas/New Year and was plugging his iPod Touch into and out of our Mac laptop. In fact, we believe he was doing the very same thing described in this reply regarding: "...the result of downloading a photo in Safari on the iPod (or taking a screen shot). The file is stored locally on the device, however when it is connected to your computer, iPhoto will open thinking that the iPod is a digital camera/memory card..."

    We noticed that iPhoto and not iTunes opened whenever he plugged in the iPod Touch and told him not to download any pictures onto the Mac. We are not sure if iTunes ever opened. Well, he's gone now and every time we turn on the laptop now, iPhoto opens up even though there are no devices connected to the laptop.

    We are also experiencing video distortion of the computer screen when waking it from sleep. To get the computer to work again, we have to force shut down by holding down the power button. So, basically, we now cannot allow the computer to go to sleep! We believe that this has something to do with the iPod Touch having been used on our laptop.

    During an entire day of trying to figure out what could be wrong with the computer (and we are not avid computer users!) we found that in the System Preferences - desktop and screen savers module, the entire iPhoto library is there along with the standard screen savers. We are not sure if this is supposed to be? We tried deleting the library of pictures in the screen savers module but were unsuccessful.

    All was fine before and now we're having no end of troubles since the departure of our little one and his iPod Touch! Help!!!