Previous 1 22 23 24 25 26 Next 383 Replies Latest reply: Dec 11, 2008 10:16 AM by skoobe20 Go to original post
  • icebike Level 3 Level 3 (740 points)
    You mention itunes 8 un-install.

    Did you explicitly uninstall the Apple Movile Device Driver?
  • sepcm91 Level 1 Level 1 (0 points)
    Hello icebike,

    Yes, I followed the directions step by step including the unistall of the Apple Mobile Device. Nothing left in Control Panel -> Programs. Rebooted, installed the new 8.0. Started iTunes, everything OK. Plugged in printer, everything ok, plugged in iPod. Death. I have a 160 GB iPod Classic.

    Kind regards,

    /sepcm91

    Message was edited by: sepcm91
  • Protoplazm Level 1 Level 1 (0 points)
    icebike,
    Really appreciate the clarification. I'm sure everyone looking to this thread for some answers, will be very reassured by your input.
  • Yorke and Vedder Level 1 Level 1 (0 points)
    Myles Redding wrote:
    I too have experienced this problem here is what I did and it seems to have fixed the problem at least for now.
    The problem seems to be the new apple ipod driver or the installation of the driver by itunes. This driver is used for 2nd gen nanos and newer older ipods use a generic driver. You need to remove the driver. usbaapl64.sys is the file for 64 bit 32 bit is probably named similar. since I didnt know what the file name was I did this:
    1st boot into safe mode with ipod disconnected
    2nd goto control panel/system/device manager
    3rd go down to usb devices and expand it
    4th (this will require a little speed on your part) connect your ipod directly to your computer not through a hub. The apple driver will appear, immediately right click on it and click disable. If your system reboots you were not quick enough. Once you have the driver disabled (you will have to have the ipod connected to see it) uninstall it.
    5th reboot into normal mode connect your ipod directly to your computer not through a hub. this should reinstall the apple driver. once installed you should be good and you can reconnect to your hub.

    This is what I did (a bit ridiculous I know) but if you know what the driver file name is and can delete it. that should prompt a reinstall of the driver the next time you connect your ipod.



    I tried this method, but it didn't work for me... Heck, I've tried every method suggested so far, but I still run into the same issue. I uninstalled practically every piece of Apple SW I have, (except Airport), deleted all Apple/Apple related folders in Program Files, App Data and so forth... Deleted all my iTunes library related files... Re-installed iTunes 7... And even after all this, the minute I plug in my 1st, (2nd?) Gen Nano, iTunes freezes, my CPU spikes up to 100%, and I end up having to shut down my laptop again.

    I do have Logitech SetPoint installed on my laptop, as well as HP printer drivers. However, I do not have the HP printer connected, (hasn't been in a while), and most of the time I did not have my Logitech USB mouse connected at all. Frankly, I don't think it should matter if I did, (Apple's going to make me choose between having a working mouse and printer or my iPod? Really??).

    Anyway, I don't know what else to do at this point, except keep reading this thread and hoping there is a light at the end of the tunnel...
  • toonz Level 7 Level 7 (22,355 points)
    If you are still having the BSOD, check the version number of this file

    Vista 32:
    Program Files\Common Files\Apple\Mobile Device Support\Drivers\usbaapl.sys

    Vista 64:
    Program Files(x86)\Common Files\Apple\Mobile Device Support\Drivers\usbaapl64.sys

    What version is it?
  • Yorke and Vedder Level 1 Level 1 (0 points)
    Well, I'm still having the same issues, but I wanted to update with some extra information:

    After going through the process of uninstalling all Apple related things, removing any and all usbaapl related files, etc, etc, etc... I re-installed iTunes 7, and as soon as I plugged in my iPod, (and I've tried it on different USB ports), I still can't get it to work. Let me stress that I'm not getting the BSOD, (that only happened when I had iTunes 8 installed), but that iTunes does not detect my iPod, even though Windows does, (after installing the drivers). My CPU grinds semi-constantly at 100%, iTunes freezes up, and I can't "safely remove" the iPod. I don't get an error message or anything, but it doesn't remove it.

    What I have noticed so far is that as soon as I plug in the Nano, I opened up my Task Manager and realized that there is a svchost.exe, (process id # 1160) process that uses up a fairly consistent 50% of my CPU resources. I also noticed that Vista's indexing and search processes, (SearchIndexer.exe, SearchFilterHost.exe, and SearchProtocolHost.exe), were competing for system resources as well. My first thought was that for some unknown reason, Vista wanted to index my iPod, (???), before letting iTunes get access to it... But after a good half hour of waiting, I decided to forcibly close iTunes, (did so successfully), and I tried to "safely remove" my iPod, (which didn't work).

    Sometime after closing down iTunes, I noticed in my Task Manager, that although that svchost.exe was still holding at around 50%, the indexing and search processes had stopped trying to hog the remaining resources, (yay!), but now the System process, (NT Kernel & System), was picking up the slack with about 45% of the remaining resources available!

    So, suffice to say that this is still a mystery to me, but I wanted to add this information in case it rings a bell with someone here and helps solve this problem, (or at least get a bit closer to a solution).

    I think I'm going to force a shutdown on my laptop and quit worrying about this for now... I'm to the point where I just want to chuck my iPod out the window, if it weren't because I can't afford to do so...
  • Yorke and Vedder Level 1 Level 1 (0 points)
    ok... I lied. I didn't stop worrying about this after all.

    I'm not even going to pretend I understand how in the world I got iTunes and my iPod to work together again, but I'll tell you what I did:

    So, after forcibly shutting down my laptop, I put my iPod in Disk Mode, (http://support.apple.com/kb/HT1363?viewlocale=en_US). I was originally seeking to restore my iPod, but I couldn't do that unless iTunes could see my iPod. Anyway, after setting the iPod to Disk Mode, I restarted my laptop into safe mode. Once Windows loaded up, I plugged in my iPod, (as I'd done a few times before), and Windows recognized it, as always. I opened iTunes, which protested that the iPod software didn't seem to be working correctly, so it asked me if I wanted iTunes to repair it for me. I accepted, only to get an error message stating that iTunes couldn't fix the problem and that I'd have to re-install iTunes altogether, (nothing new here).

    I decided to check my preferences, to see if it might still allow me to restore my iPod or at least to see if there was something there I could change to make things work again. Now, here is where I can't vouch that this will work for everyone, but give it a shot, at your own risk, (it's not as bad as it sounds, I think). I chose to disable the "Look for iPhone & iPod touch Remotes" under the "Advanced" tab, which I'm sure shouldn't matter, but I did it anyway, and I also enabled "Disable automatic syncing for all iPhones and iPods" under the Syncing tab.

    I restarted my PC, with the iPod still plugged in to the USB port, and after Vista loaded, iTunes popped up, all on its own, with my iPod showing up!!! So... I'm not sure if my iPod is still in Disk Mode or not, but I'm going to attempt a few things, (music transfers to my iPod, disconnecting it, re-connecting it, etc...), and report any issues that come up.

    Be right back.
  • Yorke and Vedder Level 1 Level 1 (0 points)
    OK... Spoke too soon, it seems. During the same session in which iTunes and my iPod were getting along, I was able to transfer music files to my iPod without problems. I was able to eject my iPod through iTunes, and reconnect without a problem, (all still under Disk Mode). I ejected my iPod once more, reset it to "regular mode" (?), and plugged it back in, no problems. iTunes still sees it properly, I can still do transfers, etc... Beautiful.

    The problem only rears its ugly head if I restart my PC and connect my iPod in regular mode first, without going through the Disk Mode. Don't ask me why, I don't get it. For now, I'll initialize my iTunes/iPod connection by putting my iPod in Disk Mode first, but I would appreciate it if Apple helped me figure this out, so I'll give them a call shortly.

    For those interested, I did get a BSOD when attempting to a shutdown last time my PC got frozen by this issue. The error message I got was: STOP: 0x00000007 (0xc0000005, 0x823163c5, 0x99196c00, 0x991968fc). No other details or information was given to me. Via Google, I found that this could possibly be due to an INVALIDSOFTWAREINTERRUPT, or possibly a memory leak from a driver.

    If Apple tech support happens to be reading this, I am willing to forward to you additional info from my Event Viewer logs, about the BSOD and any errors found in case this helps.
  • Yorke and Vedder Level 1 Level 1 (0 points)
    Here's another interesting bit... I no longer have any of the usbaapl related files under WINDOWS/System32 folder, (I mean, I did remove them manually when I uninstalled all Apple SW, but after re-installing things, I figured they'd be back in there). If I do a search within that folder for usbaapl, nothing shows up, but if I try that same search for the entire drive, (C:), it finds usbaapl.inf within the C:\WINDOWS\System32\DriverStore\FileRepository\usbaapl.inf_524e3145 folder and USBAAPL.CAT within the C:\WINDOWS\System32\DriverStore\Temp\{4d7d8e4c-a8cb-4d3b-9771-3f47cd4ec862}\Pac kage\ folder. Is this normal? Should those files be directly under the System32 folder?

    Message was edited by: Yorke and Vedder
  • toonz Level 7 Level 7 (22,355 points)
    If you moved some of those files around manually, you may have gotten the iTunes installation into a state such that reinstalling will not lay down all the necessary components. You may have to go through some of the steps in the General installation troubleshooting section of this support doc.

    Specifically, you should probably go through the first 3 tasks in that section:
    * Completely remove iTunes and QuickTime (make sure to remove Apple Mobile Device Support during this process too)
    * Empty your Temp directory and restart
    * Clean up iTunes installer files on the computer
  • WordUp Level 1 Level 1 (0 points)
    obviously. Windows automatically updates so we have no issues with Windows. It's your software.

    Message was edited by: WordUp
  • WordUp Level 1 Level 1 (0 points)
    I have 64-bit vista ultimate and after getting the blue screen all I did was the following:

    Disconnected HP printer
    Uninstalled the apple stuff in the correct order (took a while)
    restarted, then downloaded itunes from the provided link in the document for the fix
    and it worked. I use Setpoint and didn't need to reinstall it. \
    Decent recovery Apple guys,

    Thanks for the waste of time.
  • Trafcon Level 1 Level 1 (0 points)
    Here's my story. I downloaded iTunes 8 and got the Blus Screen with both my iPhone and iPod Touch.

    However when I turn off my HP PhotoSmart C5280 printer it works fine. It's really a pain that the drivers conflict so I have to turn off the printer though.

    My system is:
    VISTA Ultimate/Duo Core 2 Intel/ EVGA 8900/ Logitech USB mouse and webcam/ 4 GB Ram

    I would hope Apple could redo the USB driver so it wouldn't crash with the HP Printer USB drivers.
  • mac_0_9 Level 1 Level 1 (0 points)
    No but it is fixed for 99.44% of everyone who encountered it. So it seems likely that there is something else involved with your particular setup


    My setup worked fine with iTunes 7.


    The other option would be for you to roll back to the Apple Mobile Device Support driver that came with Itunes 7.7. (NOT roll back entirely to Itunes 7)
    as explained here: http://discussions.apple.com/thread.jspa?messageID=8084295

    In fact if you open up task manager, show processes from all users, sort by name, it will probably appear at the top. Right-click, Properties, Previous Versions, should show the older version still on your machine. You may be able to roll back without even going thru the install process.


    Tried to roll back, unfortunately Windows does not have any previous versions stored.

    Most users won't encounter it because it is fixed.


    I wouldn't say it's fixed. For some reason, even after a uninstall/reinstall, I keep getting the 1.35.0.0 version of the usbaapl driver. That is the problem driver. I assumed the 1.29.0.0 driver would replace it after d/l a fresh copy of iTunes 8 but for some reason my system is holding on to the old one. I even manually deleted it, scanned the registry, removed all signs of the Mobile software and iTunes using MS removal tool msicuu.exe, etc. When I rebooted and reinstalled again, there was no usbaapl driver at all in my System 32 folder!

    Apple support suggested I install directly from the d/l (instead of saving to desktop and installing from there). They informed me that the .exe is actually different than when you elect to "save to disk" before installing. I know, odd but that is what a second level support guy told me.

    I will try his suggestion first and if that doesn't work, I will remove and then d/l the Mobile Device software from iTunes 7 and try it that way.

    For some reason I am having major problems and this shouldn't be this hard I just keep getting the problem driver no matter what I do.
  • Ravin S Level 1 Level 1 (0 points)
    how did you go back to itunes 7.7? i'd really like to. i dont like this itunes 8. i always get the BSOD. its very very very irritating -.-
    apple ***** butt for not testing the new itunes the way they should have