Previous 1 2 3 4 5 Next 73 Replies Latest reply: Oct 22, 2008 1:14 PM by Zizone Go to original post
  • D.R.C. Level 1 (145 points)
    Basilon writes:
    "Take it to the apple care, they will take care of it".

    Alas, the nearest Apple Store is in Toronto, a 5 hour drive away.
    And Apple provides no AppleCare coverage for the iPhone in Canada.

    Given the many reports of post-2.1 update GPS defects on this and other discussion threads, it seems highly unlikely that it's a hardware problem. Unless the 2.1 update caused damage to the circuitry.
  • D.A.M.O.N Level 3 (620 points)
    Thanks!

    "Reset All Setting" has seemed to fix this issue for me. Before, the GPS would NOT pick up. And when it did, it was off by a few thousand yards. But now it's back to the way it worked before - which is really well (at least for me).

    Take care.
  • NastyChef Level 1 (5 points)
    if you any of you havent restored to factory settings and reinstalled 2.1, i recommend you give it a try. i know it might be old news to some, but after hard resetting my phone about twice a day, i restored it yesterday and now everything seems to be working fine. after reinstalling 2.1, i deleted all my apps and reset my settings. i reinstalled apps using itunes and that seems to have done the trick. sad to say there seems no real solution to this problem, but give a try anyway
  • midnightcry Level 1 (0 points)
    Having the same issue--almost never finds a location to lock on.
  • willieyao Level 1 (0 points)
    I have tried following methods but none of the solution bring back the blue dot in google map:
    1. Reset all
    2. turn off 3g, wifi
    3. swap sim card out and use another sim card to block 3g, wifi, and edge
    4. Restore to factory default
    5. restore system without adding any application.
    6. Wait for 20min out door.

    Does anyone know what to do to fix this problem?
  • sportxone Level 1 (0 points)
    Hi guys. Works for me too, but slightly off, then it'll correct itself. probably needs time to initialize, then triangulate. Bye.
  • myprofn Level 1 (0 points)
    I have the GPS problem exactly as described. The GPS used to work smoothly indoor and outdoor on the previous firmware 2.0.1 but after upgrading to firmware 2.1 it gives this message when I try to determine my location "your location couldn't be determined". I tried turning off the 3G but invain.

    What shall I do now to have it work is there a way to downgrade or what?
  • NastyChef Level 1 (5 points)
    have you guys tried turning location services off and then turning your phone off for a good 10-20 minutes? i did this about 4-5 days ago and its been working great since. give it a try if you havent
  • D.R.C. Level 1 (145 points)
    Some have had luck doing a complete restore (back to factory settings), then a reinstall & resync.

    Some have reported success installing a free 3rd party GPS app such as TrackThing. Go outside and let TrackThing acquire the GPS satellites (indicated when the "GPS" text turns from red to green). That may take 10-15 minutes for your iPhone to acquire the needed tracking information from the satellites. Once sat lock has been established, quit from TrackThing and see if Maps has started working again.

    In any event, call AppleCare and report the problem. Insist that they open a ticket; else this v2.1 defect will not get their attention.

    Good luck.
  • SuperAlex Level 1 (0 points)
    I've never seen the blue dot. I updated the moment I took it out of the box to 2.1 and the gps just never worked. Tried, reset all settings, wi-fi off, 3g off.. nothing. I hope firmware 2.2 addresses that issue, since i had a gen 1 16gb iphone and changed to a 3G one because of that feature.
  • jdbowden Level 1 (25 points)
    I could not get a blue dot 99% of the time on my new iPhone which was purchased two weeks ago. On Thursday, I when to the Apple store and they replaced my iPhone with a another new one (no FRU - Field Replacement Unit). I can tell you that the new iPhone GPS works perfect. I get location and blue dot all the time.
  • Sterno Level 1 (70 points)
    I was also getting "location cannot be determined" and tried all of the above tips without success. But here is a new fix that I found that cured my problem and you might want to give this one a go as well.

    Sort of a long story here. I travelled from Bangkok to Phnom Penh, Cambodia and found that GPS was not working "location cannot be determined", although it was working on the drive to the airport in Bangkok. I was beginning to wonder if there was some sort of situation where the local 3G cells (yes, even Cambodia has 3g!) were not acting properly and that somehow had something to do with GPS. I probably spent an hour trying all the various fixes without success.

    OK, to cut to the fix that I finally stumbled upon:

    In the Date & Time prefs, I had "Set Automatically" enabled. I switched that to 'off', selected Phnom Penh (my location) from the Time Zone menu, and that did it. GPS worked perfectly, the little blue dot was there, and it was very accurate indeed. Note: I had Data Roaming set to off.
  • Zizone Level 1 (0 points)
    OK, so I've got the same problem with my iPhone - GPS not working at all after update to 2.1
    My provider does not support 3G, so I can not attribute this to 3G issues. Triangulation using WiFi or "normal" GSM works fine - I get the cross hair in Maps, but no blue dot to show that there is proper GPS lock.
    Now, I'm sure this is a firmware problem as a managed to make it work - hard reset the phone (sleep button + home button longer than 10 sec.) GPS then works, but only until the phone gets to sleep, then I have to hard reset again to get it to work... I hope apple corrects this in the next FW update.

    Message was edited by: Zizone
Previous 1 2 3 4 5 Next