1 2 3 Previous Next 31 Replies Latest reply: Oct 4, 2008 6:43 PM by pollock28
Z Dub Level 1 Level 1 (0 points)
I just purchased an iPhone 3G and downloaded a few common, free apps (New York Times, Wikipanion, etc.) They loaded onto my menu just fine, but when I select them the correct screen comes up for a few seconds, then abruptly shuts off and sends me back to the menu screen. The same thing is happening for all my new apps. Everything else on the phone is working just fine, and - per a suggestion on this discussion board - I just downloaded the newest version of the firmware that came out this morning (9/12). Still, the problem persists. Any idea what might be causing this and how I could fix the problem?

MacBook, Mac OS X (10.5.2)
  • 1. Re: iPhone apps won't work
    David Ross2 Level 1 Level 1 (85 points)
    I just came here to pretty much ask the same question. Right before I asked I thought I'd try a few things. I went to the app store on my phone and it had a couple of updates. I did an update, typed in my password, let it download/install and checked again. They all work now. So maybe after an update the phone wants you to sort of reauthorize. Try it, might help.
  • 2. Re: iPhone apps won't work
    Z Dub Level 1 Level 1 (0 points)
    I tried checking for app updates, and there were none to download. Thanks for the advice, but the problem still persists.
  • 3. Re: iPhone apps won't work
    Z Dub Level 1 Level 1 (0 points)
    I figured it out! For those in this situation with their apps, try deleting them from your iPhone (hold until it wiggles, then click on the X in the upper corner) and reinstalling.
  • 4. Re: iPhone apps won't work
    hawkmoth Level 1 Level 1 (20 points)
    For those experiencing this problem, you really must update to version 2.1 of the firmware and iTunes 8.0. The other "solutions" are nearly all temporary without doing that.
  • 5. Re: iPhone apps won't work
    tstevens Level 1 Level 1 (0 points)
    I've tried the various solutions described here, with poor results. I've got a 3-day old iPhone 3G. It's updated with the latest software. Today, I downloaded three apps from the phone and used them all successfully. After the next sync with my computer, they won't launch. I tried deleting them and re-syncing, but got an error message saying that "the applications are not authorized for this computer." Tried "authorizing" the computer. Got an error message saying "the computer is already authorized."

    Seems like some kind of bug in Apple's DRM routine.
  • 6. Re: iPhone apps won't work
    hawkmoth Level 1 Level 1 (20 points)
    I'm guessing your new phone didn't come with version 2.1 of the firmware. Have you updated it? Don't mean to restate the obvious, but it's important to do this if you haven't already
  • 7. Re: iPhone apps won't work
    ImYourMacDaddy Level 1 Level 1 (20 points)
    You can try this to get those Apps working again:

    -delete applications from iphone
    -turn iphone off then back on
    -deauthorize computer in itunes (under store), close down itunes
    -open itunes back up, authorize computer (under store in itunes)
    -plug in iphone to sync apps over

    This worked for me. If it doesn't work you can try deleting the Apps in iTunes as well, then re-downloading them in iTunes, then syncing the phone. No need to run a Restore.
  • 8. Re: iPhone apps won't work
    xAPPO Level 1 Level 1 (0 points)
    How can I tell if an application is crashing or if the OS is terminating an application for authorisation issues ? Just one of my purchased applications runs for about 5 secs and then I see the rotating clock dial and it quits.

    I am running iTunes v8 and v2.1 of the firmware and I have tried deleting and reinstalling the application from the iPhone and the iTunes reauthorisation suggestion and synch but it's just the same every time. The application author doesn't have other users with this problem so I feel it's the OS and DRM.

    Can I apply for a refund and then purchase again - and would that help ?

    K
  • 9. Re: iPhone apps won't work
    Premier79 Level 1 Level 1 (0 points)
    Well I had the same problem and figured out why it happens to me. Whenever I connect the Iphone to my pc, it messes up my apps for some reason. My fix, I go to the appstore on IPhone and see if there is an update for any of the applications that I have and I update. That resolves my problem. I just downloaded the last ver, 2.1, and that didn't crashed my apps as well lol. So try that, updating an application, and hopefully that'll work for you as well.
  • 10. Re: iPhone apps won't work
    windowsisbetter Level 1 Level 1 (0 points)
    My phone does the same thing.
    After I select an app it loads the app then aborts it and goes back to the main screen and like a true apple, It doesn't show a error to help you figure out why.
    I restored it using itunes to fix the problem a week ago.
    And now it did the same thing again. Getting fed up with it.
    It takes over 2 hours to do a restore.=(

    Apple's customer support is no help.=(
  • 11. Re: iPhone apps won't work
    ImYourMacDaddy Level 1 Level 1 (20 points)
    You state that you are deleting and reinstalling from the iPhone. If this is truly what you meant, do not reinstall from the iPhone - let iTunes do the reinstall.
  • 12. Re: iPhone apps won't work
    ImYourMacDaddy Level 1 Level 1 (20 points)
    Did you only try a restore and not the steps above? If so, try the steps above.

    Message was edited by: ImYourMacDaddy
  • 13. Re: iPhone apps won't work
    xAPPO Level 1 Level 1 (0 points)
    Previously I was reinstalling via the iPhone but I followed your steps to the letter and I still have the same issue. I even tried deleting app from both iPhone and iTunes, de and re-authorize with reboot of disconnected iPhone and iTunes in between and re-purchase via iTunes then resynch to download the failing app from iTunes back to the iPhone. Exactly the same problem - quits after 5-10 secs

    Is there a way I can confirm this is the OS DRM and not the application itself ?

    I have tried so many avenues into Apple support but I can't seem to get someone who can really help (or cares) here . Will a refund and re-purchase help ? Should I try the total restore ?

    Thanks in advance for for any help

    K

    PS Only other perhaps significant thing is that I originally purchased this app on an iTunes machine (Windows) that wasn't the original iTunes I had synched the iPhone to and I did then try a synch to this iTunes (by mistake) and it said that the app was not authorised on this machine (although the iTunes was authorized I believe). I then downloaded it directly to the iPhone using the 'already purchased' option.
  • 14. Re: iPhone apps won't work
    dlinsalata Level 1 Level 1 (0 points)
    I am in the same exact position. I've tried reinstalling multiple times, tried turning on and off (even doing the "hold the power button and the home button for 10 seconds" method), and auth/deauth'ing my computer.

    Even still, I can't get any of the apps I've downloaded to work. They worked last night - but since I installed new ones this morning, none of them work!

    (This is a 3 day old iPhone as well.)
1 2 3 Previous Next