6 Replies Latest reply: Dec 7, 2008 9:05 PM by jvoigts
smpostma Level 1 Level 1 (0 points)
I have read the posts, that I can find, with this problem, but still not working. I highlighted my whole document, inspector, text, more, selected English, made sure that it was checking spelling while I typed, still nothing. I can type random letters with no spell check, not even manually. This document was working fine until the power went out and I had to restart, now i have problems? Any suggestions... other than a battery backup?

imac, 2.4 ghz, 24", Mac OS X (10.5.4)
  • 1. Re: spell checker not working in Pages?
    Peggy Level 8 Level 8 (38,230 points)
    I'm not sure which posts you found. The two recent topics I recall with spell check problems were about the red underlining not working. The suggestion to delete the com.apple.iwork.pages.plist found in HD > Users > (your account) > Library > Preferences worked for both of them. I'm not sure it will work for you but it doesn't hurt to try.

  • 2. Re: spell checker not working in Pages?
    Level 8 Level 8 (41,760 points)
    Hello

    On my machines I have these behaviors:

    On the G5 running 10.4.11 where I installed once a CocoaSpell Checker, Iat last I was able to get rid of it in the select spell language menu but the English checker behaves as you describe. In Pages (only with it) I must use the British English.
    On the iMac running 10.5.4 the English checker behaves flawlessly.

    It seems that Pages keeps something from the old installation of a cocoaSpell checker.

    If some other users got this behavior I will be glad to be informed.
    Maybe I will file a bug report.

    Yvan KOENIG (from FRANCE dimanche 14 septembre 2008 11:09:15)
  • 3. Re: spell checker not working in Pages?
    tallmanbaby Level 1 Level 1 (0 points)
    Thanks, my daughter (12) was having problems with the spellchecker in Pages, and it had me scratching my head. However deleting the plist file as you suggested worked the trick.

    Not sure if it is relevant, but I closed Pages, deleted the plist file, then reopened Pages.

    Because the whole family use the same machine, different users tend to work in their own accounts, so problems like this can exist in one account, without me noticing.

    cheers
  • 4. Re: spell checker not working in Pages?
    Y&J Level 1 Level 1 (0 points)
    My spell checker isn't working also. It used to, it's checked off on the edit, spell and grammer, check spelling whle typing. I don't know what happened.
  • 5. Re: spell checker not working in Pages?
    Peggy Level 8 Level 8 (38,230 points)
    Did you delete the com.apple.iwork.pages.plist found in HD > Users > (your account) > Library > Preferences as I said in my earlier post in this thread? You must then restart Pages for it to create a new, clean plist.

  • 6. Re: spell checker not working in Pages?
    jvoigts Level 1 Level 1 (0 points)
    This worked for me too! I went ahead and quit pages, deleted the document you said, and then restarted the program.