Previous 1 15 16 17 18 19 Next 572 Replies Latest reply: Oct 26, 2008 8:46 AM by Brett L Go to original post
  • Frank Malloy Level 2 Level 2 (350 points)
    This is very enlightening.

    I would be interested to hear from others if this also works for them, before I go into my local AT&T store. Somehow, I don't think they will be this forthcoming...I would prepare for "Oh, you need to go back to Apple for that..."
  • staticfish Level 1 Level 1 (0 points)
    1. Why are Apple deleting posts to this thread left-right-and centre?

    2. Why are Apple not acknowledging this problem, let alone fixing it.
  • infusopharm Level 1 Level 1 (0 points)
    I have found a workaround for those with a jailbroken phone. There is an application call insomnia on Cydia which when running will solve the problem. Hopefully Apple will fix this problems with next firmware. At least it solves my problem for now.
  • davald Level 1 Level 1 (0 points)
    Try this; it worked for me (so far): Open up your MobileMe webmail account, then see if your mail arrives.

    I was experiencing the same problems with push/fetch using my @me.com account (inbox). I sent several test emails to that account from different (POP) accounts. Nothing happened on my iPhone. Rather, at the bottom of the display the gear was rotating feverishly with the note "connecting."

    Then I opened up my webmail (MobileMe) account and resumed test emails. They appeared on webmail, MBP, and iPhone—nearly simultaneously and immediately. Even after I "closed" my webmail, the test emails worked.

    Curious if anyone can replicate this.
  • Frank Malloy Level 2 Level 2 (350 points)
    I am guessing that insomnia keeps your phone in wake mode constantly. To me that isn't much of a solution; it would likely drain the battery way too quickly.

    An efficient sleep mode uses as little power as possible.
  • Muzzman1 Level 1 Level 1 (10 points)
    So it turns out my problem still persists. I DO find that if I perform an unlock captcha it fixes it for a short while
  • davald Level 1 Level 1 (0 points)
    OK. I did some further testing, and the results are uneven.

    I have four separate POP accounts plus MobileMe. One of the POP accounts receives email on the iPhone, but not the other three. Interestingly enough, the iPhone registers the "bing" sound and vibrates--as if email is being received. However, the email messages do NOT appear in the display. The MobileMe account is working fine.
  • alborz82 Level 1 Level 1 (5 points)
    I have a MobileME account, it is the only account i have set up and i have ZERO push since 10 days ago when 2.1 came out, whats worse is im still paying for mobile me, which i got mainly for push.

    I like your post staticfish
  • Matt Werline Level 1 Level 1 (0 points)
    Very interesting.. I saw another post yesterday that was totally unrelated to this issue, but was in reference to the SIM card.. In this case AT&T did some kind of remote update and fixed their problems..

    http://discussions.apple.com/message.jspa?messageID=8142391#8142391

    Could there be some weird interaction with 2.1, the SIM card, and the power state of the phone? I'd really like to hear if anyone has had the same luck?

    Also wonder how old is old for the SIM card.. I got mine when I got my phone, which wasn't all that long ago..
  • Frank Malloy Level 2 Level 2 (350 points)
    I have tried the following:

    1. Lock/sleep the phone at 6:06pm by pressing the Sleep/Wake button. Screen is dark as expected

    2. Send a push email to MobileMe account approximately every minute, and check the response on the phone.

    I sent about 8 messages in the next few minutes. I got the vibrate indication for the first 5 within a few seconds of sending them from a Gmail account to the MobileMe account.

    At about 6:09, the notifications stopped starting with my 6th email. So, it took roughly 2-3 mins. for the notifications to cease.

    Auto-Lock is set at 1 min. But, I don't think this has any impact since I put the phone to lock/sleep using the switch just before starting the test.

    I haven't tested this procedure a second time to see if it's consistent.

    It seems like there is some timer or something that is stopping the auto checking.

    Can others with push/MobileMe try this? I have not tried POP/IMAP since the check interval is too large.
  • grodoz Level 1 Level 1 (0 points)
    Same problem here.

    I had so many troubles with mobileme not pushing, I just thought it would be safer to just set the iphone to fetch any 15 minutes. Well, I was wrong: not fetching either, unless I manually open mail and say check. None of the above turnarounds worked for me.

    Even my old mobile phone (yes, not even a smartphone), was able to check for mail every fifteen minutes!

    As many of you I didn't buy the iphone to play Monkeyball, I did cause it was advertised a pricey but reliable business device. This is very, very frustrating.
  • bernieh Level 1 Level 1 (0 points)
    My situation WAS as detailed below:

    Auto mail fetch failed with:
    Phone suspended/asleep AND
    NOT using WiFi AND
    Phone is not plugged into computer or AC supply AND
    Have tried over the course of several hours AND
    Using firmware 2.1

    I did not have an "automatic" fetch in over a week, after trying all of the suggested remedies in this thread. I gave up as of Saturday, with the exception of following this thread.

    All of a sudden, this afternoon, my phone started fetching automatically. I was surprised when I heard the "ding" that I had mail. I've received numerous emails sent from others, and sent tests to myself, with the same positive results.

    I have changed NOTHING from the scenario as detailed above. But it has "magically" started working.

    Could Apple/AT&T made some changes remotely???
  • Muzzman1 Level 1 Level 1 (10 points)
    Ok I did something similar:

    I still also have my 2g Phone with 2.0.2 I restored it as a new phone, jailbroke it, and set it to check my IMAP gmail (google apps) acct every 60 seconds.
    SURE enough!!
    My 2G phone with 2.0.2 Fetches my email every minute! For 10mins straight. (while asleep, not connected to a power source)

    In the mean time my 3g phone (also jailbroken) set to check mail every 300 seconds, sits next to my 2G phone in SILENCE!!!

    I am (as Im sure many others are) CERTAIN it is a problem with 2.1, not any external servers per se.

    So as MANY other's have begged and pleaded before me, APPLE PLEASE FIX THIS ASAP. This phone is a vital component to my work flow, and is impacting my ability to work efficiently.
  • Fluffy_bunnies Level 1 Level 1 (0 points)
    To be honest, I didn't buy the iPhone thinking that it is a reliable business platform. I bought it because I love the human-to-device interface methods and I thought that the rest would follow over time.

    I thought that everything else that was missing or wrong would eventually be included/fixed through software releases, and that eventually iPhone would become an unbeatable tool.

    And then I updated to 2.1........

    Users: Try and keep your problems and your troubleshooting very clear and precise. Around diagnosis there has been some "noise" that will only serve to confuse.

    Message was edited by: Fluffy_bunnies
  • Tarponsprings Level 1 Level 1 (0 points)
    Same problem here. No push since the 2.10 upgrade
Previous 1 15 16 17 18 19 Next