Previous 1 2 3 4 5 Next 572 Replies Latest reply: Oct 26, 2008 8:46 AM by Brett L Go to original post
  • rdb515 Level 1 (0 points)
    I have noticed the same thing with fetch while charging vs. on battery. Mine will fetch on the charger every 15 minutes like it always did (before 2.1) On battery (asleep) it will not fetch. If I leave it awake even just sitting on the home screen) on battery it will fetch too but that's not a fix -- just an observation that it will fetch if it stays awake. I does look like a developer got too agressive with the code for shutting down "unneeded" services when the phone is asleep on battery.

    Mobile email notification is pretty much the one "must have" feature on a smartphone - it's why I have mine. Apple needs to get this working pronto.
  • Utsava Level 1 (0 points)
    Add me to the list. No fetching after 2.1 update. Going into the mail app will manually fetch new emails. My gmail account worked well in the previous 2.0 releases.
  • pman83 Level 1 (10 points)
    With the iphone plugged in, my gmail does fetch as it should. I didn't think anything of it at first, i thought it had something to do with it being plugged into my macbook as opposed to a regular outlet, but after a few test it seems to be the fact that the iphone has a power source.
  • Kevin Liu Level 1 (100 points)
    Interesting... My email fetching has never worked consistantly since 2.0.x. No help after updating to 2.1. The issue is exactly as everyone here describes expect mine's never worked.
  • Andrew Bediz Level 1 (15 points)
    agreed. Look at some of the threads here. This issue has been around for a long time. 2.1 maybe just made it affect a more diverse set of setups. Push and polled fetch stops working.
  • Greg Freeman Level 1 (5 points)
    I had this problem, and i restored the phone, set it up as a new phone, reinstalled all my apps and entered all my setting afresh, without applying my old backup.
    This has cured it and a few other problems i had with installing and updating apps.
  • Andrew Bediz Level 1 (15 points)
    what do you lose when you do this?
    all call/sms history? browsing history? what else?
  • Greg Freeman Level 1 (5 points)
    You will lose all your history as the phone will be set up as a new phone, you can however sync all your bookmarks contact etc quite easily through itunes.Worth it though for me to sort this out and the app install/update issue.
  • staticfish Level 1 (0 points)
    I also get this issue on my iPhone3G with my GMail IMAP account. This has only started happening to me AFTER the upgrade to 2.1. It's a shame, because 2.1 is perfect in every other respect. Just the fact that it stops checking for messages at regular intervals. I get NO notifications of emails now.

    Just a theory, but I have a password lock enabled.
  • Pfeifler Level 1 (0 points)
    I noticed the same thing - 2.1 change my exchange to "push" as well. I changed it back to fetch and it doesn't seem to update properly. However, i did get it to synch one time now. I changed everything to manual and then put the fetch back on.

    I'll see if it sticks.

    Ugg - 2.0.2 was working just fine for me!

    Mark
  • Pfeifler Level 1 (0 points)
    Can anyone else confirm that a clean restore w/o settings and apps enables fetching again?

    Thanks
    Mark
  • FTC Level 1 (0 points)
    I tried two restores. Neither worked. I did it with a back up and I also did it as a new phone. I deleted all email settings prior to the restores. I have had no luck. Email was working perfect before 2.X.X. What happened????? Apple where are you????

    Message was edited by: FTC
  • Ryan717 Level 1 (0 points)
    I've been experiencing the same problem. With Iphone OS 2.02 at least the fetch was working correctly at the interval I set it at. Now with 2.1 it's back to going to sleep and not getting my gmail anymore or any of my mail for that matter. Very annoying. So basically, when I first got the iphone it was having fetching problems, updated to 2.02 and it was fixed, now upgrade to 2.1 has killed it again.. Geeeez Apple come on! I have noticed that it seems to fetch more correctly when plugged in though so this has to have something to do with the power saving issues I guess.
  • Morten Elley Level 1 (5 points)
    No luck here either. Restored completely, but it just wont connect to my exchange account. Ive no problem getting to it via my Macbook Pro, and my colleagues have no problem with their accounts. It must be the iPhone. Im so disappointed, this is by far the the prettiest, most expensive and also ridiculously bugged and incompetent phone I ever bought. This must be the Paris Hilton of phones. Im so disappointed.
  • pman83 Level 1 (10 points)
    So these problems we're all having, does anyone suspect they may be specifically related to our individual devices, i.e. the iphone hardware is faulty in some way?
Previous 1 2 3 4 5 Next