Skip navigation
This discussion is archived

"Your network settings have been changed by another application"

72518 Views 64 Replies Latest reply: Nov 22, 2009 3:15 AM by roger Symons RSS
  • Kevenly Level 1 Level 1 (25 points)
    I do not have Pro-Tools and this horrible incident has occurred for me IMMEDIATELY after applying this latest security update. I hope this issue is remedied with extreme haste!!
    Titanium Powerbook G4 (Onyx), Mac OS X (10.4.11)
  • arebee Calculating status...
    heya, i have the same "....changed by another application" loop here, hhhmmm suspiciously just having recently updated with that recent "security update"! it looks like its a bad updater.

    anyway, i did the "two hand trick" but instead if just switching locations as mentioned above (because i dont want to lose all details in the settings for a new blank one), i simply duplicated the "automatic" one that ive been using well for ages......the endless pop up window ceased, and then i managed to quit and reopen "network" prefs, and switched back to the original "automatic"...... and the endless popup had gone. so mbe this would be a good solution for anyone who doesnt fancy retyping all their POP, TCP/IP, and all other details over and over again.
    powerbook G4 15" Aluminium, Mac OS X (10.4.11)
  • Kevenly Level 1 Level 1 (25 points)
    I got to the Location->Edit locations->Duplicate Automatic. Once "Automatic" was copied, I immediately deleted the copy and left the location editor and the annoying loop was gone. I didn't have to switch the copy and delete the original, I just immediately deleted the copy. It was almost as if just getting to the location edit window fixed it. In any case this appears to have remedied the situation so far.
    Titanium Powerbook G4 (Onyx), Mac OS X (10.4.11)
  • Kevenly Level 1 Level 1 (25 points)
    So much for that, the endless loop is back. I installed the security update on an external drive, with 10.4 updated to 10.4.11 and no third party apps added, and after the update this problem starts. This is definitely an Apple update-caused error. Why some are having it and others aren't is interesting.. But I am back to hoping Apple corrects this error immediately.
    Titanium Powerbook G4 (Onyx), Mac OS X (10.4.11)
  • Dan C... Calculating status...
    I may have a solution... I seem to have eliminated the problem by using the mouse click / return key technique referred to earlier to get into the network settings window. I then deleted every location, except for one. I then restarted the computer and added a second location. For the moment, everything seems to be working fine.
    PowerBook G4, Mac OS X (10.4.11)
  • Ron Guest Level 1 Level 1 (5 points)
    I think this is related to an issue with keychains. I tried to do Keychain First Aid on my keychain and it always crashes (Crashlog) whether I do verify or repair.

    I was able to open Keychain Access and used that to delete the entry for my wireless network. I then used the Location dropdown trick to break out of the loop, deleted all locations, and reset up the wireless network with the router password. At least for now this is working. I suspect something is more troubling however and feel more problems are to come.

    Also note that when deleting the keychain entry there is an error in the log about not being able to create a temp file in /Library/Keychains (no permission).
    iMac 24", 2.4GHz, 2GB RAM, Mac OS X (10.5.2), also iPhone 3G, iMac G5, TiPB
  • Holzer64 Calculating status...
    There is another thread on the same subject at http://discussions.apple.com/thread.jspa?threadID=1712387&tstart=0
    eMac, Mac OS X (10.4.11)
  • Kevenly Level 1 Level 1 (25 points)
    I'm sure you are correct about the Keychain's involvement, because I solved this problem today on my system.. somewhat chaotically.. but the problem has not returned unlike previous attempts. You can read my description of how I remedied it without having to change, delete, or re-enter any information, and the keychain message that popped up, in the other thread on this topic as listed in the entry below.
    Titanium Powerbook G4 (Onyx), Mac OS X (10.4.11)
  • John G4 Calculating status...
    I've also experienced this problem where network preferences enters a seemingly endless loop and reports that " your network settings have been changed by another application", and it is tempting to associate this problem with the recent security update. Internet Connect also hung at some point.

    I've escaped from the problem by using the two handed trick that another used suggested earlier: by clicking on OK to the recurring message, and very very quickly selecting Edit Locations, I was able to delete some locations and create new locations with the same information. This is not an elegant solution but it seems to work.
    Powerbook G4
  • jad713 Level 1 Level 1 (0 points)
    This does seem to work. Created a new location. Locked it to prevent changes. Hopefully it will keep working.
    MacBook Pro, Mac OS X (10.5.2)
  • Bezvardis Level 1 Level 1 (65 points)
    Same problem here. Stopped by the same method (quickly clicking on ok, then on locations and editing it and then locking). But: what an annoying bug. Apple would do nice if they said they were working on fixing it.
    Powerbook G4, 12, 1.33, Mac OS X (10.4.5)
  • julay Calculating status...
    I am having the same problem. OS 10.4.11, and I just installed the security update.

    Instead of the two-hand maneuver, you can open Activity Monitor, select the active process "System Preferences" then select Quit Process -> Force Quit.
    MacBook Pro 2.16Ghz Core 2 Duo, Mac OS X (10.4.11)
  • i.cypek Calculating status...
    It has to be the update (Security Update 2008-006 (Intel) 1.0).

    I only saw that alert when I was truely changing my setting with Vodafone Mobile Connection; but since this update, I get this alert loop problem. Solution has been to click on OK and use the short cut to quit i.e. ⌘Q

    I hope that Apple are listening to all these problem and get a quick update to fix this problem!
    MacBook Pro 15", Mac OS X (10.4.11)
  • Dennis Bolt Calculating status...
    Same problem. iMac with 10.4.11. I did the updates including iTunes. I would not be too flustered BUT since the iTunes 8 update, I cannot stream music to my Airport Express, and Apple online support document says to go into the network preferences and fiddle with some settings, BUT with this endless loop error, that is impossible. SO I guess I have to wait for Apple to make some fixes on there end?
    iMac 24" 2.33 ghz intel core 2 duo, Mac OS X (10.4.10), Powerbook G4, iPhone, other older macs
  • Steve Thompson Level 2 Level 2 (405 points)
    yoojin's apa said 'I am with the people who think it is the security update that did it.'

    agreed and hopefully Apple are rectifying the situation.

    yoojin's apa said 'I used the return key to click the "OK" button on the "Your network settings have been changed by another application" screen and then immediately clicked on the "location" pull down menu and was able to get in before the next alert screen came down.

    Then I pulled down to "edit" on that location pull down, and for no real reason, clicked rename and then cancel. The endless loop of alerts went away and came back after I closed system prefs, but it was gone long enough to switch locations . . .'

    This worked fdor me thank you for the advice
    Steve
    iMac (ALS) G5 (2GB ram), Mac OS X (10.4.11), BondiG3 (10.3.9) 1 extreme/5 expresses/3 ipods/tv

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.