Skip navigation
This discussion is archived

"Your network settings have been changed by another application"

72574 Views 64 Replies Latest reply: Nov 22, 2009 3:15 AM by roger Symons RSS
  • Anthony Pucca Level 1 Level 1 (15 points)
    Michael Neely's solution I think is the superior one. I tried it and the problem is gone. I was also able to adjust the IP addresses on my unit against my router to solve a problem of no more than one Mac on my wifi network at a time.
    Mac Pro, Mac OS X (10.4.11)
  • Jon Burr Calculating status...
    *I found the solution, at least for me* - I'm on OS 10.4.11 - The problem went away after I updated the firmware on my Airport Express.
    Sorry, i don't have the link handy, but it's easy enough to find.
    G5, G4 laptop, Mac OS X (10.4.11)
  • lynnie61 Level 1 Level 1 (40 points)
    I also experienced this problem after doing the 2008-008 security (and also 10.4.11) updates. The solution as suggested above worked for me: Click ok then immediately click the lock to prevent further changes. Force quit on system preferences and then re-open. Problem solved. I also clicked the lock to see if the problem recurred and it didn't. Very simple fix.
    imac4,1, Mac OS X (10.4.9)
  • lynnie61 Level 1 Level 1 (40 points)
    Scrap that... it came back again after i unlocked and quit. Seems to work ok if I just lock it... but what if I want to make changes to the network??
    imac4,1, Mac OS X (10.4.9)
  • gald Calculating status...
    This solution worked for me
    iMac, Mac OS X (10.4.11)
  • roger Symons Calculating status...
    Here is a 4-step solution that worked for me:
    1) As soon as you get the looping message, Force Quit the System Preferences application.
    2) Re-launch the System Preferences application and open the Sharing pane (not the Network pane).
    3) Check and if necessary restore your sharing settings (from your back up records), then close the Sharing pane and open the Network pane. The looping should now be gone
    4) From the Location tab of the Network pane, choose "Edit Locations…". Duplicate your active Location, call the duplicate say, "Location Copy 1" then delete the original.

    This has (so far) fixed the problem on both my computers.
    G3 iBook, plus 2 GHz G5 iMac, Mac OS X (10.4.11), Networked with FireWire cable. Dial-up Internet. Shared printer.
  • pfarn1 Calculating status...
    You are absolutely brilliant! These steps resolved the issue immediately. Thanks so much for posting the information.
    iBookG4, Mac OS X (10.4.11)
  • roger Symons Level 2 Level 2 (180 points)
    Unfortunately, the solution that I suggested only works for me until the next re-start, when all the Sharing settings are unlocked and corrupted again. When I correct the Sharing settings I find that Internet sharing spontaneously turns off the moment I leave that Internet tab. The only way to beat it is to first establish an Airport network with another computer; only then can you lock Internet Sharing "On", and have it remain "On" after you disconnect the network. Establishing an Ethernet network or a Firewire network will not do the trick.
    As you can imagine I am heartily sick of this bug, which I have suffered for at least six months. The newest Security Update for PowerPC hasn't fixed it either.
    G3 iBook, plus 2 GHz G5 iMac, Mac OS X (10.4.11), Networked with FireWire cable. Dial-up Internet. Shared printer.
  • Peter Linz Calculating status...
    I don't know if this will work for other Mac models, but I had a Mac Genius solve this one for me & it ended up not only fixing the "Network Settings" issue, but it also freed up memory and made my 4-year-old PowerBook G4 run like new. In this procedure, you trash your preferences, which doesn't delete your data, but you may need to set up Mail again, so it's a good idea to jot down your Mail account information. Also, I believe it'll delete all 'locations' other than 'automatic' in your Network Settings.

    1. Quit all open apps
    2. Repair Permissions
    3. Drag the entire contents of your preference folder to the trash (MacintoshHD/Library/Preferences)
    4. Empty Trash
    5. Perform an SMC Reset (PowerBook G4: Shut down your computer. Press the power button and hold it down until it beeps, 5 - 10 seconds) http://support.apple.com/kb/HT1411
    6. Perform a PRAM Reset (Restart your machine holding down CommandOption+PR, wait for two or three chimes & release)

    And now, a warning: (and NOW a warning?!), The next time you fire up any application, they'll act as though it's the first time you've ever run them. You'll have to tell iTunes where your music library is located (in your iTunes folder, btw) and if you use Quicken, you'll have to tell it to open your latest backup of it. Don't Panic. All your data is there. You just might need to tell some apps where to find it. I hope this helps!
    17 PowerBook G4, Mac OS X (10.4.11)
  • els1 Level 1 Level 1 (0 points)
    This worked perfectly for me also.
    Powerbook 1.0 GHz 512 MB, Mac OS X (10.4.11)
  • els1 Level 1 Level 1 (0 points)
    And as mentioned above, it failed again after restarting preferences.
    Powerbook 1.0 GHz 512 MB, Mac OS X (10.4.11)
  • iyedo Calculating status...
    Roger.
    Do you know if the "your network settings have been changed by another application" problem has any relation to my inability to log into "ftp" sites to upload or not being able to download apps from web sites?
    g-5 dual powerpc, Mac OS X (10.4.11)
  • Boneandfeathers Calculating status...
    It is a easy solution. Please install the latest security update 2009-002. And when you open the networks window, you will get the message "Your network settings have been changed by another application." Use you 'enter' key and the message vanishes for a second. In that second gap, click on 'Assist me...' at the bottom with your mouse. And then you get a message from Assist me. Press 'Cancel'. It should resolve.

    Hope it helps!
    MacBook, Mac OS X (10.5.7)
  • roger Symons Level 2 Level 2 (180 points)
    Unfortunately Security Update 2009-002 makes absolutely no difference. I have suffered this maddening bug for 12 months now. As well I have suffered from the cryptic message "your modem has unexpectedly hung up" since the year 2003 - that's 6 years so help me!
    G3 iBook, plus 2 GHz G5 iMac, Mac OS X (10.4.11), Networked with FireWire cable. Dial-up Internet. Shared printer.
  • Hunter.Peck Level 1 Level 1 (15 points)
    Found this solution for Mac OS 10.4.11 while googling the web:
    [A simpler fix I found tonight is to open System Preferences, go to Security and check "Require password to unlock each secure system preference."]
    source: Pieter B. http://urbantektonic.com/tekblog/2008/10/mac-network-settings-changed/print/
    eMac, Mac OS X (10.4.11), also run 10.5 on a miniMac

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.