7 Replies Latest reply: Dec 1, 2008 7:52 PM by KJK555
StringerPhotography Level 1 (0 points)
I have made a mistake and have no clue how to fix it. When I call Apple they are so confused. Here is the deal. I was using a public internet access. So I went to make sure my hard drive permission was not available to everyone. So I changed all three to never.....

Admin - never
System - never
Everybody - never

I think this is the three that is listed.

Well after checking emails I shut off the computer. Later that night I turned it on and it opens to the grey page with the apple and spinning wheel then the screen turns blue and you see the small spinning grey circle and the spinning grey circle will leave and come back leave and come back. It will not boot up. I have checked my drive with Disk Utility and everything is ok.

Somebody told me since I sent all my 3 permissions to "NEVER" I have "locked" myself out of my computer.

Can anyone help???

Please, Please, Please

Thanks

Macbook Pro, Mac OS X (10.5.4)
  • baltwo Level 9 (62,215 points)
  • StringerPhotography Level 1 (0 points)
    Thanks sooooo much!!!

    It worked with no problem.

    Charlie
  • baltwo Level 9 (62,215 points)
    Thanks for the feedback and reward. Good computing.
  • 00afro Level 1 (0 points)
    Not quite the same problem, but basically, the internal Hard drive on my MBP is now mounting as Read Only. This means I cannot boot up from that disk. Luckily I have a backup on an external drive and have booted from that. However the internal disk takes ages to appear on the desktop, together with a "This disk cannot be repaired by this computer" message. The same thing happens in Target disk mode: it mounts after a while with the same error message.

    tried Niel's solution from the link above and when I type in CHMOD... terminal comes back with
    chmod: /Volumes/ volumename/: Read-only file system

    is there anything I can do apart from erasing the drive?
  • KJK555 Level 4 (2,895 points)
    Start the computer in single user mode and run the commands, not in firewire mode.

    Kj
  • 00afro Level 1 (0 points)
    Cheers for the reply, but that's what I did, I only had it in Target disk mode to make sure I could access the disk. What threw me was that the disk wasn't my startup disk so I used option A2 from Niels instructions. However, I managed to get it to boot using the "Mount -uw" etc,
    The problem I now have is, I want to reinstall OSX on the internal drive, but when I boot from my external drive and the internal still mounts as read only. How can I make the process I go through using Niels method stick so the drive remains "read and write"?

    thanks
  • KJK555 Level 4 (2,895 points)
    set permissions on data drives as:

    owner: root group: admin chmod 775

    example:
    sudo chown root:admin /Volumes/data1
    #subsitute the actual drive name for 'data1'#
    sudo chmod 775 /Volumes/data1

    Kj