8 Replies Latest reply: Dec 8, 2005 7:50 AM by dolomite
Mike Shondeck Level 1 Level 1 (25 points)
Help please! I've been at this for 6 hours now, My pentium 4 win xp SP 2 machine keeps thinking that my wife's new iPod Nano is a "USB Mass Storage Device" and I keep getting the "do not Connect" warning. I've tried unistalling everything and starting from scratch 4 or 5 times now with no progress. If I have the device manager open and uninstall the "USB Mass Storage Device", then connect the iPod, I can see Win XP initally recognize it as and iPod, then the next moment, it changes to "USB Mass Storage Device" and I'm back to square one. It is really frustrating because this was a special gift for my wife and it just won't work!
  • Victor Roman Level 1 Level 1 (20 points)
    I have Windows XP SP2 and it says it is a USB Mass Storage Device, but it works fine so I assuming it is supposed to say that. Do you see the "Safely Remove Hardware" with the green arrow in your taskbar, lower right hand corner? If you click on that to open up the window, does it say USB Mass Storage Device? Try clicking on "display device components" and you should see "Apple iPod USB Device."

    You should also note that "Do Not Connect" will show up whenever the device is being accessed, potentially by the iPodService application running invisibly in the background. If your iPod says "Do Not Connect" that is what this means.

    Out of curiousity, what drive letter is your iPod assigned when you connect it? You should be able to find this by double clicking on the "My Computer" icon, it'll look like a device with a slot and should be titled "ipod."
  • Mike Shondeck Level 1 Level 1 (25 points)
    When I click on the arrow, yes it says what you have, the iPod is assigned volume F, but underneath it, it says Generic volume F:. The other wierd thing is that I had to buy a USB 2.0 card for this machine (it orginally had only USB 1.1) and since I installed it I also plugged my Epson PictureMate printer into it and the computer also thinks that the printer is a storage device (volume G:),it wasn't that way before the card install, but it works though.

    How long should that "Do Not Disconnect" message last? It simply does not go away, and iTunes does not "see" the iPod.
  • Victor Roman Level 1 Level 1 (20 points)
    I am copying this from another post in the forum:

    First install the iPod Updater program, you can download it from this very website! Once the program is installed, run it. It will ask you to connect your iPod (even if it is connected before you start the program, it may need you to disconnect/reconnect it), once you connect it, what happens? Does it just freeze up for a long time? If it does let it sit, give it at least an hour and tell us if it gives you an error message (most likely "could not mount ipod") and how long it took before it gave you the error or if it just continues to sit there. What SHOULD happen is it will list your iPod model, serial number, space, etc. and the "Restore" button should become clickable (Update will be disabled because you have the most up to date version of the software).

    Try this out and post the results.
  • Mike Shondeck Level 1 Level 1 (25 points)
    Ive done that twice over the last 6 hrs. I was able to get to the RESTORE button, and the software reinstalled on the iPod, then went to reboot. After the reboot, it went back to the "do not disconnect" message again.
  • Victor Roman Level 1 Level 1 (20 points)
    Do Not Disconnect should go away when you, well, disconnect the iPod from the USB port. It will also go away when you "Eject" the iPod using iTunes. Lastly, if you use the "Safely Remove Hardware" icon in Windows, "Do Not Disconnect" will go away.

    Essentially, if you can go to "My Computer" and see your ipod, it should say "Do Not Connect" on the ipod itself. If you can't see your ipod in "My Computer" it should not say "Do Not Connect."

    My guess is that iPodService.exe is having problems accessing your iPod. Try restarting the service, also try switching the iPod to use a different drive letter.

    If working properly, under "Safely Remove Hardware" you should see these components in the following nested structure:
    USB Mass Storage Device > Apple iPod USB Device > Generic Volume (then drive letter)
  • Mike Shondeck Level 1 Level 1 (25 points)
    Everything in the last post is correct. I feel that the iPod itself is working properly. When I disconnect(Eject) it, all of it's functions seem to work. iTunes still does not see the iPod. It says that there is no ipod connected. I've tried changing the drive letter in the admin tools to no avail. Ive put it back to F:. I am using iTunes 5.0. I did restart the machine and can see that iPodService.exe is running, but iTunes won't recognize the iPod. Thanks for your help so far, but I'm still stumped!
  • Aaron Dixon Level 1 Level 1 (0 points)
    I was having the same problem. I also had to buy a USB 2.0 card. I could not get iTunes to see my iPod nano. iPod software would hang during installation after connecting the iPod. Windows did see it as a drive.

    The only way I can get it to work is to use the USB 1.1 port on my laptop. It seems to be working just as it is supposed to. Of course it is slow transferring songs. It even appears to be charging the nano. I thought I read that this was not possible.
  • dolomite Level 1 Level 1 (0 points)
    Mike:
    I have both an IPOD mini and a new IPOD shuffle that I am unable to get recognized by my WinXP SP2 machine. I have what appears to be the exact problem that you have. Did you ever find a solution?

    Regards
    ...Wes