13 Replies Latest reply: Oct 22, 2009 8:05 AM by mvizzina
Tim Bloom1 Level 1 (110 points)
I'm having an issue on a client's computer, and suspect it's a bug. Ever since they've updated to 10.5.4 they're randomly getting getting this error:
"This message can't be saved to the Outbox. The message contains one or more attachments that are too large to be saved in the Outbox. Try deleting some attachments"

The issue is that the attachments are less than 1MB, and should not be causing this error. I've checked the settings on the server and client machines, nothing is set wrong from what I can tell. I've gone through the general troubleshooting steps (repair permissions and such..)
We've narrowed down the issue to specific emails that have background images that are being forwarded. They can be forwarded by stripping the email by making it plain text then reattaching the attachments, but I would like to know if anyone has had this issue and found a full-time workaround.

MacBook Pro, Mac OS X (10.5.4)
  • MarkTroutman Level 1 (0 points)
    Tim, any update on this? Having the same issue here.
  • Marco Romeny Level 1 (0 points)
    Bump... same issue here, but on 10.5.5
  • Tim Bloom1 Level 1 (110 points)
    I have not seen the issue reappear after updating to 10.5.5 yet. I also ran maintenance on their mailboxes and mail database just to rule them out.
  • DelegatorNH Level 1 (5 points)
    I'm seeing this on 10.5.5 with a message whose attachments total only 97KB...
  • John Benedetti Level 1 (5 points)
    I'm seeing this issue with 10.5.6. I googled the error, but this is really the only discussion I've found. Doesn't appear to be too widespread. Question: are you guys using IMAP? I'm thinking it could have something to do with our IMAP servers and not Mac Mail at all. Just a theory, and I'm hoping maybe you guys can confirm whether you're using POP3 or IMAP.
  • John Benedetti Level 1 (5 points)
    Tonight I restarted the IMAP and exim services on my web/mail server and the issue went away. I wish I had done it one-at-a-time so I could confirm which was the cause, but alas... I was also traveling when I first discovered the problem, so it's also possible the network admin providing my wireless at my travel location had set some limits on outbound attachments. So there are really 3 potential causes for this issue, none of them really Apple's issues.

    So for others who are having this issue, try the following:

    1.
    Quit Mail and try again from a different location or network.

    2.
    Have the sysadmin in charge of your webserver or mail server restart IMAP and/or exim.

    3.
    If you can't do either of the above, try using webmail. Mobile Me users can hit their mail from me.com and most web hosts will provide a webmail application for their customers. Not sure if this will help, but it seems like it would...
  • Thomas.Me Level 1 (0 points)
    I am having this message on 2 x POP and 3 a IMAP account. It only happens when I try to forward a message, new messages with attachments work fine. Any other ideas?
  • Cristina Marchica Level 1 (0 points)
    I am getting the same error and have very small attachments. I'm not sure I am following the steps provided to fix it. Could you simplify steps? Thanks, Cristina
  • DelegatorNH Level 1 (5 points)
    The only workaround I've found is to use Reply instead of Forward. For some reason the semantics seem to differ between the two. So, I use Reply instead of Forward, remove the reply-to address, and put in the Forward-to addresses. I may or may not change the Re: to Fwd: depending on my mood.
  • gayrad Level 1 (0 points)
    Iam having same issue on forward mail on imap server, i can reply and change address, but what a hassle.

    Sigh!

    The computer says now.
    Unsure is Dreamhost would do this to the mail server for me?
  • srinivasan shanmugam Level 1 (5 points)
    I had the same issue and issue was resolved when I check marked the below in Composing option for message format in mail preferences. Hope it helps

    Mail->Preferences->Composing
    Responding:
    [x] Use the same message format as the original message
  • mvizzina Level 1 (0 points)
    Thanks for that tip. I just tried it though and the problem persists. I quit mail, and re-checked the preference change that you suggested and still it did not work. I still get:

    "This message can't be saved to the outbox. The message contains one or more attachments that are too large to be saved in the Outbox. Try deleting some attachments."

    Has anyone else had success with using the previous preference change?