Previous 1 2 3 Next 31 Replies Latest reply: Jun 19, 2009 1:13 PM by crzygirlntx
ticklingadragon Level 1 Level 1 (0 points)
I'm using 2.1 firmware on my iPhone 3G and iTunes 8. I have no problems syncing all my data to and from my iPhone. The only thing is I can't seem to get iTunes to back up my files!! Everytime I try to run a backup, iTunes tells me that my iPhone has been disconnected, although it's still displayed on the devices panel.

Someone please help me with this!

MacBook Pro, Mac OS X (10.5.4), 2.1 iPhone 3G
  • gumsie Level 4 Level 4 (2,150 points)
    have you installed any new apps lately? I had that problem with one of mine. Went fine after I removed it.
  • ticklingadragon Level 1 Level 1 (0 points)
    yeah I have. But I installed a few at a go so I'm not sure which one it is. But I'm gonna give this a shot and see if it works. I just reinstalled iTunes and the problem still exists.
  • gumsie Level 4 Level 4 (2,150 points)
    If one of them is Hearts........
  • ERamosLV Level 1 Level 1 (0 points)
    I am having the same problem. It will not sync or upgrade to 2.1. I deleted all of the applications that were new and it did not help. Any other advice??
  • Jason L Community Specialists Community Specialists (10,745 points)
    I would also recommend looking at 3rd party apps. This may be an issue without outdated third party apps as users have described in this thread: http://discussions.apple.com/thread.jspa?threadID=1702442

    Does iTunes backup the iPhone in a new user account?
    If it does, you may want to look at the User login items in System Preferences> Accounts> Login iTems.

    If it does not, this may be a connection issue.
    Make sure the iPhone is directly connected to a high speed USB port on the Mac.

    Jason
  • ERamosLV Level 1 Level 1 (0 points)
    I have deleted several of the third party apps that were added since my last backup and that didn't work. The phone is connected and shows up in iTunes. I have tried two different things. First, I tried to update software. The software downloads and then during the attempted backup, there is an error message that says "can not back up. iPhone is disconnected". Then, I tried to just sync and got the same message. So there seems to be some conflict in the backup.
  • ticklingadragon Level 1 Level 1 (0 points)
    Yup, that's the exact same problem that I'm experiencing. I deleted all my apps and tried to do a backup but the same issue came up. Then I tried reinstalling iTunes but everything is the same. Syncing is still okay for me. The only problem is getting iTunes to do a backup.
  • ticklingadragon Level 1 Level 1 (0 points)
    I doubt it's an issue with the cable because syncing all my stuff onto the phone is fine. I have tried it on both ports on my MacBook. How do I know if iTunes has been backing up the phone in a different account? I only have one account, btw. Also, would it help if I deleted all my previous backups? I'm not using any third-party apps, if that helps.
  • Jason L Community Specialists Community Specialists (10,745 points)
    ticklingadragon wrote:
    How do I know if iTunes has been backing up the phone in a different account?

    You would have to create another User account and test syncing/backing up. Go to System Preferences> Accounts> Click the lock in bottom left to unlock> click + above the lock to create another test account.

    Also, would it help if I deleted all my previous backups?

    You can try that, you would lose the option to recover from those backups.

    Jason
  • jcwacky Level 1 Level 1 (10 points)
    I am having this problem too. Did you find a solution?

    Syncing works fine, but when it tries to back up it goes really really slowly and eventually says that it couldn't backup because the iPhone disconnected.

    I'm on 2.1. And iTunes 8.

    Thanks
    James
  • Woodsy1 Level 1 Level 1 (25 points)
    I had this exact same problem. Back up would take a good couple of hours and would usually end with an error message saying that back up could not complete because the iPhone had been disconnected. Not sure when during the process this happened, because I'd often leave it going overnight, only to find the error message in the morning.

    Anyay After looking at these discussions and searching the web for similar posts on other forum, I tried the following, which seemed to work.

    1. With iPhone disconnected from computer (I have a MacBook) I deleted the previous back up (which was listed under iTunes > Preferences > Devices).
    2. Quit iTunes and all other programmes
    3. Go to disk utility and repair permissions for disk
    4. Restart MacBook
    5. Hard reset of iPhone (home and standby button pressed together for approx 10 sec, until screen goes blank - let go as soon as this happens)
    6. leave iPhone for about 10 mins
    7. Restart iPhone and plug in - iTunes should start and perform a back up immediately before syncing. This took about an hour, but completed OK.
    8. Just to make sure the MacBook or iPhone were not 'going to sleep' (which might have caused the disconnect error before??) I routinely moved the mouse on the keyboard and on the iPhone
    9. Verified good back up by checking it under iTunes > Preferences > Devices - there should be a back up there in the name of your iPhone and the time you did it.

    Hope this works for you guys. Not exactly technical, but I'm not a developer or anything, just a keen user.

    Cheers.

    Message was edited by: Woodsy1
  • Andreas Amann Level 5 Level 5 (7,815 points)
    You might want to try to connect your iPhone via a powered USB hub instead of directly to your computer - this is the only way I can get it to work on my G4 PowerBook. I guess the phone just draws a little too much power during the backups…

    Andreas
  • zasr Level 1 Level 1 (0 points)
    that kept happening to me, but it was because the computer kept sleeping before it finished the backup, which cancelled it. the iphone is now backing up, but ive turned off sleep, which seems to have solved the problem.
  • luckyguy9 Level 1 Level 1 (0 points)
    There's nothing wrong with your iPhone! You don't have to remove every application, restore, reboot or anything complicated!

    Here's the definative answer from APPLE. The "Mobile Sync Program" on your computer needs to be rebooted. Here's how:

    IN WINDOWS XP

    Go to Control Panel (switch to Category View)
    Go to "Performance and Maintenance"
    Go to "Administrative Tools"
    Double click "Services"
    Right click on "Apple Mobile Device", then "stop" it and then "restart" it
    reboot your computer
    start iTunes
    plug-in iPhone
    right chick on your iPhone device on left on the screen and chose "Backup"
Previous 1 2 3 Next