Previous 1 2 3 Next 199 Replies Latest reply: Feb 15, 2010 4:24 AM by JemmaWNN
kaitpg Level 1 (0 points)
i just bought the new ipod upgrade so i can buy all these applications. well after i bought them all i go to play them and they dont work. so i tried restarting my ipod a few times and it still doesn't work. what it does is it goes on the application then goes to the applications main page for about a second then immediately goes to the menu page of my ipod. please please help me!

  • CasperGemini Level 5 (4,305 points)
    So, when you open applications it kicks you back to the Home screen?

    Do all applications do this, or only some?

    If it happens with specific apps, try reinstalling them.
    To uninstall, hold your finger on an icon on the Home screen until they start shaking, and then tap the X that appears on it. To reinstall, you can either re-sync the app from iTunes, or download it directly from the App store on the iPod touch (even if it's a paid app, you can download again for free if you act as though you're going to pay for it again).

    If it's happening with all third party apps you might want to consider updating your firmware if not already running the most recent version. Connect to iTunes, and click the Update button on the Summary page. If there are no updates available, or updating doesn't help, you can restore the iPod in iTunes as well, and then re-sync your content to it through iTunes.

  • PaulB Level 2 (200 points)
    This just happened to me today. At first I thought it was the internet connection since I'd had it turned off the day before while traveling. In the process of checking through that, I launched the App Store application and found three apps had upgrades waiting. I did all three upgrades and then all the downloaded apps started working again.
  • xheadman Level 1 (0 points)
    same thing has happened to me, have tried resetting iPod with no effects what so ever. so i have removed all the apps off the iPod and will be reinstalling them later. Just make sure you have the latest version of the firmware available as this can sometimes be the problem, was for me. hope this works as i've had it less than a week
  • C.Hoi Level 1 (0 points)
    This just started happening to me, but on all of my apps. I just checked to see if there were any updated, but there weren't. I just got this the other day and downloaded my apps last night and the night before. I don't know what to do. Please help me!
  • aznm0nk3y Level 1 (0 points)
    Ok, I just got my ipod touch this last weekend and I've encountered this issue twice already. It is happening to all of my downloaded applications, ones that do not require internet access. The first time they all started it, I ended up deleting them all and reinstalling to get it to work. That seemed to help for the time. Then today I brought my ipod to work and during my downtime I found that they didn't work again. They act like their gonna load, then just shut off back to the applications menu (home). This really doesn't make for a good first impression considering this is my first apple ipod experience this week.
    Where's the help?!
  • Flynn Level 3 (795 points)
    Same experience here but I found that just deleting one of the apps and resyncing it from iTunes to the touch made all the apps work again. If it happens again I'll just try downloading one of the apps again from the App Store and see if that also fixes all the apps.
  • mikeiow Level 1 (0 points)
    Yup, this has happened twice to me: ALL apps stop working (actually they all go to their first screen, then jump back to the main screen of apps).
    Doing something to re-attach to itunes store (as someone said, deleting app or perhaps reinstalling one) appears to fix it....but of course when they stop working I am not on the network: latest was on a plane heading somewhere, so no apps would work during my entire trip!).

    This is appalling. It looks like some odd authentication error, but really this needs investigating. Someone from Apple SURELY should be investigating this & posting some fix.

    & yes, this is on the latest f/w, yada yada.
    Any way to raise this kind of issue to the attention of Apple ? I spent ages scouring their so-called "help" system to no avail, and I cannot find anywhere to actually contact their technical support !?

  • Newsflash Level 1 (0 points)
    New poster here with a brand new Touch and the exact same difficulty.

    It's really difficult for me to believe that I spent this kind of money for a Touch which has this serious a problem. Apparently, it has been going on for months and through several software updates. Also, it appears Apple support is MIA on the issue.

    I'm wondering if there is a common, rogue app that might be causing this? Buying applications that don't run, and having to go through resets, downloading new programs, etc. all the time is just not acceptable.
  • sobersecondlook Level 1 (0 points)
    I checked in the Support section. One possible solution is checking to see what you have open (eg Safari pages you may not even know you have open). This occupies memory and prevents apps from loading. I have been having the same problem and was de-installing and re-installing apps until I noticed that sometimes if I just waited a while, the app would load normally. I think it is the memory issue.
  • sobersecondlook Level 1 (0 points)
    Following up on my answer a second ago: close some Safari pages and/or restart the machine (hold on the power button - upper left side - until power off slider appears or hold it and home menu simultaneously (that restarts it))
  • mikeiow Level 1 (0 points)
    Nope: both times it happened to me I did that full reboot.....& the problem still existed. It is like the apps suddenly all get "un-authorized", and need to be "refreshed" with a visit to the applestore.

    Curiously I only have some free apps loaded. Frankly if Apple can't sort this BASIC issue out, then I'm darned if I would ever pay for any apps. Digital Rights Management is one thing, locking customers out of valid use of their machine is quite another.

    Come on Apple, speak up & fix this fault !
  • Henry280 Level 1 (0 points)
    I had the same problem on two different IPOD touch's.
    Both times it happened after I synced some large video files onto the touch. It almost looks like adding large media files sometimes over-writes the existing programs. This looks like a serious flaw in the current IPOD touch 2.2 firmware. It's time for version 2.2.1
  • drum! Level 1 (20 points)
    i have the same problem. Have downloaded apps and none of them work, free or paid for. I have deleted the free apps, restarted the ipod, reset the ipod, sync'd applications, un-syncd applications. nada-apps dont work. Apple, what's going on?
  • F Shippey Level 7 (21,500 points)
    From time to time, an application may crash. (After all, the touch IS a computer.)

    Just like any computer, a reboot usually helps. Hold down the 'Sleep/Wake' button at the top left of your touch until you see the Red Slider on the screen as asking 'Slide to power off'. Slide it to shut down your touch. After it is off, hold down the 'Sleep/Wake' button and you should see a black screen with a silver Apple as the touch reboots (this can take several seconds).

    BTW, the 'Sleep/Wake' button" isn't a power off button; it only puts the touch to sleep or wakes it up. The Red Slider is the real power off button.
Previous 1 2 3 Next