12 Replies Latest reply: Nov 20, 2009 9:53 PM by Kenny Velez
Scott Crawford Level 1 (0 points)
When I select an MP4 movie and then choose Advanced -> Create iPod or iPhone Version, the movie is converted and a new version is created, but they don't work correctly. In two cases, the resulting file has audio, but the video is missing (just white). With another file, the video is there but the audio is missing. How can I troubleshoot this and get the videos converted properly so I can play them on my iPod?

iMac4,1, Mac OS X (10.5.1)
  • Scott Crawford Level 1 (0 points)
    PS - the same thing happens whether I do the conversion in iTunes or directly from QuickTime. I choose QuickTime File -> Export, then choose "Movie to iPod" and it creates a new movie with the m4v suffix, but that file has to video, only audio, whether viewed in QT or iTunes.
  • lorentje Level 1 (0 points)
    i have the same issue, files converted through itunes have the white effect. mp4 files i downloaded play in itunes, but won't transfer to the iphone. and files that i converted from avi to ipod format work fine (just takes an entire day to convert).
  • wanderlusterer Level 1 (5 points)
    I'm having the same problems as well. The video I have is beyond the dimensions of the requirements for my ipod, since it's 1024x576. I get the white screen and full audio, but no video.

    Anyone, Bueller? Anyone?
  • mkralo Level 1 (0 points)
    I am having the same issue. I spent days converting all of my home videos into apple's mp4 H.264 format. Now they play on my apple TV, and in quicktime and itunes. They also will play on my itouch, but for some reason they will not transfer to my iphone 3g. It says "xxxxx.mp4 was not transferred because it cannot be played on this iphone. When i choose to "create an ipod or iphone version" it will then sync, but I really dont want to have to re-convert every video i have because of this glitch. Anyone figure anything out here?
  • W Budding Level 1 (0 points)
    Having the same issue here. With mencoder (http://en.wikipedia.org/wiki/MEncoder) I create an H264 file, after that I create an MP4 file with mp4creator (http://mp4creator.sourceforge.net/). Then I can import the .mp4 file in iTunes just fine, it plays well. But when I select the file, go to menu Advanced, choose 'Create iPod or iPhone Version', the file is converted, audio is fine but video stays white .
  • osxdude Level 1 (80 points)
    I am having the same exact problem as all of you, but I tried to save it in QuickTime Pro (not export, save), and it gave me an error saying: The movie contains an incorrect time value. Assuming this meant something was wrong with the timing, I cut off the last few milliseconds of the video which did not fix the problem. Exporting as a QuickTime Movie fails as well, with the same result of the m4v's.
  • Flames2StarDust Level 1 (0 points)
    I'm having the "white screen, only audio" problem.

    Has anyone figured this out???
  • NathVG Level 1 (0 points)
    Same problem here. I added .mov files to the iTunes, and synced to my iphone 3gs but I got a message "was not copied to iphone because it cannot be played on iphone"
    Fine, I chose the "Create iPod or iPhone version" from Advanced menu by selecting the video. iTunes gave a message that "could not be converted because this file does not allow saving or conversion"
    Please, somebody resolve or provide a work around. I am using iTunes 8.2.1.6 and iPhone 3GS v3.0.1
  • puma1824 Level 1 (0 points)
    Same issue here...is there a fix?
  • SA Level 1 (5 points)
    Had the same exact problems. Solved it by ripping the original movie disc with Mactheripper then using the default preset for iphone/ipod in Handbrake. Open in iTunes and sync with device. This bypasses iTunes conversion process which obviously needs a fix or something. Programs are free downloads off the internet. Tutorials and forums for these programs on web.
  • supexcellency Level 1 (0 points)
    I think this is an obvious CODEC problem. I can't really say what is wrong with these settings because I have no idea what your specs are and what codecs you are using for export/import. For the most part, I would suggest downloading the K-lite codec pack (it's free) which contains most of the codecs you will need (unless you are doing professional video editing). I have learned that installing this codec pack solves 99% of the transform issues.
  • Kenny Velez Level 1 (70 points)
    Just adding myself to this. Same problem. I remember having this when SL just came out and haven't tried it since but I'm surprised it's still happening.