10 Replies Latest reply: Feb 18, 2009 7:59 AM by Jake Abramson
kris1017 Level 1 Level 1 (0 points)
My iMac just stopped recognizing CD-R's. It will read commercially bought CD's, DVD-R, etc. When I put a CD-R in the drive it makes a sound as if it were loading and then a fan runs for about 5 minutes before spitting the disk back out.

Before this problem I did not change any settings. I have already checked my settings in system preferences, reset the pram, and fully reinstalled OSX all to no avail.

Any suggestions are GREATLY appreciated



I am using an Intel iMac on OSX(10.5.5)
Pioneer DVD-RW DVR-K06A

Intel iMac, Mac OS X (10.5.5)
  • Ian R. Brown Level 6 Level 6 (18,400 points)
    Is it just one particular CD-R or is it doing it with all CD-Rs?

    If it is just one it may be that the CD is defective.
  • kris1017 Level 1 Level 1 (0 points)
    Thanks for your response Ian!

    Unfortunately this is happening with all CD-R's including those that will work in other computers.
  • johnwesleybarker Level 1 Level 1 (90 points)
    Same here. This is the 4th thread I've responded to. The drive will not accept the discs. Wo;t show up on Finder or anywhere else.
  • Sass Level 2 Level 2 (330 points)
    Same problem with a MacBook Pro!

    Sass
  • RockabyeJames Level 1 Level 1 (0 points)
    More than likely the problem is that your default option when inserting a blank CD is to open iTunes. Open System Preferences, choose "CDs & DVDs" under Hardware, and change the default action for "When you insert a blank CD:" to "Open Finder".
  • Sass Level 2 Level 2 (330 points)
    Already have those settings

    Sass
  • RonL-Fritz Level 1 Level 1 (0 points)
    I've been looking for an answer to this problem, but this post seems to have stopped.

    My intel mac stopped recognizing any CD. I've been copying CDs, and at one point, I think I accidentally dragged the CD icon in the Sidebar out to the finder. Since then, the imac tries to read a disc (I've tried many different ones), and after a while just spits it out.

    I've checked my System Preferences and blank CDs/DVDs are set to Open in Finder. Music, Picture and Video CDs are checked to open in iTunes, iPhoto and Open DVD Player respectively. Finder Preferences for CD are all checked to Show on Desktop. These have always been the settings and the CD drive worked fine before today.

    I've tried restarting (warm and cold boot), and even inserting the Mac OS X boot disc, which it ejects as well.

    Anybody know what happens when the CD icon is dragged out of the Sidebar?? or if there is any other way to "reset" the CD drive?

    Ron
  • Gijs Level 1 Level 1 (25 points)
    I cannot imagine that dragging the cd-icon out of the Finder wil have this effect. Your superdrive seems to be broken.
    As for the original topic, I have the same problem. The drive won't recognize any cd's, but plays, burns and recognizes dvd's fine. This probably means that de CD-laser is malfunctioning. Cleaning it might help, but how do you manually clean a laser in an iMac? A cleaning disc doesn't help.
    The best solution is replacing the superdrive, but if you're out of warranty that's not cheap. The cheap solution is getting an external cd-drive or burner for a few bucks. I had one lying around and that works fine. But if you want your iMac to work as it is intended you will have to replace the drive I'm afraid.
  • RonL-Fritz Level 1 Level 1 (0 points)

    The CD icon was dragged INTO the finder from the Sidebar, and then there was the little puff of cloud and it was off the Sidebar. Maybe that helps describe what happened?? I am doubtful the Superdrive is broken, as it seems to spin fine, ejects OK, but doesn't register or play CDs or DVDs.

    Judging from other posts, this has happened a lot, but with no resolution. I don't understand why there is not more input from Apple on this.

    I checked firmware updates and my computer is fine. I wasn't able to access open firmware when I tried (Restart > Control + Option + O + F ?), but since it ejects OK by itself, I'm not sure what I can check or fix with firmware.
  • Jake Abramson Level 2 Level 2 (450 points)
    I have a related issue.

    When inserting a CD-R it comes up as a blank CD. Commercial CDs, Burned and commercial DVDs work fine.

    I've tried many different CD-Rs from different sources. Same result. I also have a MacPro and they are all readable on that system.