5 Replies Latest reply: Sep 25, 2008 8:07 AM by Athy
Athy Level 1 Level 1 (0 points)
Hullo everybody!

I'm planning to buy a presonus firepod 10x10 interface since I'll need to live record an acoustic drumkit... I found a sweet used model featuring the right price at my local music store, went there and requested to be alowed to plug the unit to my MacBook (2 GHz Intel core duo, running 10.5.5), just to make sure everything was working fine. The unit built-in clock sync'd quickly and smoothly, but when I checked the device's properties under the Audio and MIDI settings utility, the drop down menu read "PreSonus FireBox", and it showed only 6x8 I/O channels, instead of 10x10. Same thing went for Logic: only 6 ins and 8 outs displayed.

I'm posting here since FP10/Firepod drivers are supposed to be part of the Core Audio... Does any of you guys have an idea about what is going amiss? Any kind of help would be truly appreciated.

Thanks in advance,
Marco.

MacBook 13" 2 GHz Intel Core Duo, Mac OS X (10.5.5)
  • deltonfoster Level 2 Level 2 (230 points)
    Hi Athy,

    I would first try to call presonus and ask them what might be wrong. Or, post over on the presonus forum.

    I had the main chip go out in mine, after replacement it now says "FP10" instead of "Firepod"... no big deal. Everything still works perfectly, same chip just different name now. Sounds like something along those lines happened here, just with the wrong part. Sounds kind of fishy...

    Good luck!

    -delton
  • Athy Level 1 Level 1 (0 points)
    Thing is, the unit was also detected as a FireBox when connected to the store's iMac (also running 10.5.5). I might try and partition my HD and fresh install Tiger and see if the problem gets solved.


    Any other 10.5.5 users with a FirePod/FP10 who got the same problem (and possibly solved it)?

    And by the way, posting on the PreSonus forums might not be so easy... Looks like the mods are not planning to unlock new registrations any soon...

    Message was edited by: Athy
  • worldwyn Level 1 Level 1 (25 points)
    If the "FirePod" showed up as a FireBox on your Mac and the other Mac at the store as well, my bet is there is a problem with the Presonus. I wouldn't take the effort to reinstall software on your Mac. I am running a FirePod in my studio and have had no problems with it. Setup was just plug and play. Great audio interface! I would suggest looking for another FirePod, maybe on eBay.

    Good luck!
  • tankfield Level 1 Level 1 (85 points)
    I recently updated the firmware in my Firepod so I could pair it with a friend's FP10, and it now reports it is an FP10.

    If yours is reporting it's a Firebox, maybe someone has loaded the wrong firmware updater, although I would be surprised if that were possible. Unless, possibly, the Firepod and Firebox share the same processors.

    You could try updating the firmware to the FP10 version. You have to do this in Windows, unfortunately.

    Message was edited by: tankfield

    Message was edited by: tankfield
  • Athy Level 1 Level 1 (0 points)
    The unit shows as a Firebox even in Tiger!

    There IS a problem with the interface! The guy at the store is going to use boot camp and restore the FP10/Firepod firmware (thank you guys for suggesting this). I'll let you guys know if the problem gets solved.