7 Replies Latest reply: Sep 25, 2008 4:43 AM by fffred
fffred Level 1 Level 1 (0 points)
I have a shutdown problem on my macbook pro with MacOs 10.4.11. After asking for shutdown, the icons disappear as usual, but the desktop stays, and I can still control the mouse. After a while, it will just go back to the login screen, but I still cannot shut it down : I have then the usual blue desktop background without icons, and I can control the mouse, volume, etc., but nothing happens.

I tried to repair permissions in the disk utility, but it didn't solve the problem. I also did it by booting from the installation disk, and also by pressing the shift key on boot.

Then I tried to add a 'test' user and shutting down from this user. Same thing.

The system.log file looks like that :
+Wed Sep 24 23:23:50 2008 crashdump[535]: crashdump started+
+Wed Sep 24 23:23:52 2008 crashdump[535]: Started writing crash report to: /Library/Logs/CrashReporter/loginwindow.crash.log+
+Wed Sep 24 23:23:54 2008 crashdump[535]: Finished writing crash report to: /Library/Logs/CrashReporter/loginwindow.crash.log+

And the loginwindow.crash.log file shows these errors among many other things:
+Exception: EXCBADACCESS (0x0001)+
+Codes: KERNINVALIDADDRESS (0x0001) at 0x65737361+

I tried to find some help on the internet but nothing worked for now.

Fred

MacBook Pro, Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10 (120,060 points)
    Hi Fred, and a warm welcome to the forums!

    You mention Repairing Permissions, but did you try Verifying/Repairing the HD?

    When you Safe Booted it still wouldn't **** down?

    Have you tried making a new User in Accounts to see if they have the same problem?

    How much Free Space is on the HD?

    Do you have the part of the crash log starting with Thread xx crashed?
  • Carolyn Samit Level 10 Level 10 (95,985 points)
    Hello and Welcome to Apple Discussions ...

    To add to BDAqua's suggestions ...

    What you are experiencing is called a kernel panic. Usually just a reboot fixes this but if not... go here for help; http://www.thexlab.com/faqs/kernelpanics.html

    Carolyn
  • fffred Level 1 Level 1 (0 points)
    Thank you for your welcome and for your answers

    BDAqua >> I tried repairing the HD ; when I safe booted, it wouldn't shut down ; making a new user didn't solve the problem ; there is more than 20GB of free space on this HD.
    The log file shows :
    +Thread 0 Crashed:+
    +0 libobjc.A.dylib 0x90a584c7 objc_msgSend + 23+
    +1 com.apple.BezelServices 0x004d2b2b 0x4cf000 + 15147+
    +2 com.apple.BezelServices 0x004d193a 0x4cf000 + 10554+
    +3 com.apple.Foundation 0x9284ba50 __NSFireMachPort + 307+
    +4 com.apple.CoreFoundation 0x9083c2fd __CFMachPortPerform + 136+
    +5 com.apple.CoreFoundation 0x9082c5a1 CFRunLoopRunSpecific + 2904+
    +6 com.apple.CoreFoundation 0x9082ba42 CFRunLoopRunInMode + 61+
    +7 com.apple.HIToolbox 0x92df2878 RunCurrentEventLoopInMode + 285+
    +8 com.apple.HIToolbox 0x92df1f82 ReceiveNextEventCommon + 385+
    +9 com.apple.HIToolbox 0x92df1dd9 BlockUntilNextEventMatchingListInMode + 81+
    +10 com.apple.AppKit 0x93297f45 _DPSNextEvent + 572+
    +11 com.apple.AppKit 0x93297b37 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 137+
    +12 com.apple.AppKit 0x932918c4 -[NSApplication run] + 512+
    +13 com.apple.loginwindow 0x000056e1 0x1000 + 18145+
    +14 com.apple.loginwindow 0x000052a6 0x1000 + 17062+
    +15 com.apple.loginwindow 0x0001af35 0x1000 + 106293+

    Carolyn >> I am going to try your suggestion.

    Fred
  • Carolyn Samit Level 10 Level 10 (95,985 points)
    Hi Fred,

    Ok, let us know how it goes.

    Carolyn
  • fffred Level 1 Level 1 (0 points)
    I had a look on the link about Kernel panics, but it doesn't look like I'm having one of the mentionned issues. I already tried several of these solutions (in my first message) and the only thing left I can see is to use a tool like DiskWarrior which I don't have. Any other suggestion ?

    fred
  • BDAqua Level 10 Level 10 (120,060 points)
    Hi Fred,

    Try trashing that preference file and restarting and see if that fixes the problem.

    /Library/Preferences/com.apple.BezelServices.plist
  • fffred Level 1 Level 1 (0 points)
    It worked ! Thank you so much for your help.
    Fred