4 Replies Latest reply: Dec 1, 2008 4:45 PM by Qwikrex
rachinc Level 1 Level 1 (0 points)
a few days ago my computer wouldnt burn .mov files to blank dvds...and it kept giving me some error code 0x80020063

(mind you, i had this problem a YEAR ago with the ORIGINAL superdrive that came with my computer, and they suggested I replace it with a new one, and they were right, it fixed the problem).. okay so i've had this Pioneer superdrive for a year now... and its starting to give me the same error i got a year ago.

so i ordered a NEW superdrive (different brand because the pioneer one was sold out) and installed the NEW superdrive last night (brand: samsung). and it worked like a beauty. it let me burn mov files onto a blank dvd without any problems.

i started to burn another DVD today... and it gave me the same error that i was having a few days ago (with the OLD superdrive), but i wondered if it was because i had a program open that was trying to use the files that i was trying to burn.

so i quit the program. and pressed restart. and i tried to reburn the footage to a blank dvd to see if it gave me a similar error. and it did......

this isnt good. it wont let me burn .mov files to a DVD.

this is a BRAND NEW super drive that worked last night and now it doesnt work today.

what am i supposed to do? am i supposed to send this NEW one back and use the old one that doesnt burn DVDs either?

the old and new one have the same problem: sometimes they work, sometimes they don't... so it leads me to believe its a problem with my computer...

I dont know..i refuse to believe this day old super drive is defective.

the old DVD superdrive is only a year old, and this new super drive is only a Day old, and already gives me the same error that i was getting with the old super drive. (error code 0x80020063)

i got this superdrive from "Other World Computing." If I talk to them, they will tell me to contact the manufacturer, and the manufacturer will tell me to contact apple....i called apple for help, and they said my computer isn't covered any more under apple's care and protection plan so they can't help me without me paying $50 dollars.

OY!

and the STRANGE part is... if i'm using DVD studio pro, it'll let me burn a disc... if i'm using the software "fast dvd copy 4", it'll let me burn a disc...

but if i just throw in a blank dvd on the desktop and throw files on it and press burn, it gives me the error code.

the funny part is...even though it gives me an error that the disc couldnt burn, i look at the disc and inspect the properties on it, and everything is there. so it looks like it burned fine. so why am i getting this error???

_*tech support at Other World Computing said he thinks its a problem with my external hard drive (my lacie). and that the drive is probably fragmented and i need to defrag the computer and lacie, and that MIGHT work. he says you "film people" do horrendous things to your external hd. and use it to the maximum. even tho you do clean it out.*_

_*But basically he said i need to try 2 things:*_

_*the first thing to try:*_
_*try your OWC external harddrive, (not your lacie), and plug it in, and burn .mov files to a DVD from the OWC external hard drive. IF IT WORKS (THE BURNING, WITHOUT AN ERROR MESSAGE), then you know its a problem with your lacie. if the burning FAILS though with the OWC external hard drive then do this:*_

_*the second thing to try:*_
_*step 1) boot up from os disc, leopard disk*_
_*2) go into disc utility, and repair both external harddrive and computer hard drive, fix permissions*_
_*3) go online mac update.com, download program called iDefrag, let it run,*_

_*So i tested out burning from the OWC external hard drive and the result was: it burned successfully.*_

_*so that means its probably a problem with my terrabite lacie hard drive :(*_

_*gotta defrag it big time (WITH THE SOFTWARE DISC WARRIOR), or get a new one later.*_
Source(s):
_*macsales.com, macupdate.com, disc warrior*_

power mac g5, Mac OS X (10.5.5)
  • Jeff Johnson4 Level 2 Level 2 (185 points)
    Hi. I believe that I have found the cause of at least some of these 0x80020063 errors. The problem is the hidden .DS_Store file in the burn folder. This seems to be a Leopard bug; it started happening for me after I switched from Tiger to Leopard.

    If you launch "/Applications/Console.app" and look at "~/Library/Logs/DiskRecording.log", you may see something like this after the burn:

    Finder: Burn started, Fri Oct 31 14:11:42 2008
    Finder: Burning to DVD+RW (RICOHJPN W11) media with DAO strategy in MATSHITA DVD-R UJ-846 FB2U via ATAPI.
    Finder: Requested burn speed was 47x, actual burn speed is 4x.
    Finder: Burn finished, Fri Oct 31 14:16:08 2008
    Finder: Verify started, Fri Oct 31 14:16:08 2008
    Finder: Discrepancy in block 284 at byte 22.
    Finder: Source data: 0000 0010 0000 0801 0000 0000 0000 0000
    Finder: Burned data: 0000 0010 0000 8700 0000 0000 0000 0000
    Finder: Verify failed, Fri Oct 31 14:16:08 2008
    Finder: Verify error: 0x80020063 Verification of the burn failed.

    After much experimentation, I believe I've narrowed down the problem to the .DS_Store file. After you burn, compare the .DS_Store in the burn folder with the .DS_Store on the DVD.

    $ hexdump Untitled\ DVD.fpbf/.DS_Store
    0000000 00 00 00 01 42 75 64 31 00 00 10 00 00 00 08 00
    0000010 00 00 10 00 00 00 01 08 00 00 00 00 00 00 00 00

    $ hexdump /Volumes/2008-10-30/.DS_Store
    0000000 00 00 00 01 42 75 64 31 00 00 10 00 00 00 08 00
    0000010 00 00 10 00 00 00 00 87 00 00 00 00 00 00 00 00

    Notice that at the 23rd byte (22 if you start counting from 0, which programmers tend to do), you have "01 08" vs. "00 87". As this is a little-endian Intel machine, the bytes-order can be flipped, so you have "0801" vs "8700", which is exactly the discrepancy in the log.

    If you're comfortable with "/Applications/Terminal.app", the easiest way to work around this bug is to rm the .DS_Store file in the burn folder before you start the burn. Drag everything you want to the burn folder, close the burn folder, rm the .DS_Store, and then click the burn button in the Finder sidebar.

    It seems that the problem occurs when the burn folder window is changing in some way to during the burn, for example, if you close the window after starting to burn. If you're not comfortable with Terminal, I think the other workaround is to not touch the burn folder at all after starting to burn. Don't close it, don't move it, don't resize it. Switch to a different application, and don't touch Finder until the burn is complete.
  • Jeff Johnson4 Level 2 Level 2 (185 points)
    Note that even though the burn verification phase fails because of this .DS_Store discrepancy, your burned data may be ok. The Unix command-line tool cmp can do a byte-by-byte comparison of your original and burned files to see whether there are any discrepancies.
  • Fred Grieve Level 1 Level 1 (35 points)
    Thanks for this very full explanation, Jeff.

    However, I'm a bit puzzled as to how I can rm the .DS_Store file in the burn folder because when viewed in Terminal, my burn folder shows as a file, e.g. Burn Folder.fpbf

    I don't get the above error code. Mine is 0x8002006B but I'm trying to figure out what's going on. As one of the DVDs won't burn on a PC I suspect I may have a bad batch.
  • Qwikrex Level 1 Level 1 (0 points)
    I've been experiencing the same 0x80020063 error code as well when attempting to burn a DVD-R. If I close the burn folder window after starting a burn, the process fails verification. If I leave the burn folder open it seems to work. Any word on when an official fix will be ready? Oh and to clarify this is occurring on my brand new Aluminum 2.0ghz Macbook(stock specs except for 4gb ram upgrade)

    In addition, I've also noticed an issue with DVD+RW's. If I burn to a DVD+RW and then erase it's contents, when I eject it with the keyboard eject button, the disk icon stays on the desktop. Now with the same scenario, if i right click and eject the disk from the desktop the disk ejects from the drive and the icon disappears as it should. This only happens with DVD+RW's. I've tried DVD-RW's and they have no issue.